Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007445TestLinkTest Specificationpublic2016-02-25 18:502016-09-08 15:13
Reporteramccollough 
Assigned Tofman 
PrioritylowSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007445: Feature Request: Add Bulk Action capability at the Test Suite level to update contained Test Cases
DescriptionThis is a feature request. I did not see a category for "Test Suite" so I picked "Test Specification"

There is the ability to modify Status, Importance, Execution Type for a single Test Case by navigating to Test Specification > Test Suite > Test Case > Actions > Bulk Action.

It would be beneficial if one could make the same "Bulk actions" adjustment at the Test Suite level to all test cases within the suite. I could see navigating to Test Specification > Test Suite > Actions > *Bulk Action (does not yet exist)*

Use Case: I create a new suite, and add ten test cases to it; all of them being in "Draft" status. After a few edits on the test cases, I am happy with the results and wish to change the status on all cases to "Ready to Review".
Steps To ReproduceCreate a number of Test Cases without explicitly setting the Status. They will default to "Draft".

Attempt to change the Status on all the Test Cases by a bulk action.
Additional InformationI am using version 1.9.15 (Tauriel). I started out using the 1.9.14 version, from the Bitnami Stack, running on a local Windows 2008 R2 server. I upgraded manually from 1.9.14 to 1.9.15.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE 11
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0024538)
fman (administrator)
2016-02-25 21:42

>> There is the ability to modify Status, Importance, Execution Type for a single Test >>Case by navigating to Test Specification > Test Suite > Test Case > Actions > Bulk >>Action

There is no way to reproduce your steps because there is nothing like bulk action

If you explore carefully all operation available you will find that using operations at test suite level you will find test case table view that will allow you to set on a group of CHILDREN TEST CASES status & importance.

Please try, & provide feedback
(0024559)
amccollough (reporter)
2016-02-29 17:51

I see what you are talking about. Test Suite Operations > Test Cases table view. Check the boxes for desired cases, and click "Save".

Your suggested path works for me, and I would consider this issue closed. Thank you so much.
(0025279)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2016-02-25 18:50 amccollough New Issue
2016-02-25 21:36 fman QA Team - Task Workflow Status => TBD
2016-02-25 21:36 fman Severity minor => feature request
2016-02-25 21:42 fman Note Added: 0024538
2016-02-25 21:43 fman Assigned To => fman
2016-02-25 21:43 fman Status new => feedback
2016-02-29 17:51 amccollough Note Added: 0024559
2016-02-29 17:51 amccollough Status feedback => assigned
2016-02-29 18:07 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2016-02-29 18:07 fman Status assigned => resolved
2016-02-29 18:07 fman Fixed in Version => 1.9.14 (2015 Q3)
2016-02-29 18:07 fman Resolution open => fixed
2016-09-08 15:13 fman Note Added: 0025279
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker