Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007415TestLinkReports - Test report matrixpublic2016-01-19 02:162019-04-02 20:41
Reportersudheer41in 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformwindowsOSOS Version
Product Version 
Fixed in Version 
Summary0007415: Not able to export a specific testplan "test results matrix" to an excel file with error: "PHP Fatal error: Uncaught exception"
Descriptiontestlink 1.9.14 version.

The export of a particular testplan "Test results matrix" data to excel file, is failing.

PHP Fatal error: Uncaught exception 'Exception' with message 'Worksheet!I914 -> Formula Error: An unexpected error occured' in /var/www/testlink-1.9.14/third_party/codeplex/PHPExcel/Cell.php:288\nStack trace:\n#0 /var/www/testlink-1.9.14/third_party/codeplex/PHPExcel/Writer/Excel5/Worksheet.php(441): PHPExcel_Cell->getCalculatedValue()\n#1 /var/www/testlink-1.9.14/third_party/codeplex/PHPExcel/Writer/Excel5.php(171): PHPExcel_Writer_Excel5_Worksheet->close()\n#2 /var/www/testlink-1.9.14/lib/results/resultsTC.php(540): PHPExcel_Writer_Excel5->save('/var/www/testli...')\n#3 /var/www/testlink-1.9.14/lib/results/resultsTC.php(82): createSpreadsheet(Object(stdClass), Object(stdClass))\n#4 {main}\n thrown in /var/www/testlink-1.9.14/third_party/codeplex/PHPExcel/Cell.php on line 288
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome, Firefox
PHP Version5.5.30
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0024423)
fman (administrator)
2016-01-20 00:37
edited on: 2016-01-20 00:37

detailed for reproduce are not provided => no action will be done till info will not be provided as indicated on forum.testlink.org

providing testlink version when reporting is kindly requested to avoid waste of time

(0024425)
sudheer41in (reporter)
2016-01-20 00:49
edited on: 2016-01-20 00:50

It was provided when the issue is raised :-). It is 1.9.14

The export of "test results matrix" is working fine for most of the testplans, except one. The testplan for which export is failing is a big testplan compared to other ones.
Please let me know any other information is needed. Thanks a lot for looking into this.

(0024426)
fman (administrator)
2016-01-20 00:54

>> It was provided when the issue is raised :-). It is 1.9.14
false, and emoticon adds no value
You pretend that because you have provided the path I need to get the version from this info. This is not the way to work, just to do not use your time to set the combo version when reporting the issue.

Big means nothing , 10 is big ? 100 is big? 1000 is big?
and because you have not provided the info from start, we need to start a 'loop of notes'.

What I need ? very simple EXACT STEPS TO reproduce and this includes the same kind of test project and test plan structure with the same amount of test cases.
(0024432)
sudheer41in (reporter)
2016-01-22 01:12

Hi,
There are around 1680 entries.
Steps:
1) Click on "Reports and Metrics"
2) Choose the testplan (in our case, it is the testplan that has around 1680 entries)
3) click on "test results matrix"
4) Once the page is loaded, click on the icon (of excel), to export.
This is the step failing.

Once again, thanks for looking into the issue.
(0024433)
fman (administrator)
2016-01-22 01:53

a sample xml file to recreate your test spec and test plan is needed.
(0024440)
sudheer41in (reporter)
2016-01-25 23:20

HI,
It was not clear to me from your message, whether you are expecting me to provide the sample xml file or are you in the process of recreating the xml file? are you able to reproduce? Thanks.
(0024441)
fman (administrator)
2016-01-26 01:32

Please provide a sample xml file to recreate your test spec and test plan
(0024508)
anton7811 (reporter)
2016-02-09 14:30

I have the same issues.
In my case it is caused that some cells (execution notes) have value like this - '====== some text...'.
It tries to process this value as a formula and fails.

As a workaround I use the following changes:

$ diff /var/www/testlink-1.9.14/third_party/codeplex/PHPExcel/Cell.php /var/www/testlink-1.9.14/third_party/codeplex/PHPExcel/Cell.php.orig
280c280
< if ($this->_dataType == PHPExcel_Cell_DataType::TYPE_FORMULA and substr($this->getValue(), 0, 2) != '==') {
---
> if ($this->_dataType == PHPExcel_Cell_DataType::TYPE_FORMULA) {

- Issue History
Date Modified Username Field Change
2016-01-19 02:16 sudheer41in New Issue
2016-01-20 00:37 fman Note Added: 0024423
2016-01-20 00:37 fman Note Edited: 0024423 View Revisions
2016-01-20 00:37 fman Status new => feedback
2016-01-20 00:49 sudheer41in Note Added: 0024425
2016-01-20 00:49 sudheer41in Status feedback => new
2016-01-20 00:50 sudheer41in Note Edited: 0024425 View Revisions
2016-01-20 00:54 fman Note Added: 0024426
2016-01-20 00:55 fman Assigned To => fman
2016-01-20 00:55 fman Status new => feedback
2016-01-22 01:12 sudheer41in Note Added: 0024432
2016-01-22 01:12 sudheer41in Status feedback => assigned
2016-01-22 01:53 fman Note Added: 0024433
2016-01-22 01:54 fman Status assigned => feedback
2016-01-25 23:20 sudheer41in Note Added: 0024440
2016-01-25 23:20 sudheer41in Status feedback => assigned
2016-01-26 01:32 fman Note Added: 0024441
2016-01-26 01:32 fman Status assigned => feedback
2016-02-09 14:30 anton7811 Note Added: 0024508
2019-01-19 15:08 fman Status feedback => resolved
2019-01-19 15:08 fman Resolution open => unable to reproduce
2019-04-02 20:41 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker