Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007384TestLinkAPI - XMLRPCpublic2015-12-11 00:232016-09-08 15:13
Reporteranton7811 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSScientific LinuxOS Version7.1
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007384: Insufficient permission message on attempt to modify keywords using XMLRPC API
DescriptionUser account has project specific permissions to edit test cases and keywords but its global role is guest. Using WEB this user is able to assign/remove keywords for test case. But the same operation using XMLRPC API failed with message:
TLResponseError: 2010: User corresponding to Developer Key has insufficient rights to perform this action

Workaround: If I set global role the same as project specific then it works and user is able to modify keywords via API.

However I don't like an idea to use global roles instead of test project roles.
Steps To ReproduceI'm using TestLink-API-Python-client 0.6.2.
Call looks like this:
>>> import testlink
>>> tl = testlink.TestLinkHelper('http://mytestlink/lib/api/xmlrpc/v1/xmlrpc.php', [^] 'xxxxx').connect(testlink.TestlinkAPIClient)
>>> tl.addTestCaseKeywords({'PREFIX-123': ['keyword1', 'keyword2']})
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql (mariadb)
Browser
PHP Versionphp-5.4.16-36.el7_1.x86_64
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
child of 0007262closedfman Availables hot-fixes for 1.9.14 & How To get full fixed package from GitHub 

-  Notes
(0024353)
fman (administrator)
2015-12-14 19:04

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/8b9d8531ed8d928c2a3a89841c88932f1312e060 [^]
(0025300)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2015-12-11 00:23 anton7811 New Issue
2015-12-14 19:04 fman QA Team - Task Workflow Status => TBD
2015-12-14 19:04 fman Fixed in Version => 1.9.15 (2015 Q4)
2015-12-14 19:04 fman Note Added: 0024353
2015-12-14 19:05 fman Status new => resolved
2015-12-14 19:05 fman Resolution open => fixed
2015-12-14 19:05 fman Assigned To => fman
2015-12-14 19:05 fman Relationship added child of 0007262
2016-09-08 15:13 fman Note Added: 0025300
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker