Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007347TestLinkTest Specificationpublic2015-11-19 17:252019-04-02 20:41
Reportermedienwolf 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformfedoraOSlinuxOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version 
Summary0007347: Create Test Cases from Requirements fails (Migrated to 1.9.13 from 1.9.9) mb_* functions issue ?
DescriptionThe creation of test cases from requirements fails nowwith 1.9.13.

The user can get into the "create test cases from requirements" view and click on a requirement that should generate the test case, but then the screen goes white.

THe error log shows

_WARNING Division by zero - in /var/www/html/testlink-1.9.13/lib/requirements/reqCommands.class.php - Line 448

I verified that the previous mentioned fix in 1.9.13 is there, however still see this issue.


Fyi, not sure whether there were DB changes. We went from 1.9.9 to 1.9.13.
Any help is apprecated.
Steps To ReproduceCreate requirement spec with a couple requirement
Go to the create test cases form requirements view
Select a couple requirements
verify that the blank screen and error message appears.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browserchrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
related to 0007243new mb_strlen() is assumed but not neccessarily available in all php packages 

-  Notes
(0024277)
fman (administrator)
2015-11-20 19:47

1) 1.9.14 has been released, upgrade is a must
2) please test on FRESH install, and provide feedback, issue can be related to migration. DB SAMPLE is needed
(0024290)
fman (administrator)
2015-11-21 11:53

Tested on Tauriel, unable to reproduce
(0024299)
NOC (reporter)
2015-11-24 10:47

We had the same issue with 1.9.14: Created Requirements -> <Create Test Cases> -> Blank Screen and no created test cases.
(0024301)
fman (administrator)
2015-11-24 13:57

please do fresh install of latest code from github, retest and provide feedback
(0024310)
NOC (reporter)
2015-11-26 16:34

1. I investigated this issue in more detail today. I found out (httpd-log) that "mb_substr" was the cause which is not available in our system (CentOS). It seems that the corresponding package is not compiled into PHP in this distribution.

2. I had a similar problem with the third-party redmine-api (which uses mb_strlen).

3. Solution for me was to find a polyfill ("Mbstring") and wrap the needed static methods of Mbstring in global functions in custom.config.inc.php. Yes, not nice(!), but working.
(0024311)
fman (administrator)
2015-11-27 07:25

@NOC
Great!!
Thanks for details
I'm going to add check on FRESH install regarding mb_substr

- Issue History
Date Modified Username Field Change
2015-11-19 17:25 medienwolf New Issue
2015-11-20 19:47 fman Note Added: 0024277
2015-11-20 19:48 fman QA Team - Task Workflow Status => TBD
2015-11-20 19:48 fman Summary Create Test Cases from Requirements fails => Create Test Cases from Requirements fails (Migrated to 1.9.13 from 1.9.9)
2015-11-20 19:48 fman Assigned To => fman
2015-11-20 19:48 fman Status new => feedback
2015-11-21 11:52 fman Steps to Reproduce Updated View Revisions
2015-11-21 11:53 fman Note Added: 0024290
2015-11-24 10:47 NOC Note Added: 0024299
2015-11-24 13:57 fman Note Added: 0024301
2015-11-26 16:34 NOC Note Added: 0024310
2015-11-27 07:25 fman Note Added: 0024311
2015-11-28 17:35 fman Summary Create Test Cases from Requirements fails (Migrated to 1.9.13 from 1.9.9) => Create Test Cases from Requirements fails (Migrated to 1.9.13 from 1.9.9) mb_* functions issue ?
2015-12-31 17:33 fman Relationship added related to 0007243
2019-01-19 15:08 fman Status feedback => resolved
2019-01-19 15:08 fman Resolution open => unable to reproduce
2019-04-02 20:41 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker