Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007344TestLinkReq Overviewpublic2015-11-17 14:002016-09-08 15:13
Reporteratelman 
Assigned Tofman 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007344: DB Access Error by clicking on "Requirements Overview"
DescriptionDB Access Error by clicking on "Requirements Overview"
Steps To Reproduce - login to Testlink
 - go to specific project
 - click on "Requirements Overview"

Actual outcome:
 - DB Access Error by clicking on "Requirements Overview". But only for the one project

Expected outcome:
 - you can open "Requirements Overview"
Additional InformationThis behavior is since yesterday. The project was created few month ago and has a lot of test and requirements. But now we can not use "Requirements Overview"
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browserall browsers
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesjpg file icon not_ok_048.jpg [^] (243,664 bytes) 2015-11-17 14:00

- Relationships

-  Notes
(0024251)
fman (administrator)
2015-11-17 15:23

because 1.9.14 has been released, I only work on issues that user can reproduce on latest stable release => do 30 min test

fresh install of 1.9.14 on sandbox, retest and provide feedback
detailed to reproduce anyway are not enough => see guidelines on forum.testlink.org
(0024252)
patrick_g (reporter)
2015-11-17 16:00

This is a known issue which can happen with this old TL version.
Mantis ticket exists but I forgot the ID.
It happens when a requirement gets deleted using some pop-up window from TestLink. ( I think it hepens when clicking on a requirment in requirements overview and then delete the opened req.)
You need to undo the deletion somehow and it will work again.
Issue got fixed in newer TL version, but I guess the fix just prevents the error but will not cope with an already broken system.
(0024253)
fman (administrator)
2015-11-17 16:59

>> Issue got fixed in newer TL version, but I guess the fix just prevents the >>error but will not cope with an already broken system.
fix => fix error not that provide method to recover broken data
(0024254)
fman (administrator)
2015-11-17 16:59

@patrick_g
thanks for the hint and confirmation of fix on latest version
(0025308)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2015-11-17 14:00 atelman New Issue
2015-11-17 14:00 atelman File Added: not_ok_048.jpg
2015-11-17 15:23 fman Note Added: 0024251
2015-11-17 15:23 fman Assigned To => fman
2015-11-17 15:23 fman Status new => feedback
2015-11-17 16:00 patrick_g Note Added: 0024252
2015-11-17 16:59 fman Note Added: 0024253
2015-11-17 16:59 fman QA Team - Task Workflow Status => TBD
2015-11-17 16:59 fman Status feedback => resolved
2015-11-17 16:59 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-11-17 16:59 fman Resolution open => fixed
2015-11-17 16:59 fman Note Added: 0024254
2016-09-08 15:13 fman Note Added: 0025308
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker