Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007326TestLinkAPI - XMLRPCpublic2015-11-05 18:122016-09-08 15:13
Reporterghutchis 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007326: API - getTestSuiteByName => getTestSuite()
DescriptionI would like to be able to get a test suite ID using a name lookup, as at the point my script needs to do the call, the suite may not yet have been associated with a test plan. getTestSuiteByProject would also work acceptably.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0024203)
fman (administrator)
2015-11-05 18:29

one ticket => one request
then getTestSuiteByName() or getTestSuiteByProject() not both on one ticket

In addition requirement for getTestSuitByProject() has not been provided then there is no way other than guess to provide an answer from dev point of view.

In addition because TestSuite name can be used on different suites on different levels of test spec tree => this will not allow to get an unique answer
(0024204)
ghutchis (reporter)
2015-11-05 18:55

Request is really to get a test suite by something other than an ID (which is what I need) or a test plan (because it isn't in one yet). I have no idea of what the underlying structure of the DB and what is easy or difficult, which is why I listed alternatives. I do not need all alternatives implemented, although ByName would be consistent with other calls.

Returning multiple values is OK, I can easily sort through multiple results and find the correct one.
(0024206)
fman (administrator)
2015-11-06 06:56

>> I have no idea of what the underlying structure of the DB and what is easy or >>difficult, which is why I listed alternatives
again disagree you have you do a clear request because output of getTestSuiteByName() or getTestSuitesByTestProject() is very different.

You will not be able IMHO to get the right ID if you get an array of ID belonging to all test suites on a test project that have same name, if no other info like position (depth) in test spec tree will not be provided.
(0024213)
fman (administrator)
2015-11-07 09:03

new method getTestSuite()

/**
  * Returns all test suites inside target
  * test project with target name
  *
  * @param
  * @param struct $args
  * @param string $args["devKey"]
  * @param int $args["testsuitename"]
  * @param string $args["prefix"]
  * @return mixed $resultInfo
  *
  * @access public
  */
 

Please test and provide feedback
paypal donations are welcomed
(0024214)
fman (administrator)
2015-11-07 09:08

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/31bbc0cad74d4219e8ce78242a8b4e157cda3299 [^]

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/fab503c280e06be9613c321216db2d71dfabd91b [^]
(0025311)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2015-11-05 18:12 ghutchis New Issue
2015-11-05 18:26 fman QA Team - Task Workflow Status => TBD
2015-11-05 18:26 fman Summary Need call getTestSuiteByName => API - getTestSuiteByName
2015-11-05 18:29 fman Note Added: 0024203
2015-11-05 18:29 fman Status new => feedback
2015-11-05 18:55 ghutchis Note Added: 0024204
2015-11-05 18:55 ghutchis Status feedback => new
2015-11-06 06:56 fman Note Added: 0024206
2015-11-07 09:03 fman Note Added: 0024213
2015-11-07 09:03 fman Fixed in Version => 1.9.15 (2015 Q4)
2015-11-07 09:03 fman Summary API - getTestSuiteByName => API - getTestSuiteByName => getTestSuite()
2015-11-07 09:08 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-11-07 09:08 fman Note Added: 0024214
2015-11-07 09:08 fman Status new => resolved
2015-11-07 09:08 fman Resolution open => fixed
2015-11-07 09:08 fman Assigned To => fman
2016-09-08 15:13 fman Note Added: 0025311
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker