Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007259TestLinkTest Execute - 'Save and move to next'public2015-09-17 09:182015-11-27 07:24
ReporterBastienGT 
Assigned Tofman 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007259: Missing entire "Save Execution" are for 2nd and following assignees with the "tester" role
DescriptionWhen a test Case is assigned to multiple users with the Tester role, the whole section "Save Execution" section is missing (does not display at all) at the bottom of Test Case page for the 2nd and following users.
Steps To Reproduce1. Create a Project > a Test Plan > a Build > a Test Case.
2. Create 3 users with the following specifications (see Capture_1a/b/c.png):
 - Role: <no right>
 - Test Project Role: guest
 - Test Plan Role: tester
3. Assign Test Case Execution, assigning the Test Case to all the 3 testers (see Capture_2.png). Pay attention to the order users have been assigned the Test Case.
4. Login as 1st user, navigate to Execute Tests, select the Test Case in the tree, and scroll down to the bottom of the Test Steps page --> Save Execution area IS present (see Capture_3.png).
5. Now login as 2nd or 3rd user the Test Case has been assigned to, navigate to Execute Tests, select Test Case in the tree, scroll down to the bottom of the Test Steps page --> Save Execution area is MISSING (see Capture_4.png).
Additional InformationIt is temporarily possible to allow 2nd and 3rd users to view and use the "Save Execution" area by granting them the Leader or higher Test Plan role. This has the major drawback of allowing them to change test cases assignments and others stuffs for all users, which we don't want to allow to testers.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserAny
PHP Version5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Fileszip file icon Captures.zip [^] (493,859 bytes) 2015-09-17 09:18

- Relationships

-  Notes
(0023878)
fman (administrator)
2015-09-17 13:09

30 min test:
get latest code from github, do fresh install, retest & provide feedback
(0024034)
fman (administrator)
2015-09-27 09:47

no more user feedback
(0024309)
BastienGT (reporter)
2015-11-26 16:12

Issue fixed after system updated to 1.9.14

- Issue History
Date Modified Username Field Change
2015-09-17 09:18 BastienGT New Issue
2015-09-17 09:18 BastienGT File Added: Captures.zip
2015-09-17 13:09 fman Note Added: 0023878
2015-09-17 13:09 fman Assigned To => fman
2015-09-17 13:09 fman Status new => feedback
2015-09-27 09:47 fman QA Team - Task Workflow Status => TBD
2015-09-27 09:47 fman Note Added: 0024034
2015-09-27 09:47 fman Status feedback => closed
2015-09-27 09:47 fman Resolution open => unable to reproduce
2015-11-26 16:12 BastienGT Note Added: 0024309
2015-11-26 16:12 BastienGT Status closed => assigned
2015-11-26 16:12 BastienGT Resolution unable to reproduce => reopened
2015-11-27 07:24 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-11-27 07:24 fman Status assigned => closed
2015-11-27 07:24 fman Resolution reopened => fixed
2015-11-27 07:24 fman Fixed in Version => 1.9.14 (2015 Q3)



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker