Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007255TestLinkUsers and Rightspublic2015-09-15 08:562015-09-19 08:49
Reporterlble 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007255: Unable to create a platform with XMLRPC request if user has not "admin" role
Descriptionerror message when sending an XMLRPC request for creating a platform, if WMLRPC user has not "admin" role
Steps To Reproduce1- Create a new "Robot" role with following rights :

Test Plan :
 - Test Plan create/edit
 - Build create/edit
 - Test Plan planning
 - Test Plan execute
 - Test Plan metrics
 - Role assignment
 - Add/Remove Platforms

Platform :
 - Platform view (read only access)
 - Platform Management => this right should be sufficient

Test Case management
 - Test Case view (read only access)
 - Test Case create/edit

Custom field
 - Custom field view (read only access)
 - Custom field management


--------------------

2 - Create a new user "R2D2" and set its role as "Robot"

---------------------

3- Send a XMLRPC request to create a new platform with "R2D2"

=> KO

 XMLRPC response : "User corresponding to Developer Key has insufficient rights to perform this action- Details: right mgt_modify_product, test project id: 0, test plan id: " } }

Note : there is also a bug in return message, because the testproject id and the testplan id were found (in my case, Found project Id = 196915, Found testplan Id = 196916)

---------------------

4- Send again the same XMLRPC request to create a new platform with "admin" user
=> OK
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023857)
fman (administrator)
2015-09-15 08:57

30 min test:
get latest code from github, do fresh install, restest & provide feedback
(0023867)
lble (reporter)
2015-09-16 13:45

same behaviour with latest build (09-16-2015)

User corresponding to Developer Key has insufficient rights to perform this action- Details: right mgt_modify_product, test project id: 0, test plan id:
(0023870)
fman (administrator)
2015-09-16 21:51

Please retest using commit:
https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/3ea11b65e8bba76c6d69b27912873efba4828e9f [^]
(0023886)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-09-15 08:56 lble New Issue
2015-09-15 08:57 fman Note Added: 0023857
2015-09-15 08:58 fman Assigned To => fman
2015-09-15 08:58 fman Status new => feedback
2015-09-16 13:45 lble Note Added: 0023867
2015-09-16 13:45 lble Status feedback => assigned
2015-09-16 21:50 fman QA Team - Task Workflow Status => TBD
2015-09-16 21:50 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-09-16 21:51 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-09-16 21:51 fman Note Added: 0023870
2015-09-16 21:51 fman Status assigned => resolved
2015-09-16 21:51 fman Resolution open => fixed
2015-09-16 21:52 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023886
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker