Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007254TestLinkUsers and Rightspublic2015-09-15 08:522015-09-19 08:49
Reporterlble 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007254: Unable to create a testplan with XMLRPC request without "Test Project management" right
DescriptionIt's impossible to create a testplan by XMLRPC if the user role has not the "Test Project management" right enabled
Steps To Reproduce1- Create a new "Robot" role with following rights :

Test Plan :
 - Test Plan create/edit => this right should be sufficient
 - Build create/edit
 - Test Plan planning
 - Test Plan execute
 - Test Plan metrics
 - Role assignment
 - Add/Remove Platforms

Platform :
 - Platform view (read only access)
 - Platform Management

Test Case management
 - Test Case view (read only access)
 - Test Case create/edit

Custom field
 - Custom field view (read only access)
 - Custom field management


--------------------

2 - Create a new user "R2D2" and set its role as "Robot"

---------------------

3- Send a XMLRPC request to create a new testplan with "R2D2"

=> KO

 XMLRPC response : "User corresponding to Developer Key has insufficient rights to perform this action- Details: right mgt_modify_product, test project id: 196915, test plan id: "


---------------------
4- Enable the "Test Project management" right in "Robot" role and send the same XMLRPC request again => OK
Additional InformationOur XMLRPC bot must not have the "Test Project management" right, because it must not perform actions out of its testproject (like a testproject creation)

Our bot has a "guest" role for all testproject, and the "robot" role for only some projects
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0023856)
fman (administrator)
2015-09-15 08:57

30 min test:
get latest code from github, do fresh install, restest & provide feedback
(0023868)
lble (reporter)
2015-09-16 13:46

works correctly on latest build (09-16-2015)
(0023887)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-09-15 08:52 lble New Issue
2015-09-15 08:57 fman Note Added: 0023856
2015-09-15 08:57 fman Assigned To => fman
2015-09-15 08:57 fman Status new => feedback
2015-09-16 12:49 lble Note Added: 0023866
2015-09-16 12:49 lble Status feedback => assigned
2015-09-16 13:03 lble Note Deleted: 0023866
2015-09-16 13:46 lble Note Added: 0023868
2015-09-16 14:49 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-09-16 14:49 fman Status assigned => resolved
2015-09-16 14:49 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-09-16 14:49 fman Resolution open => fixed
2015-09-16 14:50 fman Additional Information Updated View Revisions
2015-09-19 08:49 fman Note Added: 0023887
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker