Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007250TestLinkRequirement Managementpublic2015-09-11 06:422016-09-08 15:13
ReporterJaini 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows8OS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007250: Requirement View (Read only access) given you user doesnt work as expected
DescriptionLog in as admin and assign Requirement view (read only access)to the role A.
Assign Role A to user B
Log in as user Bs to whom you have assigned this Role A.
On home page, Requirement Specification link is present.
On click of that, it doesn't lead user to folder tree structure but refreshes the home page.
Expected : It should lead user B to requirement folder structure where requirements are added but should not provide any edit option
Steps To ReproduceLog in as admin and assign Requirement view (read only access)to the role A.
Assign Role A to user B
Log in as user Bs to whom you have assigned this Role A.
On home page, Requirement Specification link is present.
On click of that, it doesn't lead user to folder tree structure but refreshes the home page.
TagsRequirements, RIGHTS
Database (MySQL,Postgres,etc)MySQL
BrowserIE, Chrome, Firefox
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Testlink-Admin.png [^] (44,335 bytes) 2015-09-29 08:12

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023840)
fman (administrator)
2015-09-11 19:40

1) Reporter does not need to monitor his/her own issues
2) 30 min test:
get latest code from github, do fresh install, retest & provide feedback
(0023858)
Jaini (reporter)
2015-09-15 10:20

We have large chunk of data added in TestLink. Is there any way to upgrade the existing testlink with latest package? We have used bitnami version of testlink.

Apart from mysql dump, any other config files need to be backed up?
(0023859)
fman (administrator)
2015-09-15 14:01

When asking for a fresh install what is supposed is that you will create just a Test env.
To do a migration/update you have to follow instructions present on FORUM and on README of TestLink installation.
(0023865)
Jaini (reporter)
2015-09-16 12:32

We have installed the latest version available but still the issue exists.
(0023869)
fman (administrator)
2015-09-16 14:51

>> We have installed the latest version available but still the issue exists.
this info is MISLEADING, confirm you have used latest code from github
(0023880)
fman (administrator)
2015-09-17 19:55

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/8cdb18f948150639753d3a224f6cb4c153dd3280 [^]
(0023996)
fman (administrator)
2015-09-22 16:58

very good => marked as urgent ZERO Feedback
(0023997)
fman (administrator)
2015-09-22 16:59

no more user feedback
(0024057)
Jaini (reporter)
2015-09-29 08:12

Thank you for the updates. Regret to let you know that We have taken the latest code as per your suggestion and have done the installation. The issue still exist. Could you please check at your end?
(0024081)
Jaini (reporter)
2015-10-05 09:51

Hi,
Any updates on this? we have installed the latest code and the issue is still there.
(0024082)
fman (administrator)
2015-10-05 11:14

1) Support is offered on best effort basis => there is no ETA
2) You have never answer in a CLEAR way my question regarding version.
would you mind to provide a DETAILED ANSWER?
(0024083)
Jaini (reporter)
2015-10-05 11:19

1) Agreed and understand your point. Since it was marked resolved, the question/note was asked/added.
2) I have mentioned in the earlier post that we have taken the code from https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/8cdb18f948150639753d3a224f6cb4c153dd3280 [^]
and the version detail is attached as part of screenshot which is 1.9.14. In this version of TestLink the issue is still present. Please let me know if you need any other details.
(0024262)
fman (administrator)
2015-11-18 15:00

Monitoring a resolved issue is IMHO something that has no value => I will remove always
(0025307)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2015-09-11 06:42 Jaini New Issue
2015-09-11 06:43 Jaini Tag Attached: Requirements
2015-09-11 06:43 Jaini Tag Attached: RIGHTS
2015-09-11 19:40 fman Note Added: 0023840
2015-09-11 19:40 fman Assigned To => fman
2015-09-11 19:40 fman Status new => feedback
2015-09-15 10:20 Jaini Note Added: 0023858
2015-09-15 10:20 Jaini Status feedback => assigned
2015-09-15 14:01 fman Note Added: 0023859
2015-09-15 14:01 fman Status assigned => feedback
2015-09-16 12:32 Jaini Note Added: 0023865
2015-09-16 12:32 Jaini Status feedback => assigned
2015-09-16 14:51 fman Note Added: 0023869
2015-09-16 18:18 fman Status assigned => feedback
2015-09-17 19:54 fman Relationship added child of 0006830
2015-09-17 19:54 fman QA Team - Task Workflow Status => TBD
2015-09-17 19:55 fman Note Added: 0023880
2015-09-22 16:58 fman Note Added: 0023996
2015-09-22 16:59 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-09-22 16:59 fman Note Added: 0023997
2015-09-22 16:59 fman Status feedback => closed
2015-09-22 16:59 fman Resolution open => fixed
2015-09-22 16:59 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-09-29 08:12 Jaini Note Added: 0024057
2015-09-29 08:12 Jaini Status closed => assigned
2015-09-29 08:12 Jaini Resolution fixed => reopened
2015-09-29 08:12 Jaini File Added: Testlink-Admin.png
2015-09-29 18:36 fman Status assigned => resolved
2015-09-29 18:36 fman Resolution reopened => fixed
2015-10-05 09:51 Jaini Note Added: 0024081
2015-10-05 11:14 fman Note Added: 0024082
2015-10-05 11:19 Jaini Note Added: 0024083
2015-10-28 12:13 Jaini Note Added: 0024173
2015-10-28 12:13 Jaini Status resolved => assigned
2015-10-28 12:13 Jaini Resolution fixed => reopened
2015-10-28 20:25 fman Note Deleted: 0024173
2015-10-28 20:40 fman Status assigned => resolved
2015-10-28 20:40 fman Fixed in Version 1.9.14 (2015 Q3) => 1.9.15 (2015 Q4)
2015-10-28 20:40 fman Resolution reopened => fixed
2015-11-18 15:00 fman Note Added: 0024262
2016-09-08 15:13 fman Note Added: 0025307
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker