Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007234TestLinkDatabase Generalpublic2015-08-14 11:432015-09-21 12:03
Reporteranushajoisa 
Assigned Tofman 
PriorityhighSeverityblockReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformWindowsOSWindowsOS VersionServer 2012 R2
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007234: Test Projects disappear from Testlink UI but remain in the database
DescriptionTwice this week, one of our test project disappeared from the Testlink Web UI. They were no longer listed in "Test Project Management" and no longer listed in the project selection combo box. However, when I look at the contents of the 'testprojects' table in the database, I can see that the entry for this particular project is still there.
The value of 'id' for this test project is '1'.
In the tables nodes_hierarchy, I can see test cases, test suites and test plans belonging to this test project, but the entry of the test project name is missing in nodes_hierarchy.
When I check the output of the query "SELECT * FROM nodes_hierarchy WHERE parent_id IS NULL", the netry for this project is missing.
Steps To ReproduceI do not know how this can be reproduced.
Additional InformationI have seen the ticket 0007041, but there is no update on the same.
We have seen this issue twice this week. After it happened the first time, we restored backup we had of the database. Three days after, we have noticed the same issue again.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0023747)
fman (administrator)
2015-08-14 11:59

you have to get latest code from github, do fresh install, retest & provide feedback
(0023749)
anushajoisa (reporter)
2015-08-14 12:03
edited on: 2015-08-14 12:04

Will replacing all the codes with the latest codes from github be sufficient? Ours is a production setup with lot of data in the database.

(0023751)
fman (administrator)
2015-08-14 12:07

You have to create a BACKUP OF YOUR DB and create A PLAYGROUND environment, at least for me this is obvious way to avoid issues
(0023754)
rajesh.raman (reporter)
2015-08-14 12:57

I don't think its a good idea to take the latest code and check if its fixes the issues as we don't know the steps to reproduce.

As we have already installed the latest current stable version of TestLink version (1.9.13) last week itself, do you think you have given something which can fix the current issue?

Upgrading to latest version always is not suggested as its irrelevant to understand the issue and fix the same.

Please suggest on ways we can look at reproducing the issue and how we can get the fix for it. Hope you can understand the context here.
(0023757)
fman (administrator)
2015-08-14 18:24

>> I don't think its a good idea to take the latest code and check if its fixes the issues as we don't >>know the steps to reproduce.
Other people has reported similar issues and have been fixes on latest code, you can check this info doing some searches on issues.
A good starting point as suggested on each README ob each TestLink installation is the TICKET
Availables hot-fixes for X.Y.ZZ & How To get full fixed package from GitHub

Latest available code and latest released version are two different things.
Latest available code contains all things fixed and all new features since latest release.
That's why i strongly advice always this approach.

Then is your choice how to proceed.
(0023758)
fman (administrator)
2015-08-14 18:26

regarding
>> I have seen the ticket 0007041, but there is no update on the same.
what update you expect if reporter was not willing to collaborate?
(0023760)
rajesh.raman (reporter)
2015-08-15 06:56

sure we will try to update to latest hot fix available for 1.9.13 and update you. Thanks for the quick reply.
(0023766)
anushajoisa (reporter)
2015-08-17 05:02

We have two systems with TestLink 1.9.13 installed, one for production and the other for testing. We have observed this issue in the production setup. We will apply the hot fixes and test and let you know.
(0023776)
anushajoisa (reporter)
2015-08-18 08:38

Hi Fman,

I downloaded the latest code from Github link mentioned in the ticket http://mantis.testlink.org/view.php?id=6830. [^]

I went through the README and CHANGELOG files in this package and saw that whatever tickets (139t tickets) have been fixed are part of the CHANGELOG in our 1.9.13 TestLink installation.

Could you please let me know if there is an easy way to cherry pick only the fixes done in 1.9.13 since the time it was released and incorporate them in our current installation?

Thanks,
Anusha
(0023778)
fman (administrator)
2015-08-18 08:54

Please just follow my advice blindly i.e get latest code from github and do fresh install
You are not understanding that some files are ONLY UPDATED when things are released because updating it before is useless, this is what happens to README and CHANGELOG

You are not following my advices, and this means that I need to use a lot of additional time with you (time that I have not have).

GIVE A LOOK TO INDICATION ON README FILE PRESENT ON stable release you have downloaded from sourcefore and READ CAREFULLY EXPLANATION ABOUT getting latest fixes.

Your coworkerd has said
>> sure we will try to update to latest hot fix available for 1.9.13 and update >>you. Thanks for the quick reply.
this task has been done ?
why you continue to ask for confirmation before doing a thing?
if you need this kind of support you need to pay for it.
(0023827)
anushajoisa (reporter)
2015-09-02 04:50

Hi Fman,

I have found out a probable cause of this issue. We use TestLink python APIs function 'updateTestCase()' to modify the execution type of a test case and the execution type of every step of the test case as well.

1. What I observed is that if updateTestCase() function is called with the test case external ID, execution type and steps (list of elements where each element is a hash with following keys: step_number,actions,expected_results,execution_type) as arguments, the entry for the test project with ID '1' gets deleted from the table nodes_hierarchy, and hence this project is not seen in the TestLink UI.

2. But if I call updateTestCase() function with only the test case external ID and execution type as arguments, the project entry is intact in nodes_hierarchy and the project does not disappear from the UI.

I am able to reproduce this consistently in our test environment.

Thanks,
Anusha
(0023829)
fman (administrator)
2015-09-02 12:13

Thanks for info but i still need help for your side .
You need to do what i have requested in my previous note.
Without this feedback i will ignore and close this issue in 5 working days.

Unfortunately you are not providing requested help, but only pressing for a solution
(0023831)
anushajoisa (reporter)
2015-09-03 10:02

Hi Fman,

Thank you for your suggestion. But performing a fresh install on our setup is a costly process. It would be great if you can help us with this issue with the APIs. Or if you can point me to the scripts where the fix was done, we can replace those scripts and test. We would really like to help here with this.

Thanks,
Anusha

- Issue History
Date Modified Username Field Change
2015-08-14 11:43 anushajoisa New Issue
2015-08-14 11:59 fman Note Added: 0023747
2015-08-14 12:03 anushajoisa Note Added: 0023749
2015-08-14 12:04 anushajoisa Note Edited: 0023749 View Revisions
2015-08-14 12:07 fman Note Added: 0023751
2015-08-14 12:07 fman Assigned To => fman
2015-08-14 12:07 fman Status new => feedback
2015-08-14 12:57 rajesh.raman Note Added: 0023754
2015-08-14 18:24 fman Note Added: 0023757
2015-08-14 18:25 fman QA Team - Task Workflow Status => TBD
2015-08-14 18:25 fman Additional Information Updated View Revisions
2015-08-14 18:26 fman Note Added: 0023758
2015-08-14 18:27 fman Priority immediate => high
2015-08-15 06:56 rajesh.raman Note Added: 0023760
2015-08-17 05:02 anushajoisa Note Added: 0023766
2015-08-17 05:02 anushajoisa Status feedback => assigned
2015-08-18 08:38 anushajoisa Note Added: 0023776
2015-08-18 08:54 fman Note Added: 0023778
2015-08-18 08:54 fman Status assigned => resolved
2015-08-18 08:54 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-08-18 08:54 fman Resolution open => fixed
2015-09-02 04:50 anushajoisa Note Added: 0023827
2015-09-02 12:13 fman Note Added: 0023829
2015-09-02 13:21 IronFritz Note Added: 0023830
2015-09-02 13:38 IronFritz Note Deleted: 0023830
2015-09-03 10:02 anushajoisa Note Added: 0023831
2015-09-03 12:02 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker