Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007227TestLinkTest Spec. - Test Case Stepspublic2015-08-11 08:322015-09-19 08:49
Reporterquartoxuna 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007227: Reordering Steps results in error message
DescriptionWhen reordering steps, a javascript alert message pops up "Step numbers must be unique".
Steps To Reproduce- Create a testcase with some steps (1,2,3,4)
- Try to reorder some steps (1,2,4,3)
Additional InformationI think the problem is the check itself, becaus usually you leave some step numbers as they are, resulting in non-unique steps numbers.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 33.0
PHP Version5.4.35
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0023732)
fman (administrator)
2015-08-11 09:10

1) please check for similar issue, removing status filter
2) get latest code from github, do fresh install, retest and provide feedback.
(0023797)
quartoxuna (reporter)
2015-08-25 09:40

Was fixed in commit
  1546e0bc86fd93d5226a52bbb84be1c7ac8be57e
in branch testlink_1_9.

Can be set to invalid. Thanks! :-)
(0023895)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-08-11 08:32 quartoxuna New Issue
2015-08-11 09:10 fman Note Added: 0023732
2015-08-11 09:10 fman Assigned To => fman
2015-08-11 09:10 fman Status new => feedback
2015-08-25 09:40 quartoxuna Note Added: 0023797
2015-08-25 09:40 quartoxuna Status feedback => assigned
2015-08-25 11:43 fman QA Team - Task Workflow Status => TBD
2015-08-25 11:43 fman Status assigned => resolved
2015-08-25 11:43 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-08-25 11:43 fman Resolution open => fixed
2015-09-19 08:49 fman Note Added: 0023895
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker