Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007224TestLinkAssign Test Case Executionpublic2015-08-10 09:432015-09-19 08:49
Reportersprosper 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007224: GITHUB CODE - Mail not sent in test case assignment when BULK MODE IS USED
DescriptionUsing TestLink 1.9.14 [DEV] (Padawan)
 
Taken on 23/06/2015.

In test case assignment window, flagging checkbox to 'Send mail notification to sender' and than assigning test case clicking on 'Save' button give the message:

"You must provide at least one recipient email address. PROBLEMS SENDING MAIL TO:
Mailer Error: You must provide at least one recipient email address."

Despite of the user having correct mail configured and no mail is sent.

See attached screenshot

Note:

I have mail smtp server configured correctly and was able to send to the same user a mail in other context!
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon errorSendMailToTester.jpg [^] (260,209 bytes) 2015-08-10 09:43


jpg file icon noMailOnAssign_Firefox.jpg [^] (419,607 bytes) 2015-09-01 14:40
jpg file icon yesMailOnAssign_Explorer.jpg [^] (376,592 bytes) 2015-09-01 14:40

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023706)
fman (administrator)
2015-08-10 09:53

>> Despite of the user having correct mail configured and no mail is sent.
this info is not enough
You need to provide a detailed example with users involved and with configuration of each user
(0023710)
sprosper (reporter)
2015-08-10 10:25

You can easily reproduce with any configuration assigning test case to an user.
Anyway I have reproduced assigning a test case to admin as you can see in the attached screenshot.
I don't think it can be a configuration problem.
Consider that in the same scenario if you assign the test case to the same user, while you're assigning the test case to a test plan, mail is sent correctly.

Stefano
(0023711)
fman (administrator)
2015-08-10 10:29

Please avoid the typical sentence 'You can easily reproduce', this provide no value, and seems to say that developer is an stupid.

>> Anyway I have reproduced assigning a test case to admin as you can see in the >>attached screenshot
>> I don't think it can be a configuration problem.
This can be OK if you plan to solve the issue by yourself, if not please provide requested information. This is the way to work in order to be sure we both are using SAME SCENARIO. (realy this is the ONLY way to work)



>> Consider that in the same scenario if you assign the test case to the same >>user, while you're assigning the test case to a test plan, mail is sent >>correctly.
Unfortunately you did not provide this info before
(0023714)
fman (administrator)
2015-08-10 10:32

waiting for requested details
(0023723)
fman (administrator)
2015-08-10 18:19

Tested on latest code from github => worked OK
(0023823)
sprosper (reporter)
2015-09-01 14:39

Hi,

I finally realized why still not working to me.

It is because of the used browser:

I have tested right now with Firefox 40.0.3 and have reproduced the same error first reported, while doing the same operation with Explorer 11, it's working fine.
I'm going to attach a pair of screenshots showing how the related components in the page involved seem to be managed differently in the 2 cases, causing 'no user selection' in the firefox one.

Let me know if you need further details.

Thank you.

Stefano.
(0023824)
sprosper (reporter)
2015-09-01 14:53

WARNING:

I did the selection reported in

http://mantis.testlink.org/file_download.php?file_id=4280&type=bug [^]

first selecting the user under 'Bulk user assignment' and than clicking on 'DO' button, with related test case selected.

The case in which you do the selection directly for the single test case works fine.

Stefano
(0023825)
fman (administrator)
2015-09-01 15:07

On IE Jquery plugin for multiselect seems not to be loaded.
(0023826)
sprosper (reporter)
2015-09-01 15:09
edited on: 2015-09-01 15:11

Hi,

sorry I realized only now:
The real difference from work and not work cases is the use of 'Bulk user assignment' or not.

With Explorer the 'Bulk user assignment' seems to not work and this is probably a different bug, so I tested with success only because I did the assign directly on the single test case.

Stefano

(0023834)
fman (administrator)
2015-09-08 13:50

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/271df6d74c2cf034f344c90b0435bdbf5989c8aa [^]
(0023891)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-08-10 09:43 sprosper New Issue
2015-08-10 09:43 sprosper File Added: errorSendMailToTester.jpg
2015-08-10 09:53 fman Note Added: 0023706
2015-08-10 09:53 fman Assigned To => fman
2015-08-10 09:53 fman Status new => feedback
2015-08-10 10:25 sprosper Note Added: 0023710
2015-08-10 10:25 sprosper Status feedback => assigned
2015-08-10 10:29 fman Note Added: 0023711
2015-08-10 10:32 fman Note Added: 0023714
2015-08-10 10:32 fman Status assigned => feedback
2015-08-10 18:19 fman Note Added: 0023723
2015-08-10 18:19 fman QA Team - Task Workflow Status => TBD
2015-08-10 18:19 fman Status feedback => closed
2015-08-10 18:19 fman Resolution open => unable to reproduce
2015-08-10 18:19 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-09-01 14:39 sprosper Note Added: 0023823
2015-09-01 14:39 sprosper Status closed => assigned
2015-09-01 14:39 sprosper Resolution unable to reproduce => reopened
2015-09-01 14:40 sprosper File Added: noMailOnAssign_Firefox.jpg
2015-09-01 14:40 sprosper File Added: yesMailOnAssign_Explorer.jpg
2015-09-01 14:53 sprosper Note Added: 0023824
2015-09-01 15:07 fman Note Added: 0023825
2015-09-01 15:09 sprosper Note Added: 0023826
2015-09-01 15:11 sprosper Note Edited: 0023826 View Revisions
2015-09-08 11:58 fman Status assigned => acknowledged
2015-09-08 13:49 fman Summary GITHUB CODE - Mail not sent in test case assignment => GITHUB CODE - Mail not sent in test case assignment when BULK MODE IS USED
2015-09-08 13:50 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-09-08 13:50 fman Note Added: 0023834
2015-09-08 13:50 fman Status acknowledged => resolved
2015-09-08 13:50 fman Resolution reopened => fixed
2015-09-08 15:34 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023891
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker