Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007209TestLinkAPI - XMLRPCpublic2015-07-31 19:392015-09-19 08:49
Reporterlczub 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007209: reportTCResult - optional parameter to provide execution duration
Descriptionthe attachment xmlrpc.class.mod.php includes modifications for
- protected function _insertResultToDB
- protected function _updateResult
which allows the user to set or update the execution_duration of a test case execution with the xmlrpc api method reportTCResult, using a new optional parameter 'execution_duration'

TagsNo tags attached.
Database (MySQL,Postgres,etc)psql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon xmlrpc.class.mod.php [^] (8,730 bytes) 2015-07-31 19:39

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023666)
fman (administrator)
2015-08-01 08:31
edited on: 2015-08-01 09:00

thanks for contrib.
1) need to be refactored to be in line with our design
2)please next time check latest code because on github there is already a version where the
estimatedexecduration has been defined, and your definition is different => will be replaced with our => public static $executionDurationParamName = "execduration";

just to maintain same naming convention

(0023667)
fman (administrator)
2015-08-01 09:01

please get code from github, retest and provide feedback
(0023668)
fman (administrator)
2015-08-01 09:02

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/98b456308d05b33e955b2f8219824ce412814955 [^]
(0023670)
lczub (reporter)
2015-08-01 18:27

retest commit 98b4563 passed
- call reportTCResult without parameter execduration -> no execution_duration is set - ok
- call reportTCResult with parameter execduration=5.1 -> execution_duration is set with value 5.1 - ok
(0023671)
fman (administrator)
2015-08-01 20:03

thanks for helping with tests
(0023901)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-07-31 19:39 lczub New Issue
2015-07-31 19:39 lczub File Added: xmlrpc.class.mod.php
2015-08-01 08:31 fman Note Added: 0023666
2015-08-01 08:36 fman Note Edited: 0023666 View Revisions
2015-08-01 08:38 fman Note Edited: 0023666 View Revisions
2015-08-01 09:00 fman Note Edited: 0023666 View Revisions
2015-08-01 09:00 fman QA Team - Task Workflow Status => TBD
2015-08-01 09:00 fman Summary reportTCResult - optional parameter execution_duration => reportTCResult - optional parameter to provide execution duration
2015-08-01 09:01 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-08-01 09:01 fman Note Added: 0023667
2015-08-01 09:01 fman Assigned To => fman
2015-08-01 09:01 fman Status new => feedback
2015-08-01 09:02 fman Relationship added child of 0006830
2015-08-01 09:02 fman Note Added: 0023668
2015-08-01 18:27 lczub Note Added: 0023670
2015-08-01 18:27 lczub Status feedback => assigned
2015-08-01 20:03 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-08-01 20:03 fman Note Added: 0023671
2015-08-01 20:03 fman Status assigned => resolved
2015-08-01 20:03 fman Resolution open => fixed
2015-09-19 08:49 fman Note Added: 0023901
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker