Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007201TestLinkTest Plan - Add/Remove Test Casespublic2015-07-21 16:072015-09-19 08:51
ReporterChristophW 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.11 (2014 Q2 - bug fixing) 
Summary0007201: Testplan with many test cases - custom fields not saved
DescriptionThe text of custom fields is not saved in case of using a test plan with too much test cases.

I'm using a test plan with 193 test cases. There is one custom field which is enabled on test plan design. When I try to save a text in the custom fields this is working for the first 164 test cases. When I try to add a text to the custom field of test case 165 (or larger) the value of the custom field is not saved.

(used Version is 1.9.14)
Steps To Reproduce1) create custom field (type=text area, enabled on test plan design).
2) create test plan and add more than 165 test cases.
3) Add/Remove Testcases -> Try to enter a text in the custom field to all the test cases. Press "Save Custom Fields" button.

Check if the entered text is stored in ALL custom fields.
Additional InformationIt seems to be a problem that the value of the custom field is not stored to the database (and not a problem of the GUI). Using a tool connected to the API doesn't recognizes any text after the failed storage of the custom field.

TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome or InternetExploerer
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Fileslog file icon logsuserlog2.log [^] (891,573 bytes) 2015-07-22 06:09

- Relationships

-  Notes
(0023642)
fman (administrator)
2015-07-26 17:43

Check if you have followed instructions on README file provided with each distribution, regarding changes to be done on php.ini.

2. Release notes / CRITIC Configuration Notes

then please provide feedback
(0023646)
ChristophW (reporter)
2015-07-27 06:12

Hello,

increased the value of the variable max_input_vars.

Now the issue is resolved.

THANK YOU VERY MUCH FOR YOUR SUPPORT!!!
(0023649)
fman (administrator)
2015-07-27 19:35

great! If you find TestLink useful think about a donation to support this work

- Issue History
Date Modified Username Field Change
2015-07-21 16:07 ChristophW New Issue
2015-07-22 06:09 ChristophW File Added: logsuserlog2.log
2015-07-26 17:43 fman Note Added: 0023642
2015-07-26 17:43 fman Assigned To => fman
2015-07-26 17:43 fman Status new => feedback
2015-07-27 06:12 ChristophW Note Added: 0023646
2015-07-27 06:12 ChristophW Status feedback => assigned
2015-07-27 19:35 fman Note Added: 0023649
2015-07-27 19:37 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-07-27 19:37 fman Status assigned => resolved
2015-07-27 19:37 fman Fixed in Version => 1.9.11 (2014 Q2 - bug fixing)
2015-07-27 19:37 fman Resolution open => fixed
2015-09-19 08:51 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker