Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007187TestLinkTest Specification Importpublic2015-07-07 17:112015-09-19 08:49
Reporterssallmen 
Assigned Tofman 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSRed Hat Enterprise Linux ServerOS Version6.5
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007187: TestLink installation unusable after importing a test case
DescriptionIn test specification view, when importing a test case (from an XML) with import configuration which should update the existing test cases with the same external id causes the TestLink installation to become unusable. After login the screen is mostly empty, only logout and My Settings options are available. No projects seen in the drop down menu on the right.
Steps To Reproduce1. Create new test project and select that as the one to be used
2. Go to Test Specification
3. Select the empty root (test project) on the left frame
4. Click actions icon on the right frame to open the Test Suite operations
5. Click Import icon
6. Set the following import settings:
File type=XML
Consider Test Case as duplicate if=has same External ID
Action for duplicates=Update data on Latest version
7. Choose the XML file containing the test suites and test case to be imported.
8. Click Upload file-button
9. Check that the import was ok and the test case can be seen
10. In Test Specification view, select again the root (test project)
11. Repeat steps 4-8, with exactly the same or modified XML-file
12. TestLink reports the import as ok but look at the test cases on the left frame after it has refreshed. No test cases can be seen anymore.
13. Go to the Dashboard and see the almost empty screen.
Additional InformationWhen in import configuration setting "Action for duplicates" is set to "Create a new version" all is ok and new version of the test case is created successfully.
Attached is a Word-file with screenshots of the steps and the content of the XML-file.
I will try to add also the diff (in patch format) of the database dumps before and after the second import by commenting this report since only one attachment is allowed during reporting. Also some other files are available in case they are helpful to solve the problem:
- Full database dumps (SQL-files) before and after the second import
- Contents of the templates_c directory after the second import
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL Distrib 5.6.16, for Linux (x86_64)
BrowserChrome 43.0.2357.130 m
PHP Versionto be asked
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesdocx file icon screenshots.docx [^] (769,338 bytes) 2015-07-07 17:11
patch file icon testlinkdb_20150707-BADROBOT.patch [^] (15,644 bytes) 2015-07-07 17:12 [Show Content]
xml file icon testlink_testcase_import_bug_repro.xml [^] (1,708 bytes) 2015-07-07 17:13
html file icon phpinfo.html [^] (159,678 bytes) 2015-07-07 17:29
bz2 file icon testlinkdb_20150707-180716-before.sql.bz2 [^] (6,572 bytes) 2015-07-08 06:56
bz2 file icon testlinkdb_20150707-180944-after.sql.bz2 [^] (6,888 bytes) 2015-07-08 06:56

- Relationships

-  Notes
(0023588)
ssallmen (reporter)
2015-07-07 17:14

Added the diff of the database dump before and after and the xml-file used for test case import.
(0023589)
ssallmen (reporter)
2015-07-07 17:30

PHP Version is 5.6.10. Attached output of phpinfo() as a HTML-file.
(0023590)
ssallmen (reporter)
2015-07-07 20:49
edited on: 2015-07-07 20:53

Forgot to say that when I analyzed the diff of the database dumps, it seems that nodes_hierarchy table gets somehow badly affected by the import. All the rows related to the test project, the test suites and the test case title gets removed:

-INSERT INTO `nodes_hierarchy` VALUES (1,'My Project',NULL,1,1),(2,'COM action tests',1,2,1),(3,'actions',2,2,1),(4,'Test action 1',3,3,1),(5,'',4,4,0),(6,'',5,9,0),(7,'',5,9,0),(8,'',5,9,0),(9,'',5,9,0),(10,'',5,9,0),(11,'',5,9,0),(12,'',5,9,0),(13,'',5,9,0);
+INSERT INTO `nodes_hierarchy` VALUES (14,'',5,9,0),(15,'',5,9,0),(16,'',5,9,0),(17,'',5,9,0),(18,'',5,9,0),(19,'',5,9,0),(20,'',5,9,0),(21,'',5,9,0);

I don't know if this is normal but at least it seems suspicious. The same thing happens also if there are plenty of test cases and one or many of them is imported again with the import settings mentioned in the description.

(0023591)
fman (administrator)
2015-07-08 05:28

1) have you checked for similar issues ? IMHO some reports regarding errors on node_hierarchy has been reported

2) please get latest code from github, do fresh install, point to a copy of same db, retest and provide feedback
(0023592)
fman (administrator)
2015-07-08 05:31

>> - Full database dumps (SQL-files) before and after the second import
please provide it
(0023594)
ssallmen (reporter)
2015-07-08 07:30

1) Issue 7159 is the only one that I can find with node_hierarchy keyword and that is still a bit different. In that case only two projects of many were deleted. In my case, all the projects were deleted (yes, I faced this bug first time when we had many projects created in TestLink and the end result was the same) and in practice nothing can be done with the installation.

2) We can try with the latest code, with the fix to 7159, but it might also make sense to make the 1.9.14 release already because there are quite many majors and some blockers and crashes of 1.9.13 version fixed already. People using a tool for serious use are not usually very happy with using some development versions.

I attached the database dumps before and after the import causing the problem. The database was initially as empty as possible (only one project with one test plan and one tets case), just to make it easier to reproduce and isolate the problem. In real world the same happens with much larger amount of data too.
(0023595)
fman (administrator)
2015-07-08 07:41

>> 2) We can try with the latest code, with the fix to 7159, but it might also >>make sense to make the 1.9.14 release already because there are quite many >>majors and some blockers and crashes of 1.9.13 version fixed already. People >>using a tool for serious use are not usually very happy with using some >>development versions.
latest code is as good or as bad as official release will be, then IMHO is better to try it instead of asking for a blessed release
(0023596)
ssallmen (reporter)
2015-07-08 10:19

>> latest code is as good or as bad as official release will be, then IMHO is better to try it instead of asking for a blessed release

Well, if that is the case, and there is no release testing executed for the releases, why are you then making any releases if you think that everyone should use whatever is found from Git? Git does not have any updated release notes or installation instructions either. You might not be aware of usual software delivery processes but all those are quite important aspects of a decent software release, on top of the actual software. Open source does not mean that there would not be any releases, usually actually releases are done more often than with commercial software because it is more simple and does not need many kinds of commercially binding processes to be followed.

But, we'll try with the latest software from Git and tell what was the outcome.
(0023597)
ssallmen (reporter)
2015-07-08 12:09

Ok, the bug is not existing in the code found from the GitHub. When running the same steps mentioned in original failure description, import is ok and the tool works normally after the import. We also tried with a working version of database from 1.9.13 version and migrated that to 1.9.14 (one project with multiple test cases) and updated one test case by importing the update as described in the steps. Test case was updated and the TestLink worked well also after the update.
(0023598)
fman (administrator)
2015-07-08 15:30

>> Well, if that is the case, and there is no release testing executed for the >>releases, why are you then making any releases if you think that everyone >>should use whatever is found from Git?
I've not said this, is what you have understood.
Github contains code that will be next stable release, with each bug that has been fixed and each new feature.

>> You might not be aware of usual software delivery processes but all those are >>quite important aspects of a decent software release, on top of the actual >>software. Ope
I do not think is a thing to discuss there but I found offending your comments.
After more than 10 years of developing and releasing TestLink IMHO it's quality is acceptable.

>> Open source does not mean that there would not be any releases,
Again I do not need a lecture on what open source is or not.

It would be better if you have proceed as requested, and then get the result you have written on note 23597 => i.e. issue fixed.

It is supposed that fixes are tested (not as much as it will need due to lack of resources).


Do you want to collaborate donating time to test?
If answer is yes => contact me francisco.mancardi@gmail.com
(0023908)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-07-07 17:11 ssallmen New Issue
2015-07-07 17:11 ssallmen File Added: screenshots.docx
2015-07-07 17:12 ssallmen File Added: testlinkdb_20150707-BADROBOT.patch
2015-07-07 17:13 ssallmen File Added: testlink_testcase_import_bug_repro.xml
2015-07-07 17:14 ssallmen Note Added: 0023588
2015-07-07 17:29 ssallmen File Added: phpinfo.html
2015-07-07 17:30 ssallmen Note Added: 0023589
2015-07-07 20:49 ssallmen Note Added: 0023590
2015-07-07 20:52 ssallmen Note Edited: 0023590 View Revisions
2015-07-07 20:52 ssallmen Note Edited: 0023590 View Revisions
2015-07-07 20:53 ssallmen Note Edited: 0023590 View Revisions
2015-07-08 05:28 fman Note Added: 0023591
2015-07-08 05:31 fman Note Added: 0023592
2015-07-08 05:31 fman Assigned To => fman
2015-07-08 05:31 fman Status new => feedback
2015-07-08 05:31 fman QA Team - Task Workflow Status => TBD
2015-07-08 05:31 fman Priority immediate => high
2015-07-08 06:56 ssallmen File Added: testlinkdb_20150707-180716-before.sql.bz2
2015-07-08 06:56 ssallmen File Added: testlinkdb_20150707-180944-after.sql.bz2
2015-07-08 07:30 ssallmen Note Added: 0023594
2015-07-08 07:30 ssallmen Status feedback => assigned
2015-07-08 07:41 fman Note Added: 0023595
2015-07-08 10:19 ssallmen Note Added: 0023596
2015-07-08 12:09 ssallmen Note Added: 0023597
2015-07-08 15:30 fman Note Added: 0023598
2015-07-08 15:30 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-07-08 15:30 fman Status assigned => resolved
2015-07-08 15:30 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-07-08 15:30 fman Resolution open => fixed
2015-09-19 08:49 fman Note Added: 0023908
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker