Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007168TestLinkAssign Test Case Executionpublic2015-06-18 09:222015-09-19 08:49
Reporterlgyuri 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007168: Tester can set test cases on Test Case Assignement Overview page without permission
DescriptionTester can open the Test Case Assignement Overview page and he can check and modify the whole test cases executing status weather it was assigned him or wasnt


Steps To Reproduce1. Assign TC1 to Tester1 //TC1=test case
2. Assign TC2 to Tester2
3. Tester1 open the Test case assignement overview report
4. Test Case Assignement Overview shows the TC1 and TC2 status
5. Tester1 set TC2 status with smile icon (as passed)
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023523)
fman (administrator)
2015-06-18 13:17
edited on: 2015-06-18 13:19

1) no info is provided regarding ROLE of Tester1 and Tester2
2) get latest code from github, do fresh install, retest and provide feedback

3) ... weather it was assigned him or wasnt
Why this has to be forbbiden?
what kind of configuration have you done?

4) wrong issue category

(0023524)
lgyuri (reporter)
2015-06-18 14:22

.) Tester1 and Tester2 have tester role for tis test plan
they have rights on

TEST PLAN:
Test plan execute
Test plan metrics
Show test cases assigned to me

Test Case management:
Test Case view (read only access)

2.) Are you sure that latest code would be resolved my issue? Where there any bug fixes for this? (We have TestLink 1.9.13 (Stormbringer))

3.) "Why this has to be forbbiden?"
Because we do not let user to run those test cases which were not assigned him. Because he was not responsible for it.
If theres is no possible, pls help us how can we set disabled the smile icons on this report.

4.) Im sorry about it.
Anyway, which one would be better? And how can I change it?
(0023525)
fman (administrator)
2015-06-18 14:28

>> 2.) Are you sure that latest code would be resolved my issue? Where there any >>bug fixes for this? (We have TestLink 1.9.13 (Stormbringer))
because you are getting free support, it is requested that some tests will be done by you. This is the minimun collaboration I'm asking

>> 4.) Im sorry about it.
>> Anyway, which one would be better?
may be something related to the report you are using?

>>And how can I change it?
now you can not
(0023526)
lgyuri (reporter)
2015-06-18 14:48

..And what about number 1 and 3?
(0023527)
fman (administrator)
2015-06-18 19:17

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/3baa4bf1023e0523ec033f9eb8414311d0a584a1 [^]
(0023532)
lgyuri (reporter)
2015-06-22 14:33

It works well!

Upgrade testlink from 1.9.13 to 1.9.14 and this issue was solved.

thns a lot!
(0023916)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-06-18 09:22 lgyuri New Issue
2015-06-18 13:17 fman Note Added: 0023523
2015-06-18 13:18 fman Note Edited: 0023523 View Revisions
2015-06-18 13:19 fman Note Edited: 0023523 View Revisions
2015-06-18 14:22 lgyuri Note Added: 0023524
2015-06-18 14:28 fman Note Added: 0023525
2015-06-18 14:28 fman QA Team - Task Workflow Status => TBD
2015-06-18 14:28 fman Priority high => normal
2015-06-18 14:28 fman Steps to Reproduce Updated View Revisions
2015-06-18 14:48 lgyuri Note Added: 0023526
2015-06-18 19:17 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-06-18 19:17 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-06-18 19:17 fman Note Added: 0023527
2015-06-18 19:17 fman Status new => resolved
2015-06-18 19:17 fman Resolution open => fixed
2015-06-18 19:17 fman Assigned To => fman
2015-06-18 19:18 fman Relationship added child of 0006830
2015-06-22 14:33 lgyuri Note Added: 0023532
2015-09-19 08:49 fman Note Added: 0023916
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker