Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007155TestLinkPerformancepublic2015-06-10 16:272015-09-19 08:49
Reportervincam 
Assigned Tofman 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007155: Test Plan usage - Edit test cases - access to test case data is very slow when test plan links > 30
DescriptionWhen a test case is assigned to several Test Plans (more than 30) the time to open this test case on Test Specification for edit is too much big.
Steps To Reproduce1. Assign a Test case to a more than 30 different Test Plans
2. Try to open / edit this test case via Test Specification
Additional InformationIf this test cases is assigned to only for 2 or 3 test plans this time is very quickly and is very comfortable to open and edit the test case.

P.S: I think that this issue is related to a Test Plan Usage. If the test case is assigned to a several test plans the function "Test Plan Usage" list keep to much time to consult and due this there is much time to open this test cases to edit.
TagsDB INDEX, INDEX
Database (MySQL,Postgres,etc)Mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006230closedfman Possibility to configure Test plan usage show up in Test specification 
child of 0007162new Performance Issues due to missing / wrong indexes 
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023467)
fman (administrator)
2015-06-10 16:52

>>When a test case is assigned to several Test Plans the time to open this test >>case on Test Specification for edit is too much big.

Several => means nothing
to much => means nothing

please provide detailed steps to reproduce
(0023468)
vincam (reporter)
2015-06-10 17:06

Several = More Than 30 Test Plans
to Much = 00:03:10 Tree minutes and ten seconds to open the test case.
(0023469)
vincam (reporter)
2015-06-10 17:08

I tried to disable the "Test Plan Usage" via file: config.inc.php -> $tlCfg->spec_cfg->show_tplan_usage = False;

But the issue continues reproduce.
(0023470)
vincam (reporter)
2015-06-10 17:34

The same issue are previously reported via Mantis ID: 0006230

1. Test cases are loading very slow when too many test plans are linked to same test case.
(0023471)
fman (administrator)
2015-06-10 20:18

unfortunately reporter of 6230 never provided feedback
(0023472)
fman (administrator)
2015-06-10 20:21

try this
https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/1bfe839a6e7cfec28ba1ae38f33d03822d4d715d [^]

with
$tlCfg->spec_cfg->show_tplan_usage = False;
on custom_config.inc.php

please provide feedback (and may be support this work)
(0023475)
vincam (reporter)
2015-06-10 20:30

I do the solution mentioned in 6230, but the test cases continues loading very slow.

To improve the time to display the test cases, I deleted some Test Plans. Because I have 93 test Plans with around 2000 test cases each one.

After delete 63 test plans the time to load the test cases decrease form 00:03:10 to 00:00:07.

There is a way to improve this? Without removing the test plans?
(0023476)
fman (administrator)
2015-06-10 21:02

have you read carefully note 23472?
please proceed as required
(0023477)
vincam (reporter)
2015-06-10 21:10

Yes, I read the note 23472.

I do this! But but the test cases continues loading very slow.
(0023478)
fman (administrator)
2015-06-10 21:12

please try to write in a more clear way, have you applied the fix?
with this fix info about info about test plan usage is not got, this has to be the issue.
please provide clear feedback
(0023482)
vincam (reporter)
2015-06-11 12:10

Yes, I applied the fix! When I say (Yes I do this).

In config.inc.php I changed the$tlCfg->spec_cfg->show_tplan_usage = False; (From true to FALSE.)

After that, the time to load the test cases is the same. Nothing has changed after applied the fix.

Sorry for my words did not clear.
(0023484)
fman (administrator)
2015-06-11 12:54

without your db I've no other option that close unable to reproduce.
(0023489)
fman (administrator)
2015-06-13 06:35

ALTER TABLE executions
ADD INDEX `executions_idx3` (`tcversion_id` ASC);
(0023490)
fman (administrator)
2015-06-13 08:04

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/29dbd5162da392f2651003542baa3c5947c5b56b [^]
(0023491)
fman (administrator)
2015-06-13 08:05

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/29dbd5162da392f2651003542baa3c5947c5b56b [^]
(0023608)
quietust (reporter)
2015-07-09 19:41

Your ALTER TABLE statement mentioned above does the trick (I had the same problem in a database with over 100,000 executions and independently implemented the same fix). However, the commit mentioned above adds the index as a UNIQUE constraint, which won't work at all if you have multiple platforms or multiple builds.
(0023609)
fman (administrator)
2015-07-09 20:15

ok, will check & transform in a simple index
(0023610)
fman (administrator)
2015-07-09 20:26

code on github was correct with a newer commit (that has not been documented here) then there is no issue
(0023611)
quietust (reporter)
2015-07-09 20:38

Sorry for the false alarm - I had tried checking for a subsequent fix, but I forgot to switch the branch/tag from "current commit" to "testlink_1_9"; upon doing so, I can see the newer commit including said fixes.
(0023905)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-06-10 16:27 vincam New Issue
2015-06-10 16:52 fman Note Added: 0023467
2015-06-10 16:53 fman QA Team - Task Workflow Status => TBD
2015-06-10 16:53 fman Description Updated View Revisions
2015-06-10 17:06 vincam Note Added: 0023468
2015-06-10 17:08 vincam Note Added: 0023469
2015-06-10 17:34 vincam Note Added: 0023470
2015-06-10 20:17 fman Relationship added related to 0006230
2015-06-10 20:18 fman Note Added: 0023471
2015-06-10 20:20 fman Summary Test Plan usage - Edit test cases - Much time to open => Test Plan usage - Edit test cases - access to test case data is very slow when test plan links > 30
2015-06-10 20:21 fman Note Added: 0023472
2015-06-10 20:21 fman Assigned To => fman
2015-06-10 20:21 fman Status new => feedback
2015-06-10 20:30 vincam Note Added: 0023475
2015-06-10 20:30 vincam Status feedback => assigned
2015-06-10 21:02 fman Note Added: 0023476
2015-06-10 21:02 fman Status assigned => feedback
2015-06-10 21:10 vincam Note Added: 0023477
2015-06-10 21:10 vincam Status feedback => assigned
2015-06-10 21:12 fman Note Added: 0023478
2015-06-10 21:12 fman Status assigned => feedback
2015-06-11 12:10 vincam Note Added: 0023482
2015-06-11 12:10 vincam Status feedback => assigned
2015-06-11 12:54 fman Note Added: 0023484
2015-06-11 12:54 fman Status assigned => feedback
2015-06-11 17:43 vincam Status feedback => assigned
2015-06-13 06:34 fman Tag Attached: DB INDEX
2015-06-13 06:34 fman Tag Attached: INDEX
2015-06-13 06:34 fman Relationship added child of 0007162
2015-06-13 06:35 fman Note Added: 0023489
2015-06-13 08:04 fman Note Added: 0023490
2015-06-13 08:05 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-06-13 08:05 fman Note Added: 0023491
2015-06-13 08:05 fman Status assigned => resolved
2015-06-13 08:05 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-06-13 08:05 fman Resolution open => fixed
2015-06-13 08:06 fman Relationship added child of 0006830
2015-07-09 19:41 quietust Note Added: 0023608
2015-07-09 20:15 fman Note Added: 0023609
2015-07-09 20:26 fman Note Added: 0023610
2015-07-09 20:38 quietust Note Added: 0023611
2015-09-19 08:49 fman Note Added: 0023905
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker