Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007112TestLinkTest Executepublic2015-05-08 18:192015-09-19 08:49
Reporteransar 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007112: Test Case with multiple users assigned is not able to be executed.BY USERS WITH TESTER ROLE
DescriptionIt appears that assigning a test case to multiple users removes the ability of the test case to be executed. The "Notes /Description" along with the Save Execution section are no longer there.

After digging into the code, this was discovered:

In the setCanExecute function in lib/execute/execSetResults.php, $assiagned_to_me is set as
$assigned_to_me = $tc_exec['assigned_user_id'] == $tester_id ? 1 : 0;
'assigned_user_id' seems to be a comma separated list of users if there are more than one. This causes the == check to fail even though $tester_id is in the list. The result of this is CanExecute is false, so we are not able to execute a testcase that has multiple users assigned to it. Changing the $assignmed_to_me variable to
$assigned_to_me = in_array($tester_id, explode(',',$tc_exec['assigned_user_id'])) ? 1 : 0;
addresses the issue for us. But perhaps there is some setting we have incorrect that would also fix the issue.

Steps To Reproduce1. Create a test case, call it TC1.
2. Assign it to a Test Plan.
3. Assign TC1 to Tester1.
4. Notice that Tester1 has the option to execute TC1.
5. Assign TC1 to a second person, Tester2. Now Tester1 and Tester2 are ssigned to TC1
6. Notice that neither Tester1 nor Tester2 has the option to execute TC1
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserAny
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023335)
fman (administrator)
2015-05-08 18:31

Thanks, for your help.
Please next time provide more detailed info, because in order to reproduce this you need to use users that have TESTER ROLE
If you use an admin all work as expected.
The user role is not a minor detail
(0023336)
fman (administrator)
2015-05-08 19:07

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/cb380fa78111c6d6cec2ff6651c4afbf2529b0b6 [^]
(0023938)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-05-08 18:19 ansar New Issue
2015-05-08 18:27 fman Note Added: 0023334
2015-05-08 18:28 fman Note Edited: 0023334 View Revisions
2015-05-08 18:31 fman Note Added: 0023335
2015-05-08 18:32 fman QA Team - Task Workflow Status => TBD
2015-05-08 18:32 fman Summary Test Case with multiple users assigned is not able to be executed. => Test Case with multiple users assigned is not able to be executed.BY USERS WITH TESTER ROLE
2015-05-08 18:32 fman Note Deleted: 0023334
2015-05-08 19:06 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-05-08 19:06 fman Assigned To => fman
2015-05-08 19:06 fman Status new => assigned
2015-05-08 19:06 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-05-08 19:07 fman Note Added: 0023336
2015-05-08 19:07 fman Status assigned => resolved
2015-05-08 19:07 fman Resolution open => fixed
2015-05-08 19:08 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023938
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker