Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007110TestLinkFilters - Test Specificationpublic2015-05-07 13:012015-09-19 08:49
Reportersam423 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007110: Test specification - Filter Status shows test cases whose status is different than the selected
DescriptionFiltering after the status shows as a result all test cases corresponding to the selected state. However, the version of the test case is not taken into consideration. The result is that all test cases where the previous versions have the selected status are shown, even if the current version already has a different status.
E.g.: we are looking for the status 'Draft' and get as result a test case which has the status 'Final' in the current version, because a previous version of the test case has the status 'Draft'. However, such a case we would not get through the filter, because the current state is not 'Draft'.
Steps To Reproduce1. Create a test case with the status 'Draft'.
2. Create a new version of this test case and set the status to 'Final'.
3. Go to the test specification and filter there to test cases in the status 'Draft'.

Result:
The result shows the previous created test case, although this test case has the status 'Final' in the current version.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0023330)
fman (administrator)
2015-05-07 16:08

please get latest code from github, do fresh install, retest & provide feedback
(0023333)
fman (administrator)
2015-05-08 18:21

tested on github code 20150507 - 18:21 UTC
(0023939)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-05-07 13:01 sam423 New Issue
2015-05-07 16:08 fman Note Added: 0023330
2015-05-07 16:08 fman Assigned To => fman
2015-05-07 16:08 fman Status new => feedback
2015-05-08 18:21 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-05-08 18:21 fman Note Added: 0023333
2015-05-08 18:21 fman Status feedback => resolved
2015-05-08 18:21 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-05-08 18:21 fman Resolution open => fixed
2015-09-19 08:49 fman Note Added: 0023939
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker