Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007096TestLinkBug Tracking System - Redmine Integrationpublic2015-04-28 11:212015-09-19 08:49
Reportersman 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionServer 2008 R2
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007096: Issue creation in Redmine is not working
DescriptionWhen i try to create an issue directly in redmine using Testlink, i receive the following error (entry in eventlog):

Create REDMINE Ticket FAILURE => redmine::_requesturl:http://redmine.mycompany.at [^] - response:

{"url":"http:\/\/redmine.mycompany.at\/issues.xml",
"content_type":"application\/xml",
"http_code":404,"header_size":410,"request_size":523,"filetime":-1,

"ssl_verify_result":0,"redirect_count":0,"total_time":0.015,
"namelookup_time":0,"connect_time":0,"pretransfer_time":0,
"size_upload":231,"size_download":1,"speed_download":66,
"speed_upload":15400,"download_content_length":-1,
"upload_content_length":231,"starttransfer_time":0.015,
"redirect_time":0,"redirect_url":"",
"primary_ip":"xxx.xxx.xxx.xxx","certinfo":[],"primary_port":80,"local_ip":"10.10.1.84","local_port":51679} 
- content: " "


Surprisingly, when i link an existing issue, everything works fine.

This is my tracker config:

<issuetracker>
<apikey>apikey</apikey>
<uribase>http://redmine.mycompany.at/</uribase> [^]
<uriview>http://redmine.mycompany.at/issues/</uriview> [^]
<projectidentifier>myproject-id</projectidentifier>
<tracker_id>1</tracker_id>
</issuetracker>

Connection test says OK.
Steps To ReproduceTest Execution
Select Test Case
Bug management - create issue
Save
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE 11
PHP Version5.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023246)
fman (administrator)
2015-04-28 15:28

>> Surprisingly, when i link an existing issue, everything works fine.
there is no surprise, because link is different that create.
(0023247)
fman (administrator)
2015-04-28 15:29

detailed (very detailed) steps to reproduce are needed
(0023254)
sman (reporter)
2015-04-29 07:51

1. Login using admin credentials
2. Under Test execution - click "execute tests" (i have previously assigned several test cases to this user)
3. In tree view on left side i select one test case
4. The test case has several steps. I set all status to "failed" and the overall status of test case also to "failed". Additionally, i check "create issue"
5. Entry in "issue description": test
6. press button "save execution"
7. the page refreshes and last exection is shown (normal behaviour)
8. no issue is shown below entry of last execution time
9. in event viewer of testlink, the above mentioned warning is shown.

alternative:
1. in "execute tests" click on "create issue" under "bug management" beneath last exection entry.
2. pop up window "create issue" appears
3. click "save"
4. pop up windows remains open.
5. above mentioned warning is shown in event viewer
(0023300)
fman (administrator)
2015-05-01 15:37

After several tests seems that issue happens using user:password authentication method.
I'm doing a change to use header X-REDMINE method for authentication.
(0023301)
fman (administrator)
2015-05-01 15:52

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/05f49606fffcdca20a01ac9f67dc83e2e6993b6b [^]
(0023320)
sman (reporter)
2015-05-04 05:50

Thank you very much for your response. Unfortunately, the error still remains. I have updated my Testlink installation to 1.9.14 (DEV). When i reproduce the above mentioned steps, i still get the warning message. The only difference is that it is shown directly in pop up window.
Can i provide you with further information?
(0023321)
fman (administrator)
2015-05-04 13:00

You need to check OUTSIDE TESTLINK but using same credentials that you can operatate on your redmine via REST API
(you can use POSTMAN addon for Chrome)
I can not anything more
(0023942)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-04-28 11:21 sman New Issue
2015-04-28 15:28 fman Note Added: 0023246
2015-04-28 15:29 fman Note Added: 0023247
2015-04-29 07:51 sman Note Added: 0023254
2015-05-01 15:34 fman QA Team - Task Workflow Status => TBD
2015-05-01 15:34 fman Description Updated View Revisions
2015-05-01 15:35 fman Description Updated View Revisions
2015-05-01 15:35 fman Description Updated View Revisions
2015-05-01 15:37 fman Note Added: 0023300
2015-05-01 15:51 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-05-01 15:51 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-05-01 15:52 fman Note Added: 0023301
2015-05-01 15:52 fman Status new => resolved
2015-05-01 15:52 fman Resolution open => fixed
2015-05-01 15:52 fman Assigned To => fman
2015-05-01 15:52 fman Relationship added child of 0006830
2015-05-04 05:50 sman Note Added: 0023320
2015-05-04 13:00 fman Note Added: 0023321
2015-09-19 08:49 fman Note Added: 0023942
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker