Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007089TestLinkAssign Test Case Executionpublic2015-04-27 09:032015-09-19 08:49
Reporteranushajoisa 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWindowsOS VersionServer 2012 R2
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007089: Bulk TESTER assignment does not work for all test cases when the first level test suite with many child suite is selected
DescriptionIn the 'Assign Test Case Execution' section, when a first level test suite containing many second level test suites is clicked, bulk tester assignment works only for the top most second level test suite under the parent first level test suite.
Steps To Reproduce1. Select a Test Plan and go to 'Assign Test Case Execution' section.
2. Click on a first level test suite which has more than one second level child suites.
3. Click on 'Do' that is associated with 'Check/Uncheck all Test cases'. This selects only the test cases belonging to the top-most child test suite.
4. Even if we manually check the test cases belonging to the remaining child test suites, select the tester in the 'Bulk user assignment' field and click on 'Do', the assignment happens only for the top most child test suite.

Please refer attached screen shot 'Bulk User Assignment.png'
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon Bulk User Assignment.png [^] (158,004 bytes) 2015-04-27 09:03


png file icon Assign_Test_Case_Execution_Blank.png [^] (193,938 bytes) 2015-04-30 12:48


png file icon Blank_Test_Execution.png [^] (185,369 bytes) 2015-04-30 12:49

- Relationships

-  Notes
(0023233)
fman (administrator)
2015-04-27 19:45
edited on: 2015-04-27 20:07

1. update to 1.9.13 with latest fixes and retest
2. details to reproduce do not have level of details needed (see http://mantis.testlink.org/view.php?id=7042 [^] )
3. this issues is probably related to php configuration regarding amount of POST inputs, there is a note on README file regarding this.

2. Release notes / CRITIC Configuration Notes
===============================================================

This release contains bugfixes for 1.9.12
See CHANGELOG file for detailed list of issues fixed.

*** CRITIC PHP.INI Settings ***
max_input_vars, Available since PHP 5.3.9. Default value:1000
If you are going to have test plans with more that 100 test cases, it will be CRITIC
to increase this value in order to avoid issues (CRASH or MALFUNCTIONS) when adding
test cases to test plan.
See:
http://forum.testlink.org/viewtopic.php?f=11&t=7124&p=17284&sid=e3552aca223ac1f6b3676812aa02f04c#p17284 [^]
http://mantis.testlink.org/view.php?id=5372 [^]


(0023240)
fman (administrator)
2015-04-27 20:07

php.ini configuration issue
(0023278)
anushajoisa (reporter)
2015-04-30 12:48
edited on: 2015-04-30 12:49

I have tried to reproduce this in 1.9.13, but in that version I am unable to assign test cases itself.

Steps:
1. Create a Test Plan and add few test cases to it.
2. Go to 'Assign Test Case Execution'. Here the left hand pane where the test suites are listed is not being displayed (refer attached 'Assign_Test_case_Execution_Blank.png).

I am seeing the same blank left hand pane with 'Test Execution' section also (refer attached 'Blank_Test_Execution.png').

(0023282)
fman (administrator)
2015-04-30 17:51

Can you be kindly enough to provide feedback regarding if you have or not have done the changes on php.ini, before adding more notes?

in any case only way to act is to have your db or one that will be similar on structure, test project qty, test cases qty
(0023325)
fman (administrator)
2015-05-06 08:40

no more user feedback
(0023356)
anushajoisa (reporter)
2015-05-15 03:44

In php.ini file, I have changed the line
max_input_vars = 2500
to
max_input_vars = 10000

I logged out and logged in to TestLink back again. It still does not work.

It is not easy for us to ugrade TestLink immediately to test an issue since we are using TestLink in our production setup and it will affect our work.
(0023357)
anushajoisa (reporter)
2015-05-15 03:48

I have attached the screen shot 'Bulk_user_assignment_after_php_ini_changes.png' where all test cases do not get checked when I click on 'Do' next to 'Check/uncheck all test cases All platforms'.
(0023361)
fman (administrator)
2015-05-15 06:11

>> It is not easy for us to ugrade TestLink immediately to test an issue since we are using TestLink >> in our production setup and it will affect our work.
What about setting a test machine? is a normal way to work

Have you restarted webserver after change to php.ini ?

Without db similar to yours to have same amount of test projects, test suites, test cases, nothing can be done
(0023369)
anushajoisa (reporter)
2015-05-18 03:54

Yes, I restarted the web server after the change and checked, but it did not work.

The issue http://mantis.testlink.org/view.php?id=5372 [^] and the discussiojn in the forum http://forum.testlink.org/viewtopic.php?f=11&t=7124&p=17284&sid=e3552aca223ac1f6b3676812aa02f04c#p17284 [^] that you pointed to refers to the 'Add/Remove Test Cases' section. This is working as expected, I am able to add test cases in bulk for all test suites under a parent test suite.

But the issue I am facing where all test cases under the child test suites of a parent test suite do not get checked when I click on 'Do' associated with 'Check/uncheck all test cases' and 'Bulk user assignment' is in the 'Assign Test Case Execution' section.
(0023733)
ragul (reporter)
2015-08-11 15:40

to fix this issue open file and edit these lines

\testlink\gui\templates_c\00528a7d009faa9ba706a7a6a9b6cba0c7503e4c.file.tc_exec_assignment.tpl.php

Line 476

Current Value
?> </div> <?php endfor; endif; ?>

New Value
?> <?php endfor; endif; ?>

Line 478

Current Value
<?php if ($_smarty_tpl->getVariable('smarty')->value['foreach']['div_drawing']['last']){?></div> <?php }?>

New Value
</div> <?php if ($_smarty_tpl->getVariable('smarty')->value['foreach']['div_drawing']['last']){?></div> <?php }?>
(0023734)
fman (administrator)
2015-08-11 18:22

@ragui
you can not fix anything if you change COMPILED TEMPLATE, the source tpl need to be changed (if needed)
(0023898)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-04-27 09:03 anushajoisa New Issue
2015-04-27 09:03 anushajoisa File Added: Bulk User Assignment.png
2015-04-27 19:45 fman Note Added: 0023233
2015-04-27 20:06 fman Note Edited: 0023233 View Revisions
2015-04-27 20:07 fman Note Edited: 0023233 View Revisions
2015-04-27 20:07 fman Note View State: 0023233: public
2015-04-27 20:07 fman QA Team - Task Workflow Status => TBD
2015-04-27 20:07 fman Note Added: 0023240
2015-04-27 20:07 fman Status new => closed
2015-04-27 20:07 fman Assigned To => fman
2015-04-27 20:07 fman Resolution open => fixed
2015-04-30 12:48 anushajoisa Note Added: 0023278
2015-04-30 12:48 anushajoisa Status closed => assigned
2015-04-30 12:48 anushajoisa Resolution fixed => reopened
2015-04-30 12:48 anushajoisa File Added: Assign_Test_Case_Execution_Blank.png
2015-04-30 12:49 anushajoisa File Added: Blank_Test_Execution.png
2015-04-30 12:49 anushajoisa Note Edited: 0023278 View Revisions
2015-04-30 17:51 fman Note Added: 0023282
2015-04-30 17:51 fman Status assigned => feedback
2015-05-06 08:40 fman Note Added: 0023325
2015-05-06 08:40 fman Status feedback => closed
2015-05-06 08:40 fman Resolution reopened => unable to reproduce
2015-05-15 03:44 anushajoisa Note Added: 0023356
2015-05-15 03:44 anushajoisa Status closed => assigned
2015-05-15 03:44 anushajoisa Resolution unable to reproduce => reopened
2015-05-15 03:48 anushajoisa Note Added: 0023357
2015-05-15 06:11 fman Note Added: 0023361
2015-05-15 06:11 fman Status assigned => feedback
2015-05-18 03:54 anushajoisa Note Added: 0023369
2015-05-18 03:54 anushajoisa Status feedback => assigned
2015-05-18 06:18 fman Status assigned => resolved
2015-05-18 06:18 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-05-18 06:18 fman Resolution reopened => fixed
2015-08-11 15:41 ragul Note Added: 0023733
2015-08-11 18:22 fman Note Added: 0023734
2015-08-15 15:49 fman Summary Bulk assignment of test cases does not work for all test cases when the first level test suite with many child suite is selected => Bulk TESTER assignment does not work for all test cases when the first level test suite with many child suite is selected
2015-09-19 08:49 fman Note Added: 0023898
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker