Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007084TestLinkTest Plan (builds, milestones, test assign)public2015-04-27 08:192015-09-19 08:49
Reporteranushajoisa 
Assigned Tofman 
PriorityhighSeverityfeature requestReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformWindowsOSWindowsOS VersionServer 2012 R2
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007084: While creating a new build in a Test Plan, only 'Not Run' test cases of the previous build should be associated with this build
Description1. At present, in a Test Plan, when a new build is created, in the Test Execution section all test cases get the execution status 'Not Run' bin this new build.
2. This can be enhanced in such a way that the leader/admin can be provided with an option to pull only the 'Not Run' test cases of the previous build to the new build for execution.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon build_creation.png [^] (57,531 bytes) 2015-04-30 11:22


png file icon cb01.png [^] (30,610 bytes) 2015-04-30 18:07

- Relationships
duplicate of 0006938closedfman Create Build from existent one - copy tester assignment filtering by execution status 

-  Notes
(0023235)
fman (administrator)
2015-04-27 19:53

request is too limiting then value is low.
In any case because you are not using the latest stable release, the right approach before asking for feature is to check if there is a similar feature already implemented on latest stable release or in the latest available fixes.
have you checked these info ?

IMHO this feature already exists, you just need to do careful searches .
(0023277)
anushajoisa (reporter)
2015-04-30 11:22

Ok thanks, I checked with the latest release, but this release also does not have this feature.

When a build is being created, the user is only provided an option to "copy tester assignments", not associate only the test cases which are "Not Run" on a particular previous build, seen in the attached file "build_creation.png".
(0023292)
fman (administrator)
2015-04-30 18:06

Have you searched on mantis for similar issue? I need this answer
I've just do a test with latest code from github feature exists see attached image
(0023293)
fman (administrator)
2015-04-30 18:16
edited on: 2015-04-30 18:17

as you can see I've added relation to an existent issue.
Category is Build Management.
From my point of view with a little effort before reporting (on the reporter side) I will be able to use better my time.

checking http://mantis.testlink.org/view.php?id=6830 [^] is a must (this link has been provided on README of latest stable release 1.9.13)

(0023363)
anushajoisa (reporter)
2015-05-15 07:15

Since this is fixed in version 1.9.14 and this is not the latest stable release, can you please point me to the php files that have to be replaced in 1.9.12 to have this feature implemented?
(0023365)
fman (administrator)
2015-05-15 12:59

Only solution is using latest code from Github.
Code is good enough to be used in production
(0023934)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-04-27 08:19 anushajoisa New Issue
2015-04-27 19:53 fman Note Added: 0023235
2015-04-27 19:53 fman Assigned To => fman
2015-04-27 19:53 fman Status new => feedback
2015-04-30 11:22 anushajoisa Note Added: 0023277
2015-04-30 11:22 anushajoisa Status feedback => assigned
2015-04-30 11:22 anushajoisa File Added: build_creation.png
2015-04-30 18:06 fman Note Added: 0023292
2015-04-30 18:07 fman File Added: cb01.png
2015-04-30 18:07 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-04-30 18:07 fman Status assigned => resolved
2015-04-30 18:07 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-04-30 18:07 fman Resolution open => fixed
2015-04-30 18:14 fman Relationship added duplicate of 0006938
2015-04-30 18:16 fman Note Added: 0023293
2015-04-30 18:17 fman Note Edited: 0023293 View Revisions
2015-05-15 07:15 anushajoisa Note Added: 0023363
2015-05-15 12:59 fman Note Added: 0023365
2015-09-19 08:49 fman Note Added: 0023934
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker