Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007056TestLinkBug Tracking System - JIRA Integrationpublic2015-04-13 18:202015-09-19 08:49
Reporterbly 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSRedhatOS Version6.2
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007056: JIRA REST API - No bug is created after clicking on Save button.
DescriptionConfigure testlink for jira rest integration. After Failing test case, open the bug creation window. Fill out all the fields and then click save. Bug is not created and these lines showed up in the warning log:

[>>][551dc513c9ce9227809172][DEFAULT][/testlink/lib/execute/bugAdd.php][15/Apr/2 22:39:15]
[15/Apr/2 22:39:17][WARNING][k2qkq8pr9sm98je4k0bsvnek70][GUI]
E_NOTICE
Undefined offset: 1 - in /opt/lampp/htdocs/testlink-1.9.13/lib/execute/bugAdd.php - Line 34
[15/Apr/2 22:39:17][WARNING][k2qkq8pr9sm98je4k0bsvnek70][GUI]
E_NOTICE
Undefined offset: 0 - in /opt/lampp/htdocs/testlink-1.9.13/lib/execute/bugAdd.php - Line 34
Steps To Reproduce1. Enter information in the issue tracker management page.

<!-- Template jirarestInterface -->
<issuetracker>
<username>username</username>
<password>password</password>
<uribase>https://company.atlassian.net/</uribase> [^]
<!-- CRITIC - WITH HTTP getIssue() DOES NOT WORK -->
<uriapi>https://company.atlassian.net/rest/api/latest/</uriapi> [^]
<uriview>https://company.atlassian.net/browse/</uriview> [^]
<!-- Configure This if you want be able TO CREATE ISSUES -->
<projectkey>XC</projectkey>
<issuetype>1</issuetype>
</issuetracker>

Note: The user, password, and company name is replace for privacy. However, the point is the fields were enter properly according to the example. Also, Environment field reported "OK"

2. go to Test Project management to assign the bug tracker to the project.

3. FAil a test case

4. Click on icon to crate bug and window pops up.

5. The drop down values showed up correctly for the Issue Type, Issue Priority , version, and components fields.

6. Enter values for all the fields and then click save. Nothing Happens.
Additional InformationI tried Jira SOAP and it works.
However, we plan to use Jira rest because it was built with jira fields that we want to use.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
Browserchrome, firefox
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006943closedfman No message showing issue is created successfully or not when clicking "save" in "create issue" page 
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0023080)
fman (administrator)
2015-04-13 19:37

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a1a4c6ce82b63447818abde195ffcfac23b1c72b [^]
(0023958)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-04-13 18:20 bly New Issue
2015-04-13 19:34 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-04-13 19:35 fman Summary No Jira bug is created after clicking on Save button. => JIRA REST API - No bug is created after clicking on Save button.
2015-04-13 19:35 fman Additional Information Updated View Revisions
2015-04-13 19:36 fman Relationship added related to 0006943
2015-04-13 19:37 fman Note Added: 0023080
2015-04-13 19:38 fman Relationship added related to 0006830
2015-04-13 19:40 fman Status new => resolved
2015-04-13 19:40 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-04-13 19:40 fman Resolution open => fixed
2015-04-13 19:40 fman Assigned To => fman
2015-04-13 19:41 fman Relationship deleted related to 0006830
2015-04-13 19:41 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023958
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker