Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007029TestLinkReportspublic2015-03-25 20:232019-04-02 20:41
Reportershaunhull 
Assigned Tofman 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSCentOSOS Version6.6 (Final)
Product Version1.9.13 (2015 #1) 
Fixed in Version 
Summary0007029: Test Plan Report Allowed memory size exhausted
DescriptionAttempting to run 'Test Plan Report'.
After selecting all document options, just returns a white page. Apache log shows Allowed memeory size exhausted in /lib/functions/object.class.php (line 279) referred from printDocOptions.php?type=testplan
Steps To ReproduceLog in to Test Link
Change Test Project to appropriate project
Change Current Test Plan to XY Report
Click the Test Reports Icon
Click Test Plan Report in left nav
Choose Boxes 1, 3, 4, 5
click the Top level XY Report folder icon (below the check/uncheck all button)
Additional Informationmemory_limit = 1024M
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.3.3
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0022981)
fman (administrator)
2015-03-25 20:34
edited on: 2015-03-25 20:44

please understand that you are not providing enough information about your environment,then is near impossible to reproduce.

follow this guidelines
http://www.softwaretestinghelp.com/how-to-write-good-bug-report/ [^]

and other present on forum.testlink.org

(0022982)
fman (administrator)
2015-03-25 20:50

give a look to http://mantis.testlink.org/view.php?id=7009 [^]
to understand if can solve your issue
(0022983)
shaunhull (reporter)
2015-03-25 20:57

fman, I apologize if my report was not detailed enough. 7009 states that this issue is fixed. I downloaded the latest bundle from github with the same results.

If you would prefer, I could re-submit this bug report with a more thorough explanation.

Thank you for your help.
(0022984)
fman (administrator)
2015-03-25 21:01

>> 7009 states that this issue is fixed
I was not able to reproduce then nothing was changed on code, that's why getting code from github solves nothing.
I was not able to reproduce 7009, but user was not able to provide required info
my suggestion is
1) do minor changes indicated on 7009 and retry
2) please provide more thorough explanation in this issue

regards
(0022985)
shaunhull (reporter)
2015-03-25 21:42

The fix in 7009 worked.

Thank you
(0022986)
fman (administrator)
2015-03-25 21:46
edited on: 2015-03-25 21:48

anyway can you provide more thorough explanation in this issue, because I'm not able to reproduce

can you also try with
if(is_null($current) || $current == REMOVEME)

(0022997)
fman (administrator)
2015-03-28 10:02

can you be kindly enough to provide detailed scenario ?
(0023008)
shaunhull (reporter)
2015-03-30 15:21

My apologies for my delay in getting this to you.

Platform: Virtual Host on VMware 5.5
Virtual Machine Version: 8
Memory: 8192 MB
CPUs: 4
OS: CentOS 6.6 (Final)
Kernel: 2.6.32-220.el6.x86_64
apache version: httpd-2.2.15-39.el6.centos.x86_64
php version: Zend Engine v2.3.0
Testlink version: 1.9.14 [DEV] (Padawan)

URL of Erroring Page: http://myhost.com/lib/results/printDocOptions.php?type=testplan&format=0&tplan_id=36145 [^]

Steps to Reproduce:

1. Login to Testlink
2. Select Test Project
3. Select Current Test Plan
4. Select "Test Reports" icon at upper left of screen (under username, 5th icon from left)
5. Report Format Dropdown "HTML"
6. Click first option on left menu "Test Plan Report"

The right pane should change to "Test Plan - Document options"

7. Select "Check/uncheck" all button

Below this button shows a folder icon with test project name, and a folder icon below it that reads "Reports"

8. Click the folder icon next to the test project name, not the "Reports" icon.

Expected Behavior: "Test Plan Design Report" displays
Actual Behavior: White page
(0023010)
fman (administrator)
2015-03-30 16:56

detailed scenario means test project structure, test suites, test cases and so on
(0023072)
fman (administrator)
2015-04-10 21:14

Dear user
because I've provided the solution, would you mind to be kindly enough to provide requested information ?

- Issue History
Date Modified Username Field Change
2015-03-25 20:23 shaunhull New Issue
2015-03-25 20:34 fman Note Added: 0022981
2015-03-25 20:44 fman Note Edited: 0022981 View Revisions
2015-03-25 20:50 fman Note View State: 0022981: public
2015-03-25 20:50 fman Note Added: 0022982
2015-03-25 20:57 shaunhull Note Added: 0022983
2015-03-25 21:01 fman Note Added: 0022984
2015-03-25 21:42 shaunhull Note Added: 0022985
2015-03-25 21:46 fman Note Added: 0022986
2015-03-25 21:48 fman Note Edited: 0022986 View Revisions
2015-03-28 10:02 fman Note Added: 0022997
2015-03-28 10:02 fman Assigned To => fman
2015-03-28 10:02 fman Status new => feedback
2015-03-30 15:21 shaunhull Note Added: 0023008
2015-03-30 15:21 shaunhull Status feedback => assigned
2015-03-30 16:56 fman Note Added: 0023010
2015-04-04 07:57 fman Status assigned => feedback
2015-04-10 21:14 fman Note Added: 0023072
2019-01-19 15:08 fman Status feedback => resolved
2019-01-19 15:08 fman Resolution open => unable to reproduce
2019-04-02 20:41 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker