Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007025TestLinkDatabase MySQLpublic2015-03-24 12:262015-09-19 08:49
Reporterfilip.cynarski 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007025: Execution history is slow because of attachments comparison
DescriptionI was faced that the execution history report is dramatically slow because of attachments table example URL: https://127.0.0.1/testlink/lib/execute/execHistory.php?tcase_id=1445 [^]
Steps To ReproduceIt can be fixed by adding Index on fk_id column on attachments table. After that it was rapid and responsive for huge amount of data.
TagsDB INDEX, INDEX
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0007162new Performance Issues due to missing / wrong indexes 
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0022961)
fman (administrator)
2015-03-24 14:12

thanks
it would be great to have some indication of amount of records
(0022970)
filip.cynarski (reporter)
2015-03-25 09:00
edited on: 2015-03-25 09:00

Sure, attachments table has 133147 rows, avg of testcase executions count is 202.05, max 358.

(0022975)
fman (administrator)
2015-03-25 09:43

Thanks for the info.
Unfortunately probably other areas of testlink can have similar issues, becasue when designin no stress was putted on such amount of info.
Surelly step by step this can be fixed or improved.
(0023492)
fman (administrator)
2015-06-13 08:05

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/29dbd5162da392f2651003542baa3c5947c5b56b [^]
(0023925)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-03-24 12:26 filip.cynarski New Issue
2015-03-24 14:12 fman Note Added: 0022961
2015-03-25 09:00 filip.cynarski Note Added: 0022970
2015-03-25 09:00 filip.cynarski Note Edited: 0022970 View Revisions
2015-03-25 09:43 fman Note Added: 0022975
2015-03-25 09:44 fman QA Team - Task Workflow Status => TBD
2015-06-13 06:33 fman Relationship added child of 0007162
2015-06-13 06:33 fman Tag Attached: DB INDEX
2015-06-13 06:33 fman Tag Attached: INDEX
2015-06-13 08:05 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-06-13 08:05 fman Note Added: 0023492
2015-06-13 08:05 fman Status new => resolved
2015-06-13 08:05 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-06-13 08:05 fman Resolution open => fixed
2015-06-13 08:05 fman Assigned To => fman
2015-06-13 08:05 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023925
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker