Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007014TestLinkTest Specificationpublic2015-03-20 08:442015-09-19 08:49
Reporterabaheti 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformAllOSUbuntuOS Version14.04
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007014: Create/Change test case with custom execution type, custom value is ignored
DescriptionWe can add a custom execution type to the "Execution type" via config file. Once the type is added, when we try to assign that new execution type, the test case is always save with the execution type "Manual"
Steps To ReproduceSet custom_execution_type as follows
$tlCfg->custom_execution_types = array('3'=>'not_automatable');

Set the localize string as in strings.txt file of the locale that is being used as follows
$TLS_not_automatable = "Not Automable";

The new execution type will be visible in the "Execution Type" field on the testcase.

Now open an existing test case and try to change the execution type to this newly create type.

Notice the page refreshes and doesn't allow to set the type to "Not Automable"
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.5.9
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files? file icon config.inc.php [^] (69,155 bytes) 2015-03-20 10:17
txt file icon strings.txt [^] (149,192 bytes) 2015-03-20 10:18 [Show Content]

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0022938)
fman (administrator)
2015-03-20 10:01

please provide detailed steps to reproduce.
(0022944)
fman (administrator)
2015-03-21 09:05

Solved with user help.
Anyway user has not provided (BAD attitude) requested steps to reproduce
(0022946)
abaheti (reporter)
2015-03-22 04:40

Francisco, I have added the steps to reproduce the issue. If you can tell me how exactly you wanted the steps to look like, I will try to follow that from next time.

Files were also attached.
(0022948)
fman (administrator)
2015-03-22 11:30
edited on: 2015-03-22 11:33

After you have added new custom value

Test Case #1 - assign custom execution type while CREATING test case
1. create Test project TPRJ01
2. create Test suite, TS-100
3. create test case TC-1A
    assign custom execution type value
    save
4. go to test spec feature, access test case TC-1A check execution type value

Test Case 0000002 - assign custom execution type while EDITING test case
After having done steps 1 to 3 of test case #1.
5. select test case TC-1A, and click EDIT ICON
6. change execution type to one of avaliable values
7. save
8. exit edit
9. go to test spec feature, check execution type value displayed
10. repeat 5 to 9, using each time a different execution type value

Test Case 0000003 - change execution type to CUSTOM VALUE from screen that display Test case

@reporter
I've just fixed the issue using your info/hint.
But because we can not be sure that same code path is followed on each of different ways to change this test case attribute (and may be other), it is important to
indicate with detailed step by step how you have hit the bug

regards

(0023972)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-03-20 08:44 abaheti New Issue
2015-03-20 10:00 fman QA Team - Task Workflow Status => TBD
2015-03-20 10:00 fman Priority high => low
2015-03-20 10:00 fman Severity major => minor
2015-03-20 10:01 fman Note Added: 0022938
2015-03-20 10:17 abaheti File Added: config.inc.php
2015-03-20 10:18 abaheti File Added: strings.txt
2015-03-21 09:03 fman Category General => Test Specification
2015-03-21 09:03 fman Summary Not able to edit the testcase to have custom execution type => Create/Change test case with custom execution type, custom value is ignored
2015-03-21 09:04 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-03-21 09:05 fman Note Added: 0022944
2015-03-21 09:05 fman Status new => resolved
2015-03-21 09:05 fman Resolution open => fixed
2015-03-21 09:05 fman Assigned To => fman
2015-03-21 09:05 fman Relationship added child of 0006830
2015-03-22 04:40 abaheti Note Added: 0022946
2015-03-22 11:30 fman Note Added: 0022948
2015-03-22 11:33 fman Note Edited: 0022948 View Revisions
2015-09-19 08:49 fman Note Added: 0023972
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker