Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007006TestLinkTest Spec. - Test Case Stepspublic2015-03-13 10:402015-09-19 08:49
Reportertinette 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSUbuntuOS Version14.04.2
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007006: Step is created twice assign a requirement jsut after the test creation
DescriptionWhen creating a test, with one step and then assign it a requirement, a popup window is displayed saying that I have to resend information to refresh screen.
Once done, I have 2 identical steps created
Steps To ReproduceCreate a test with one step => Test is created with one step
Assign a requirement to the test => Popup window is display to resend information, Requirement is assigned, double step is created
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox/Windows 8.1
PHP VersionPHP 5.5.9-1ubuntu4.6 (cli)
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0022897)
fman (administrator)
2015-03-14 09:46

please provide detailed step by step to reproduce
Good examples:
https://developer.mozilla.org/en-US/docs/Bug_writing_guidelines [^]
(0022945)
fman (administrator)
2015-03-21 14:36

unfortunately user did not provide requested info
(0022957)
tinette (reporter)
2015-03-23 07:58

Steps to reproduce:

Using Firefox, open Testlink.
Select a Test Project and a Test Plan and click on Test Specification in the left menu.

Then click on a Test Suite Operation and on the Actions icon.
Click on "+" icon on the Test Case Operations.

Enter a Test Case Title and a Summary. Click on Create button.

Click on Create Step button.

Define a step (Step actions+ expected Results) and click on Save&Exit button.
Only one step is displayed.

Immediatly, add a requirement by click on Link/Unlink Requirement icon (in the test case window). Close the Requirement window.

A window popup to refresh information is displayed. Click on OK button.
Now the step defined previously is displayed twice.
(0022959)
fman (administrator)
2015-03-23 18:47

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a9595e393d21e3f31518e8b5ea237a4b7eb97873 [^]
(0023970)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-03-13 10:40 tinette New Issue
2015-03-14 09:46 fman Note Added: 0022897
2015-03-14 09:46 fman Assigned To => fman
2015-03-14 09:46 fman Status new => feedback
2015-03-21 14:36 fman QA Team - Task Workflow Status => TBD
2015-03-21 14:36 fman Note Added: 0022945
2015-03-21 14:36 fman Status feedback => closed
2015-03-21 14:36 fman Resolution open => unable to reproduce
2015-03-23 07:58 tinette Note Added: 0022957
2015-03-23 07:58 tinette Status closed => assigned
2015-03-23 07:58 tinette Resolution unable to reproduce => reopened
2015-03-23 17:59 fman Status assigned => acknowledged
2015-03-23 18:44 fman Description Updated View Revisions
2015-03-23 18:44 fman Steps to Reproduce Updated View Revisions
2015-03-23 18:47 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-03-23 18:47 fman Note Added: 0022959
2015-03-23 18:47 fman Status acknowledged => resolved
2015-03-23 18:47 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-03-23 18:47 fman Resolution reopened => fixed
2015-03-23 18:48 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023970
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker