Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006955TestLinkRolespublic2015-02-17 16:542015-09-19 08:49
Reporternoe 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0006955: affecting a role on a project make you lose your own role (Pagination enabled)
DescriptionIn our organization all projects are "private" and users have global "no rights" roles.

In 1.9.13 when an "admin" user on a project affect a role to another user on this project, he loses his own rights on this project.

Steps To Reproduce- affect "xxx" a global "no right" user as "admin" on a test project
- logout, then login as "xxx"
- affect user "yyy" as "admin" on this project
- "xxx" loses his "admin" rights and "yyy" is not "admin"
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
Browserfirefox
PHP Version5.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0022729)
fman (administrator)
2015-02-17 17:32

a thing that has to be changed is possibility to use admin and specific set on a test project.

Instead of affect please use SET ROLE TO as expression, is the right one IMHO.
What would be great is to know what happens here:

>> - "xxx" loses his "admin" rights and "yyy" is not "admin"
what is the role for xxx now?
what is the role of yyy now?

Please try doing same actions using leader.

The model IMHO is to have JUST one or two GLOBAL ADMIN, and all other people can be leader.
I use this model with all test projects PRIVATE and have no issues
(0022731)
fman (administrator)
2015-02-17 19:39
edited on: 2015-02-17 19:40

1. fresh install
2. login as admin
3. create test project PADAWAN public, active
4. create user mou, default roles => no rights
5. set role on PADAWAN for mou => admin
6. logout admin
7. login as mou
8. mou can see just PADAWAN test project (is the only on system), and header feedback said mou is admin
9. logout mou
10. login admin
11. set PADAWAN test project PRIVATE
12. create test project SANDOKAN, PRIVATE
13. create user carlo, default role NO RIGHTS
14. set role for carlo on SANDOKAN => admin
15. logout
16. login using user carlo
17. carlo is identfied as ADMIN on SANDOKAN Test project (he is able to see only this, no matter other test project exists)

unable to reproduce

(0022732)
noe (reporter)
2015-02-18 13:13

It seems to be linked to pagination as we have more users. All the users of the first page are reset to default role (no rights for us).
I will do some more tests later.
Bye.
(0022733)
fman (administrator)
2015-02-18 13:24

as you understand the info provided on note 22732 is critic to do any analisys
(0022737)
noe (reporter)
2015-02-18 16:38

It is definitely due to pagination.
If I disable the pagination :
$tlCfg->gui->usersAssign->pagination->enabled = false;
everything works fine.

When the pagination is on, when you click "update", the values of the current page are saved, the other values (other pages) are lost (resetted to no rights).

Sorry for my english, it doesn't help !
(0023047)
IgnacioCoto (reporter)
2015-04-07 18:58

Hello, We have been having the same situation. Besides disabling pagination, did you find the solution for this bug? I tried to look in the hot fixes but did not found this one in particular.

Thanks
(0023048)
fman (administrator)
2015-04-07 19:49

Solution is available on latest code from repository, any time that you see that an issue has been changed status to resolved.
Follow instructions on related issue
(0023049)
IgnacioCoto (reporter)
2015-04-07 20:56

I did download the latest (available on hot-fixes 6830) but could not find the solution for this bug.
(0023050)
fman (administrator)
2015-04-07 21:26

@IgnacioCoto
Please would you mind to explain what do you mean by
'I did download the latest (available on hot-fixes 6830) but could not find the solution for this bug.' ?


I've just checked repository using:
$ git log --grep="6955"

and got:

commit fafae2c0825ca6476d41095cffaf6aa2a53f509e
Author: Francisco Mancardi <francisco.mancardi@gmail.com>
Date: Wed Feb 18 19:05:06 2015 +0100

    TICKET 6955: affecting a role on a project make you lose your own role (Pagination enabled)


I've checked and it works.
can you provide detailed steps you did in order to allow me to reproduce it ?
(0023961)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2015-02-17 16:54 noe New Issue
2015-02-17 17:32 fman Note Added: 0022729
2015-02-17 17:32 fman Assigned To => fman
2015-02-17 17:32 fman Status new => feedback
2015-02-17 19:39 fman Note Added: 0022731
2015-02-17 19:40 fman Note Edited: 0022731 View Revisions
2015-02-17 19:40 fman Note View State: 0022731: public
2015-02-17 19:40 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-02-17 19:40 fman Status feedback => resolved
2015-02-17 19:40 fman Resolution open => unable to reproduce
2015-02-18 13:13 noe Note Added: 0022732
2015-02-18 13:24 fman Note Added: 0022733
2015-02-18 16:38 noe Note Added: 0022737
2015-02-18 16:51 fman Summary affecting a role on a project make you lose your own role => affecting a role on a project make you lose your own role (Pagination enabled)
2015-02-18 18:03 fman Resolution unable to reproduce => fixed
2015-02-18 18:03 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-02-18 18:04 fman Relationship added child of 0006830
2015-04-07 18:58 IgnacioCoto Note Added: 0023047
2015-04-07 19:49 fman Note Added: 0023048
2015-04-07 20:56 IgnacioCoto Note Added: 0023049
2015-04-07 21:26 fman Note Added: 0023050
2015-09-19 08:49 fman Note Added: 0023961
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker