Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006926TestLinkTest Plan - Assign Test Case Executionpublic2015-02-03 02:332015-02-07 10:52
Reporterswang3 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006926: Cannot clear assignment in the "Assign to" drop down list
DescriptionIn test case execution assignment, for a test case, if you already selected one tester, you cannot select "empty" (clear the assignment). Looks like this is caused by the "chosen select" controller.
Steps To Reproduce1. Enter test case execution assignment.
2. Click a testsuite.
3. At the right page, click "check/uncheck all test cases", select a user and click "Do". Now all test cases have the "Assign to" field filled to this user.
4. Go to the test case list, click one of the drop down list to clear an assignment before save. You will find there is no empty string to select so you have no way to clear it.
Looks like this issue is caused by the new "chosen select" select box. I did a google and saw there are some solution on this. Hope this helps.
http://stackoverflow.com/questions/11365212/how-do-i-reset-a-jquery-chosen-select-option-with-jquery [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022629)
fman (administrator)
2015-02-04 23:12

on tc_exec_assignment_flat.tpl
jQuery(".chosen-select").chosen({ width: "85%", allow_single_deselect: true });
(0022651)
fman (administrator)
2015-02-07 10:52

1.9.13 released 20150207

- Issue History
Date Modified Username Field Change
2015-02-03 02:33 swang3 New Issue
2015-02-04 23:12 fman Note Added: 0022629
2015-02-04 23:14 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-02-04 23:14 fman Status new => resolved
2015-02-04 23:14 fman Fixed in Version => 1.9.13 (2015 #1)
2015-02-04 23:14 fman Resolution open => fixed
2015-02-04 23:14 fman Assigned To => fman
2015-02-04 23:15 fman Relationship added child of 0006609
2015-02-07 10:52 fman Note Added: 0022651
2015-02-07 10:52 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker