Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006899TestLinkReports - Failed/Blocked Test Casespublic2015-01-23 04:542015-02-07 10:53
Reporterswang3 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006899: Incorrect bug ID in exported Excel spreadsheet
DescriptionWe are using JIRA as the bug tracking tool.
In the exported spreadsheet for failed test cases which have bugs linked, the ID of "Bugs (ID : Summary)" shows something like a database index:
1348741:FileType is not working
It's better to show the original bug ID, like this:
HMC3000KT-2046:FileType is not working.

This issue maybe applicable to JIRA only. I am not sure since we don't use any other bug tracking system.
I am attaching a quick fix for this based on 1.9.12 (Line 288/290), however, not sure if this will break any other linked bug tracking tool.
Steps To Reproduce1. Execute a test case in a build of a test plan. Set it to failed and link it with a JIRA bug ID.
2. Click "Test Report", "Failed Test Cases ", and click the Excel icon to export the failed test cases list.
3. In the exported spreadsheet for failed test cases which have bugs linked, the ID of "Bugs (ID : Summary)" shows something like a database index:
1348741:FileType is not working
It's better to show the original bug ID, like this:
HMC3000KT-2046:FileType is not working
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files? file icon resultsByStatus.php [^] (28,150 bytes) 2015-01-23 04:54
? file icon jirasoapInterface.class.php [^] (15,754 bytes) 2015-01-26 04:33

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022541)
fman (administrator)
2015-01-24 18:50
edited on: 2015-01-24 19:33

Thanks for your help

Just few words about
>> This issue maybe applicable to JIRA only.
>> I am not sure since we don't use any other bug tracking system
we have developer a GENERIC system to interact with issue trackers, then
the field on execution_bugs table CAN NOT HAVE different meaning for differents issue tracker.

(0022544)
fman (administrator)
2015-01-24 19:35
edited on: 2015-01-24 19:44

Issue seems to be related to buildViewBugLink().
Your solution is OK.
thanks again

I've fixed on REST interface getIssue() method.
with this there is no need of your fix.
Anyway I'm going to check with other issue trackers.

(0022545)
fman (administrator)
2015-01-24 19:49

till know verified on jira with rest interface.
more check is needed
(0022556)
swang3 (reporter)
2015-01-26 04:33

Add fix for SOAP interface as well.
(0022658)
fman (administrator)
2015-02-07 10:53

1.9.13 released 20150207

- Issue History
Date Modified Username Field Change
2015-01-23 04:54 swang3 New Issue
2015-01-23 04:54 swang3 File Added: resultsByStatus.php
2015-01-24 18:50 fman Note Added: 0022541
2015-01-24 18:50 fman QA Team - Task Workflow Status => TBD
2015-01-24 18:50 fman Summary Incorrect bug ID in exported Excel spreadsheet (For JIRA only?) => Incorrect bug ID in exported Excel spreadsheet
2015-01-24 18:52 fman Fixed in Version => 1.9.13 (2015 #1)
2015-01-24 19:17 fman Fixed in Version 1.9.13 (2015 #1) =>
2015-01-24 19:33 fman Note Edited: 0022541 View Revisions
2015-01-24 19:35 fman Note Added: 0022544
2015-01-24 19:44 fman Note Edited: 0022544 View Revisions
2015-01-24 19:49 fman Note Added: 0022545
2015-01-24 19:49 fman Status new => resolved
2015-01-24 19:49 fman Fixed in Version => 1.9.13 (2015 #1)
2015-01-24 19:49 fman Resolution open => fixed
2015-01-24 19:49 fman Assigned To => fman
2015-01-24 19:49 fman Relationship added child of 0006609
2015-01-26 04:33 swang3 File Added: jirasoapInterface.class.php
2015-01-26 04:33 swang3 Note Added: 0022556
2015-02-07 10:53 fman Note Added: 0022658
2015-02-07 10:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker