Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006896TestLinkAPI - XMLRPCpublic2015-01-20 02:332015-01-26 18:47
Reporterswang3 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006896: XML-RPC API - add keywords to test case
Descriptionadd keywords to test case
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon xmlrpc.class.php [^] (231,640 bytes) 2015-01-26 13:57

- Relationships
related to 0006907closedfman XML-RPC API - Remove keywords from a test case set 
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022553)
fman (administrator)
2015-01-25 18:57

https://gitorious.org/testlink-ga/testlink-code/commits/98837657b336a8b5bb6b597500f3fcfa705bbbd2 [^]
(0022557)
swang3 (reporter)
2015-01-26 13:59

Thanks, with your fix, it's very easy to write the API for remove keywords. I have the tested it with Python. It works fine. I have 'removeTestCaseKeywords' attached. However, maybe you can consider a refactor since most of the code can be reused.
Line 6471 to line 6532.
Line 6602.
(0022562)
fman (administrator)
2015-01-26 18:20

Please stop adding sentence like '...it's very easy ...', because just seems you try to make the developer feel like a moron.
Better a sentence like:
Hi, I've attached the removeTestCaseKeywords, hope this can help.

I will give a look and provide feedback
(0022563)
fman (administrator)
2015-01-26 18:23

Other thing:
why if I've created an specific ticket for removeTestCasesKeywords(); you have used this ticket? This is not an ordered way to work

- Issue History
Date Modified Username Field Change
2015-01-20 02:33 swang3 New Issue
2015-01-25 18:53 fman Issue cloned: 0006907
2015-01-25 18:53 fman Relationship added related to 0006907
2015-01-25 18:53 fman QA Team - Task Workflow Status => TBD
2015-01-25 18:53 fman Summary Set/Remove keywords for a test case => add keywords to test case
2015-01-25 18:53 fman Description Updated View Revisions
2015-01-25 18:56 fman Summary add keywords to test case => XML-RPC API - add keywords to test case
2015-01-25 18:57 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-01-25 18:57 fman Fixed in Version => 1.9.13 (2015 #1)
2015-01-25 18:57 fman Note Added: 0022553
2015-01-25 18:57 fman Status new => resolved
2015-01-25 18:57 fman Resolution open => fixed
2015-01-25 18:57 fman Assigned To => fman
2015-01-25 18:58 fman Relationship added child of 0006609
2015-01-26 13:57 swang3 File Added: xmlrpc.class.php
2015-01-26 13:59 swang3 Note Added: 0022557
2015-01-26 18:20 fman Note Added: 0022562
2015-01-26 18:23 fman Note Added: 0022563
2015-01-26 18:47 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker