Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006884TestLinkTest Executepublic2015-01-14 01:462015-03-10 13:25
Reporterswang3 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityhave not tried
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006884: Link to set execution status for related test case in execution mode.
DescriptionSimilar feature as 0006876.

There is a relation list for a test case. It would be better to have a link (for test cases in the list) to execute related test cases to improve the test efficiency.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files? file icon exec_tc_relations.inc.tpl [^] (1,751 bytes) 2015-01-28 08:37
? file icon exec_tc_relations.inc - Copy.tpl [^] (1,800 bytes) 2015-01-28 08:57

- Relationships
related to 0006990closedfman Go to execute test case link is not working 
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022488)
fman (administrator)
2015-01-14 13:10

Dear user
do not try to save YOUR TIME WHILE REPORTING generating more
work for development saying ... is similar to ...
please do copy and paste if needed (sometimes is better).
(0022492)
swang3 (reporter)
2015-01-14 14:23

Sorry, I will try to improve it next time.
(0022539)
fman (administrator)
2015-01-24 15:49

Closing till requirement will be improved
(0022548)
swang3 (reporter)
2015-01-25 01:49

Please keep it opened since we are planning to contribute to this one as well.

Clarification on this request:
When a test case have a relation test case list, in the execution mode, it would be helpful if we can have "an execution button" before each related test case. By doing this, tester can directly enter the test result by clicking this button without going to the left panel and search for this test case and then execute it.
(0022574)
swang3 (reporter)
2015-01-28 08:58

Enhanced in attached file: exec_tc_relations.inc - Copy.tpl
Line 8-9
Line 23-31
(0022583)
fman (administrator)
2015-01-29 06:38

Refactoring is needed to provide a better message when related TEST CASE is not present on context (test plan,platform,build) and user try to access exec feature from icon.
doing first commint anyway

Thanks for help

- Issue History
Date Modified Username Field Change
2015-01-14 01:46 swang3 New Issue
2015-01-14 13:10 fman Note Added: 0022488
2015-01-14 14:23 swang3 Note Added: 0022492
2015-01-24 15:49 fman Note Added: 0022539
2015-01-24 15:49 fman QA Team - Task Workflow Status => TBD
2015-01-24 15:49 fman Status new => closed
2015-01-24 15:49 fman Assigned To => fman
2015-01-24 15:49 fman Resolution open => suspended
2015-01-25 01:49 swang3 Note Added: 0022548
2015-01-25 01:49 swang3 Status closed => assigned
2015-01-25 01:49 swang3 Resolution suspended => reopened
2015-01-28 08:37 swang3 File Added: exec_tc_relations.inc.tpl
2015-01-28 08:57 swang3 File Added: exec_tc_relations.inc - Copy.tpl
2015-01-28 08:58 swang3 Note Added: 0022574
2015-01-29 06:38 fman Note Added: 0022583
2015-01-29 06:40 fman Summary Need a link to set execution status for related test case in execution mode. => Link to set execution status for related test case in execution mode.
2015-01-29 06:41 fman Relationship added child of 0006609
2015-01-29 06:41 fman Fixed in Version => 1.9.13 (2015 #1)
2015-03-10 13:25 fman Relationship added related to 0006990



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker