Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006876TestLinkTest Execution - Bulk Modepublic2015-01-05 07:282015-02-07 10:52
Reporterswang3 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006876: Link to set execution status for a single test case when working in Bulk Mode
DescriptionIn the bulk mode, when a test case is failed, we may need to enter into this test case and link the bug ID to it;
When a test case is blocked, we may need to enter into this test case and set a block reason (can be a customized field) for this.

However, this would be time consuming since you have to find the test case in the left tree and click into it.

The test case link in the bulk mode only shows the detail information of this test case.
Is it possible to add a test case execution link side by side to the test case link in bulk mode to enter these information?
Steps To ReproduceEnter 'Test Execution", select the last level test suite to enter Bulk execution mode.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon bulk-tl.png [^] (62,730 bytes) 2015-01-06 08:04


png file icon cotr.png [^] (97,777 bytes) 2015-01-06 08:08


? file icon execSetResults.tpl [^] (19,298 bytes) 2015-01-28 08:12
? file icon execSetResults - Copy.tpl [^] (19,320 bytes) 2015-01-28 08:58
png file icon bulk-with-popup.png [^] (59,333 bytes) 2015-01-31 08:21

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022450)
fman (administrator)
2015-01-05 21:10

unfortunately requirement is far from clear.
Please provide better step by step to reproduce, and undertand whats happening.

May be a better option for you is to use save result and go to next test case.
ATTENTION: this cycle test cases ONLY INSIDE a Test suite.
(0022454)
swang3 (reporter)
2015-01-06 02:52
edited on: 2015-01-06 02:53

1. Enter 'Test Execution", select the last level test suite to enter Bulk execution mode. You will see all test cases listed at right.
2. Under the "Test Case" Column, you can click the link and enter the detail view of this test case, but this is not the execution view of this test case. However, if you want to link a bug to this execution of if you want to set a customized field (for instance, block reason) for the execution result, you have to click the test case at the left side (tree view) and enter the execution view for this test case.
3. The requirement is that we should have a button at right side to enter the execution view of a test case. Or we can change the current test case view to execution view of this test case when click the test case link.
We like to use bulk view since it's efficient.
Not sure if this makes sense.

(0022456)
fman (administrator)
2015-01-06 07:52
edited on: 2015-01-06 08:08

The overview (info you get about test cases) you get on right side of screen when enter bulk exec mode is the same at 99% that you have on left side tree.
(test case version is not displayed on tree).
Adding the button is IMHO duplicate work, because you can access exec feature for each test case from tree .
Only difference is that you do not have to move to the tree.

If you want to contribute with this feature, I will review the code.
IMHO you can get code to implement this using code present in feature
'Assign Test Case execution task'
(see attached image)

A different and more complicated implementation is to provide what seems to be a tabular ( that resembles unfortunately an excel sheet) execution mode.

(0022457)
swang3 (reporter)
2015-01-06 09:23

It's inconvenient to click the test case in the left side.
* You have to search for the test case on the left side tree.
* When you click the test case on the left side, it will exit bulk execution mode without saving (The new test case execution page will override the original bulk execution page.). It's better to still stay in the bulk execution mode.
Maybe we don't need to add a new button. Is it easier to just change the current test case link on the right side to execution view instead of test specification view? That would solve this issue.
(0022458)
fman (administrator)
2015-01-06 09:36

>> Is it easier to just change the current test case link on the right side to >> execution view instead of test specification view? That would solve this issu
Absolutely no.
An existent feature can not be changed, because this will generate another issue for users that already use it.
(0022459)
swang3 (reporter)
2015-01-06 09:43

Thanks, then looks like a new button is a better solution.
(0022460)
fman (administrator)
2015-01-06 09:55

OK, will wait for your contribution to review it
(0022477)
swang3 (reporter)
2015-01-13 07:50

Note for myself: This feature is needed in "Single Mode" for test cases in relation list as well.
(0022478)
fman (administrator)
2015-01-13 12:56

@user
The approach you are using is considered bad practice on issue reporting, because you are using ONE TICKET FOR 2 diff. Requirements, please avoid it.
(0022489)
fman (administrator)
2015-01-14 13:13

Any news about your contribution?
(0022491)
swang3 (reporter)
2015-01-14 14:21

Since I don't know PHP, I have to rely on a developer in our tool team. He has promised to contribute but have not committed a target date on this. I will keep tracking on this and will let you know once we have progress.
(0022555)
swang3 (reporter)
2015-01-26 01:34

We are working on this. I will let you know once it works on my setup.
(0022573)
swang3 (reporter)
2015-01-28 08:12
edited on: 2015-01-28 08:59

Enhanced in attached file: execSetResults - Copy.tpl
Line 40-41
Line 426-434

(0022591)
fman (administrator)
2015-01-31 08:14
edited on: 2015-01-31 08:22

see bulk-with-popup.png for final result on GUI
Thanks for helping

(0022592)
fman (administrator)
2015-01-31 08:30

Commit:
https://gitorious.org/testlink-ga/testlink-code/commits/73fd2715c045e1569c125c6335b2cb095970e483 [^]
(0022656)
fman (administrator)
2015-02-07 10:52

1.9.13 released 20150207

- Issue History
Date Modified Username Field Change
2015-01-05 07:28 swang3 New Issue
2015-01-05 11:01 fman QA Team - Task Workflow Status => TBD
2015-01-05 11:01 fman Description Updated View Revisions
2015-01-05 21:10 fman Note Added: 0022450
2015-01-06 02:52 swang3 Note Added: 0022454
2015-01-06 02:53 swang3 Note Edited: 0022454 View Revisions
2015-01-06 07:52 fman Note Added: 0022456
2015-01-06 08:04 fman Note Edited: 0022456 View Revisions
2015-01-06 08:04 fman File Added: bulk-tl.png
2015-01-06 08:08 fman Note Edited: 0022456 View Revisions
2015-01-06 08:08 fman Note View State: 0022456: public
2015-01-06 08:08 fman File Added: cotr.png
2015-01-06 08:09 fman Status new => feedback
2015-01-06 09:23 swang3 Note Added: 0022457
2015-01-06 09:23 swang3 Status feedback => new
2015-01-06 09:36 fman Note Added: 0022458
2015-01-06 09:43 swang3 Note Added: 0022459
2015-01-06 09:55 fman Note Added: 0022460
2015-01-13 07:50 swang3 Note Added: 0022477
2015-01-13 12:56 fman Note Added: 0022478
2015-01-14 13:13 fman Note Added: 0022489
2015-01-14 14:21 swang3 Note Added: 0022491
2015-01-25 17:43 fman Status new => feedback
2015-01-26 01:34 swang3 Note Added: 0022555
2015-01-26 01:34 swang3 Status feedback => new
2015-01-28 08:12 swang3 File Added: execSetResults.tpl
2015-01-28 08:12 swang3 Note Added: 0022573
2015-01-28 08:58 swang3 File Added: execSetResults - Copy.tpl
2015-01-28 08:59 swang3 Note Edited: 0022573 View Revisions
2015-01-29 06:42 fman Summary Need a link to set execution status for a single test case in Bulk Mode => Link to set execution status for a single test case when working in Bulk Mode
2015-01-31 08:14 fman Note Added: 0022591
2015-01-31 08:17 fman File Added: bulk-tl-with-singleexec.png
2015-01-31 08:17 fman Note Edited: 0022591 View Revisions
2015-01-31 08:18 fman File Deleted: bulk-tl-with-singleexec.png
2015-01-31 08:21 fman File Added: bulk-with-popup.png
2015-01-31 08:22 fman Note Edited: 0022591 View Revisions
2015-01-31 08:30 fman Note Added: 0022592
2015-01-31 08:30 fman Status new => resolved
2015-01-31 08:30 fman Fixed in Version => 1.9.13 (2015 #1)
2015-01-31 08:30 fman Resolution open => fixed
2015-01-31 08:30 fman Assigned To => fman
2015-01-31 08:31 fman Relationship added child of 0006609
2015-02-07 10:52 fman Note Added: 0022656
2015-02-07 10:52 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker