Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006850TestLinkReports - Failed/Blocked Test Casespublic2014-12-22 10:112014-12-31 14:22
Reportermannobi 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006850: In 'Reports and Metrics' section the direct link to Failed/Blocked/Not Run Test Cases doesn't work
DescriptionWhen opening the hyperlink the generation of the page is aborted. The error reported is

ABORTING - UNKNOWN TYPE:list_tc_failed
Additional Informationin lnl.php the section of the code involved in the generation of the page is commented

      // case 'list_tc_failed':
      // case 'list_tc_blocked':
      // case 'list_tc_not_run':
      // $param = "&tproject_id={$args->tproject_id}&tplan_id={$args->tplan_id}&format=0";
          // $what2launch = $cfg['url'] ."&apikey=$args->apikey{$param}";
      // break;

This is the reason of the issue. Why is this section commented? Is there any reason?
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0022408)
fman (administrator)
2014-12-22 11:27

Dear Sir:
Please update to latest code from gitorious (branch 1.9), install in sandbox, retest and provide feedback
(0022409)
mannobi (reporter)
2014-12-22 12:47

Same issue. Present also in the demo you have online.
(0022413)
fman (administrator)
2014-12-22 21:25

seems piece of code was commented by error

- Issue History
Date Modified Username Field Change
2014-12-22 10:11 mannobi New Issue
2014-12-22 11:27 fman Note Added: 0022408
2014-12-22 11:28 fman Assigned To => fman
2014-12-22 11:28 fman Status new => feedback
2014-12-22 12:47 mannobi Note Added: 0022409
2014-12-22 12:47 mannobi Status feedback => assigned
2014-12-22 21:25 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-12-22 21:25 fman Note Added: 0022413
2014-12-22 21:25 fman Status assigned => resolved
2014-12-22 21:25 fman Fixed in Version => 1.9.13 (2015 #1)
2014-12-22 21:25 fman Resolution open => fixed
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker