Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006837TestLinkTest Execute - Navigatorpublic2014-12-13 22:042014-12-31 14:22
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006837: Access Test Execution from Test Case Specification seems to be lost
DescriptionWhen I want to access a test execution from a testcase specification ("testplan usage" section), the displayed page don't show execution information about the testcase.
With TL 1.9.7, the execution information about the testcase was displayed.
Steps To Reproduce1 - Create a TestCase TC1.
2 - Create a TestPlan TP1
3 - Create a build for this TP1
4 - Add the TC1 to the TP1
5 - Use "Test Specification" page to consult TC1 content and click on the lightning near from TP1 (in test plan usage section) to goto the test execution

==> The test execution page for the TC1 is not displayed, only information about the TP and build.
Additional InformationThis seems to be a regression (TL 1.9.7 => OK, 1.9.10 =>KO, TestLink 1.9.13 [DEV] (Stormbringer) 20141019 => KO)
TagsNo tags attached.
Database (MySQL,Postgres,etc)Any
BrowserChrome
PHP Version5.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon tl197-01.png [^] (22,763 bytes) 2014-12-14 09:17


png file icon tl1.9.13-20141214-01.png [^] (19,584 bytes) 2014-12-14 09:38


png file icon gotoexec.png [^] (152,168 bytes) 2014-12-14 11:32

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022362)
fman (administrator)
2014-12-14 09:12
edited on: 2014-12-14 09:39

>> The test execution page for the TC1 is not displayed,
>> only information about the TP and build.
What is really happening is that feature to execute test cases is present, instead of open directly the execution section on the specific test case.

What was the info displayed on 1.9.7? Your description id far from clear.
This is one of few situation when a text and image are needed.
Anyway I've just installed 1.9.7
What happens when I click on lightning (see attached image)?
The same that happens on 1.9.13

ATTENTION
Two things has happened on latest versions (I think same is valid at least for 1.9.12), that can create a little bit confusion:
1. help (useless IMHO) on right page has been replaced with info about test plan and build, that are the context on with execution is going to happen.

2. page description has changed


Need to make clear in navigator, that feature is test execution.
Solution is => see image tl1.9.13-20141214-01.png

(0022363)
fman (administrator)
2014-12-14 09:44

https://gitorious.org/testlink-ga/testlink-code/commits/a348d2abeaa9ca2f3bce371c0d4db71407664803 [^]
(0022368)
Mr.Bricodage (updater)
2014-12-14 21:36

fman,

thank you for this feedback and code modification.

Regards,

- Issue History
Date Modified Username Field Change
2014-12-13 22:04 Mr.Bricodage New Issue
2014-12-14 09:00 fman Note Added: 0022361
2014-12-14 09:05 fman QA Team - Task Workflow Status => TBD
2014-12-14 09:05 fman Severity major => minor
2014-12-14 09:12 fman Note Added: 0022362
2014-12-14 09:17 fman File Added: tl197-01.png
2014-12-14 09:19 fman Note Edited: 0022362 View Revisions
2014-12-14 09:38 fman Note Edited: 0022362 View Revisions
2014-12-14 09:38 fman Note Deleted: 0022361
2014-12-14 09:38 fman Note View State: 0022362: public
2014-12-14 09:38 fman File Added: tl1.9.13-20141214-01.png
2014-12-14 09:39 fman Note Edited: 0022362 View Revisions
2014-12-14 09:40 fman Fixed in Version => 1.9.13 (2015 #1)
2014-12-14 09:40 fman Summary Access Test Execution from TestCase Specification => Access Test Execution from Test Case Specification seems to be lost
2014-12-14 09:44 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-12-14 09:44 fman Note Added: 0022363
2014-12-14 09:44 fman Status new => resolved
2014-12-14 09:44 fman Resolution open => fixed
2014-12-14 09:44 fman Assigned To => fman
2014-12-14 09:44 fman Relationship added child of 0006609
2014-12-14 11:32 fman File Added: gotoexec.png
2014-12-14 21:36 Mr.Bricodage Note Added: 0022368
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker