Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006814TestLinkTest Specificationpublic2014-12-04 08:422015-02-07 10:53
ReporterMartinGicom 
Assigned Tofman 
PrioritynoneSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006814: Test Case search - add option to search value on multiple fields
DescriptionIf you try to find a testcase by term and you don't know which field contains this term you have to fill in all fields.
It would be much easier if there is one central Input field from where you go through all fields like in Mantis
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesjpg file icon Testlink_search.JPG [^] (42,466 bytes) 2014-12-04 08:42


jpg file icon Mantis_search.JPG [^] (11,500 bytes) 2014-12-04 08:42

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022319)
fman (administrator)
2014-12-04 09:42
edited on: 2014-12-04 09:45

Dear sir:
1. issue subject is to vague that is useless.
2. in addition I can not work with a requirement that consists just on two images, an no other clear detail

In this situation may be developer can 'extract the info', but this kind of approach does not scale (IMHO), and is not what I use on this project

(0022320)
MartinGicom (reporter)
2014-12-04 09:47

Subject: Optimize Search by reduce field to one Input Box over all fields
(0022321)
MartinGicom (reporter)
2014-12-04 11:06

The Test case search should only consists of nine fields
• Testcase ID
• Version
• Input Box for the Term you looking for (1)
• Creation Date From
• Creation Date till
• Change Date from
• Change Date Till
• Test Priority
• Req Dok ID
All Terms you entered into (1) should be looked up in the fields

• Test Case
o Summary
o Title
o Precondition
o Steps
o Expected Result
o Keywords
(0022322)
fman (administrator)
2014-12-04 16:47

This will not be the final implementation, because this will break old TestLink versions without a good reason.
(0022461)
fman (administrator)
2015-01-06 15:02

added jolly field
search is done LIKE, in or mode in following fields
o Summary
o Title
o Precondition
o Steps
o Expected Result

these input values if provided are overwrited with JOLLY
(0022462)
fman (administrator)
2015-01-06 15:03

https://gitorious.org/testlink-ga/testlink-code/commits/389f4b2e5498fc67e3c3762e8640edf13e751ef0 [^]
(0022660)
fman (administrator)
2015-02-07 10:53

1.9.13 released 20150207

- Issue History
Date Modified Username Field Change
2014-12-04 08:42 MartinGicom New Issue
2014-12-04 08:42 MartinGicom File Added: Testlink_search.JPG
2014-12-04 08:42 MartinGicom File Added: Mantis_search.JPG
2014-12-04 09:42 fman Note Added: 0022319
2014-12-04 09:42 fman QA Team - Task Workflow Status => TBD
2014-12-04 09:42 fman Priority normal => none
2014-12-04 09:43 fman Note Edited: 0022319 View Revisions
2014-12-04 09:45 fman Note Edited: 0022319 View Revisions
2014-12-04 09:47 MartinGicom Note Added: 0022320
2014-12-04 11:06 MartinGicom Note Added: 0022321
2014-12-04 16:47 fman Note Added: 0022322
2014-12-04 16:48 fman Severity minor => feature request
2014-12-04 16:48 fman Category Usability => Test Specification
2014-12-04 16:48 fman Summary Search should be optimized => Test Case search - add option to search value on multiple fields
2015-01-06 15:02 fman Note Added: 0022461
2015-01-06 15:03 fman Note Added: 0022462
2015-01-06 15:03 fman Status new => resolved
2015-01-06 15:03 fman Fixed in Version => 1.9.13 (2015 #1)
2015-01-06 15:03 fman Resolution open => fixed
2015-01-06 15:03 fman Assigned To => fman
2015-01-06 15:03 fman Relationship added child of 0006609
2015-02-07 10:53 fman Note Added: 0022660
2015-02-07 10:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker