Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006799TestLinkRequirement Managementpublic2014-11-27 15:502014-12-31 14:22
ReporterDPower 
Assigned Tofman 
PrioritynoneSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006799: Requirements Specification: Display uploaded images in-line in Requirement Scope
DescriptionIn the Requirements Specification, we would like to be able to display images in-line in the Scope section of each requirement.

At present it's possible to upload images and attach them to a requirement, but they are not visible unless clicked and opened.

It's also possible to display an image in-line in the Scope description if you use the Image icon and provide a URL.

However it is not easy to display in-line an uploaded file. Eventually I found that if I observe the URL of the uploaded image and insert that in the Scope, then I can achieve what we want but this is not a convenient method. What I did was put this HTML in the Scope:
<img alt="" src="lib/attachments/attachmentdownload.php?id=4" style="width: 720px; height: 1280px;" />



Request is for an easy way to do this. For example when you click the image icon while editing Scope, an option appears to choose from the uploaded images for that requirement.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006803closedfman Test Case - inline images on summary & preconditions 
related to 0006809closedfman Requirements Report - display images inline & convert TestLink tlInlineImage command 
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022274)
fman (administrator)
2014-11-27 18:31

>> For example when you click the image icon while editing Scope, an option
>> appears to choose from the uploaded images for that requirement.
where ?
if you are using the rich web editor you have to 'play' with it's rules => you need to understand how to interact with FCKeditor and this is not easy because with each new version things can change.
(0022275)
fman (administrator)
2014-11-27 18:34

>> At present it's possible to upload images and attach them to a requirement, >> but they are not visible unless clicked and opened.
this can be fixed because on 1.9.12 (Unfortunately TestLink version that you are using is not provided) on reports images are dispalyed INLINE
Solution can be the same, but this is completely different to display an image inside the scope attribute.
(0022278)
fman (administrator)
2014-11-27 19:50

If enough to proceed this way

1. go to the image you want
2. put the mouse over the image you normally click to open not inline the image, click on mouse right button, select COPY LINK

3. edit scope, click on the icon on RICH WEBEDITOR TOOLBAR that allows you to insert and image, copy url obtained on step 2, in the url input.

4. save
5. you have got the image inline
(0022281)
DPower (reporter)
2014-11-28 13:37

Thank you for the comments.

Just to clarify: In my original post, " For example when you click the image icon while editing Scope, an option appears to choose from the uploaded images for that requirement." I was describing the new feature I would like to be added, not what it does now.

I understand the method described in the post above (0022278), but it would be nice to have something even easier.

My installation is 1.9.9 so I'm trying to upgrade to 1.9.12
(0022288)
fman (administrator)
2014-11-30 10:22

https://gitorious.org/testlink-ga/testlink-code/commits/54a07081c6e4f9cc329e7dba3175341eab8d8c99 [^]

- Issue History
Date Modified Username Field Change
2014-11-27 15:50 DPower New Issue
2014-11-27 18:31 fman Note Added: 0022274
2014-11-27 18:34 fman Note Added: 0022275
2014-11-27 19:50 fman Note Added: 0022278
2014-11-27 19:51 fman QA Team - Task Workflow Status => TBD
2014-11-27 19:51 fman Priority normal => none
2014-11-28 13:37 DPower Note Added: 0022281
2014-11-29 10:09 fman Issue cloned: 0006803
2014-11-29 10:09 fman Relationship added related to 0006803
2014-11-30 10:15 fman Summary Requirements Specification: Display uploaded images in-line in the description (the Scope) => Requirements Specification: Display uploaded images in-line in Requirement Scope
2014-11-30 10:15 fman Description Updated View Revisions
2014-11-30 10:16 fman Category New Feature => Requirement Management
2014-11-30 10:22 fman Assigned To => fman
2014-11-30 10:22 fman Status new => work in progress
2014-11-30 10:22 fman Note Added: 0022288
2014-11-30 10:22 fman Product Version => 1.9.12 (2014 Q3)
2014-11-30 10:23 fman Relationship added child of 0006609
2014-11-30 10:55 fman Relationship added related to 0006809
2014-12-03 22:21 fman Status work in progress => new
2014-12-03 22:21 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-12-03 22:21 fman Status new => resolved
2014-12-03 22:21 fman Fixed in Version => 1.9.13 (2015 #1)
2014-12-03 22:21 fman Resolution open => fixed
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker