Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006760TestLinkRolespublic2014-11-17 12:442014-12-31 14:22
Reporterenlaceptolosa 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindows ServerOS Version2008 R2
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006760: Edit TestProject user roles at Project level - Spanish
DescriptionHi,

We setup a new role "Jefe de Proyecto" and we performed the following configuration to the role(IMG 1).

With an Administrator account, we changed the Project Role type for a specific user to Jefe Proyecto (IMG 2). This change was made at TestProject level and not user level.

When accesing "Assign role to a user" with the selected user to a specific project we only see the "Test Plan role assignment" and missing the "Test Project role assignament"(IMG 3).

If we change the user type by accesing "userEdit" from Tester to Jefe de Proyecto (IMG 4), indeed it shows the two tabs "Assign roles to a TestProject".

What we need is to be able to see the two columns in user assignment without having to change the user global access type. The behaviour that had in v1.9.1

Please, let me know if you need aditional information, I will be more than happy to provide it to you.

Thank you for your help. Regards
Steps To ReproduceCreate new role
Assign the role to a determinated user for specific project
Access the project with that specific user
Access "assign roles to a"
TagsNo tags attached.
Database (MySQL,Postgres,etc)SQL Server 2008
BrowseriExplorer 8
PHP Version5.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon IMG 1.PNG [^] (79,643 bytes) 2014-11-17 12:44


png file icon IMG 2.png [^] (33,367 bytes) 2014-11-17 12:44


png file icon IMG 3.png [^] (29,557 bytes) 2014-11-17 12:44


png file icon IMG 4.png [^] (34,455 bytes) 2014-11-17 12:44


png file icon IMG 5.png [^] (30,572 bytes) 2014-11-17 12:44

- Relationships
related to 0006716closedfman Access to assign role management functionality for granted users 

-  Notes
(0022176)
fman (administrator)
2014-11-17 13:04

Please
1. get latest code from gitorious (branch 1.9)
2. install on MySQL
3. use ONLY english
4. try to reproduce
5. provide feedback
(0022187)
enlaceptolosa (reporter)
2014-11-18 05:55

Hi fman,

I tried the same operation that you mention and happens the same thing.
I will try to better explain the operation that we need to perform:

- all the user by default have the "no rights" roles
- instead to grant user roles to the application (global application roles) we want to grant them priviledges over the projects in that way the will only see the projects and plans that were assigned to them.
- for regular users "testers" this works great however we have some roles with more priviledges like leader, chif of department, project manager
- this roles needs to be able to assign users to test projects however when accessing the "assign roles" functionality we only visualize the tab "assign users for test plans" witch only retrive the users already assigned to that particular project.
- If we manually activate the "assign user roles to test project" tab this wont work because user has no priviledges, I assume.

The functionality that we have implemented for the "assign roles to" is as follows:
- Assign user roles to TProjects: can see all the users
- Assign user roles to TPlans: it only retrieves those users allready associated with the Project

I imagine that is because of the check rights function that:
- first checks global roles
- if user, has no rights then checks projects roles, then testplan roles

For testplan roles, checks first if it has project roles, if this is true then the application stops checking global rights, if its false then he checks global rights.

We kind need the same check to projects roles in order to be able to assign a testproject user role, even to add new users to the project, keeping global role rights to <no rights> and using the TestProject role to perform operations.

Because if we assign a global user role, the user with high priviledge like project manager, leader etc can see all the projects and we do not want this.

I hope this information clarifies the situation, if not I will be more than happy to provide you with more information.

Thank you verry much.
Best regards
(0022188)
enlaceptolosa (reporter)
2014-11-18 05:59

I have to add that users with ADMIN role will be the only users to see everything, as it was.
(0022193)
fman (administrator)
2014-11-18 06:12

I'm going to read carefully your detailed explanation in next days and try to provide an answer

regards
(0022194)
enlaceptolosa (reporter)
2014-11-18 08:24

Thank you, I will be waiting your response.

Greetings from Spain.
(0022208)
fman (administrator)
2014-11-18 20:01

would you mind to try with this and provide feedback ?
https://gitorious.org/testlink-ga/testlink-code/commits/26dee195ed2c5550650bb4cd5a0529e3abaf39cd [^]
(0022211)
enlaceptolosa (reporter)
2014-11-19 08:33

Thank you @fman, the modificación worked!

You may now close this ticket.

Thank you very much for your help.
(0022212)
fman (administrator)
2014-11-19 13:10

great!

- Issue History
Date Modified Username Field Change
2014-11-17 12:44 enlaceptolosa New Issue
2014-11-17 12:44 enlaceptolosa File Added: IMG 1.PNG
2014-11-17 12:44 enlaceptolosa File Added: IMG 2.png
2014-11-17 12:44 enlaceptolosa File Added: IMG 3.png
2014-11-17 12:44 enlaceptolosa File Added: IMG 4.png
2014-11-17 12:44 enlaceptolosa File Added: IMG 5.png
2014-11-17 13:04 fman Note Added: 0022176
2014-11-18 05:55 enlaceptolosa Note Added: 0022187
2014-11-18 05:59 enlaceptolosa Note Added: 0022188
2014-11-18 06:12 fman Note Added: 0022193
2014-11-18 08:24 enlaceptolosa Note Added: 0022194
2014-11-18 16:03 fman Relationship added related to 0006716
2014-11-18 20:01 fman Note Added: 0022208
2014-11-18 20:01 fman Assigned To => fman
2014-11-18 20:01 fman Status new => feedback
2014-11-18 20:01 fman QA Team - Task Workflow Status => TBD
2014-11-19 08:33 enlaceptolosa Note Added: 0022211
2014-11-19 08:33 enlaceptolosa Status feedback => assigned
2014-11-19 13:10 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-11-19 13:10 fman Note Added: 0022212
2014-11-19 13:10 fman Status assigned => resolved
2014-11-19 13:10 fman Resolution open => fixed
2014-12-18 20:25 fman Fixed in Version => 1.9.13 (2015 #1)
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker