Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006754TestLinkReportspublic2014-11-14 19:382014-12-31 14:22
Reporterbabaluis 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformChromeOSLinuxOS Version12.04
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006754: Test Suite Heading Prints With Text Style, Not Header Style
DescriptionWhen printing a Test Report, with all options checked, the top level test suite heading is rendered with body text style instead of heading style.
Steps To ReproduceGenerate a Test Report with all options checked.
Additional InformationI examined the HTML source and noticed that the test suite name was being printed as follows:
<h0 class='doclevel'>1.1.Product Verification</h0>
There is no h0 style defined in the css file. I looked in /lib/functions/print.inc.php and found the function that generates the 'h0'. The function is 'renderTestSuiteNodeForPrinting'. When the indent level is 1, the docHeadingLevel is made zero. This results in 'h0' as the heading level. I fixed this temporarily in my installation by adding another limiting statement to limit the lower bound of docHeadingLevel to 1, and inserted this statement just above the one that limits the upper bound to 6 (approx. line 1508).
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.3.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon print.inc.php [^] (66,217 bytes) 2014-11-14 21:39

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022153)
fman (administrator)
2014-11-14 20:59

>> upper bound to 6 (approx. line 1508).
this is not the way to provide help (at least on this project)
can you attach whole modified code ?
(0022156)
babaluis (reporter)
2014-11-14 21:41

I uploaded my fixed file. However I am a c programmer, not a php programmer and do not believe this is the correct way to fix it. It appears there is a counter that is not initialized or handled properly. My fix is intended to be temporary until someone with more expertise can fix it properly.
(0022159)
fman (administrator)
2014-11-15 08:40

OK, Thanks for your help

- Issue History
Date Modified Username Field Change
2014-11-14 19:38 babaluis New Issue
2014-11-14 20:59 fman Note Added: 0022153
2014-11-14 21:39 babaluis File Added: print.inc.php
2014-11-14 21:41 babaluis Note Added: 0022156
2014-11-15 08:40 fman Note Added: 0022159
2014-11-16 10:28 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-11-16 10:28 fman Status new => resolved
2014-11-16 10:28 fman Fixed in Version => 1.9.13 (2015 #1)
2014-11-16 10:28 fman Resolution open => fixed
2014-11-16 10:28 fman Assigned To => fman
2014-11-16 10:29 fman Relationship added child of 0006609
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker