Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006729TestLinkFilter on Keyword - Test Specificationpublic2014-11-03 12:162015-01-31 11:31
Reportervincam 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006729: Keyword´s not working properly
DescriptionThe keyword filter isn't working properly.
I update the TL version from 1.9.7 and the test suites was created on 1.9.7
Then used a keyword(CHL). Assigned some test cases.
Used the filter by setting CHL and clicked apply.
When i clicked i saw some unwanted folders, not sure from where they came.
Additional InformationThe same issue found in http://mantis.testlink.org/view.php?id=6682 [^] closed
I´m using the latest code from gitorious (BRANCH 1.9)
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
BrowserFirefox
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon Keyword issue.jpg [^] (174,897 bytes) 2014-11-03 12:16


jpg file icon Keyword issue 2.jpg [^] (177,684 bytes) 2014-11-03 15:35


jpg file icon Keyword issue 3.jpg [^] (141,461 bytes) 2014-11-03 19:32

- Relationships

-  Notes
(0022073)
fman (administrator)
2014-11-03 14:16

1. issue subject is too generic and useless => try next time to provide something useful

2. provide detailed steps to reproduce instead of just pointing to an issue where detailed info was requested and NEVER PROVIDED.
Give a look to forum to understand LEVEL OF DETAIL required in order to an issue be put on working queu

closing till info will not be provided
(0022074)
fman (administrator)
2014-11-03 14:17

1. info provided is not enough
2. TEST and FEEDBACK ON FRESH INSTALLATION (CLEAN DB) is neeed
(0022075)
vincam (reporter)
2014-11-03 15:34

Thanks in advance for your analyses!

I'm sorry for the mistake but to me the steps to reproduce is very clear and I do all the tips related on the Bug closed. And there is the same issue previously related.

Steps to Reproduce:
1. Go to Idle screen
2. Select Keyword Management and Create keyword "zzz" Description: "xxx" -> Save
3. Assign to a test suite and save
4. On this screen select the keyword "zzz" on the filters keyword
5. Select apply
6. See the wrong behavior: Some unwanted folder appears on the tree.
(0022076)
fman (administrator)
2014-11-03 18:42
edited on: 2014-11-03 18:44

this is the kind of details I need

1. get latest code from gitorious (Branch 1.9)
2. do FRESH INSTALL
3. create Test Project KOALA
4. import test spec using XML provided on issue 0006683: sample data
5. create 3 Keywords: K1,K2,K3
6. Go to testlink desktop
7. Click on Assign Keywords
8. On tree on LEFT SIDE of screen click on test suite TS-100
9. On RIGHT side of screen choose K1 and assign it
   After this operation all TEST CASES inside TS-100 will have K1 assigned.

10. Go to TestLink desktop
11. Click on Test Specification
12. Set keywords filter to K1
13. Apply filter
    Only TS-100 is displayed

(0022077)
vincam (reporter)
2014-11-03 19:32

Hi Fman,

I do all the steps above but a unwanted folder continue appears (I don´t create this folder in my database, to me this is a trash)
please see the picture: Keyword issue 3.jpg in attached.
The folder: j8ba8cfb-ca92-4fa5-83c2-551977d405fb does not exist in my test specification. But when I filter by "any" keyword folders like this appears on the tree. If I select this folder is TestLink try load, after some anythings happens.

Thanks in advance
(0022170)
fman (administrator)
2014-11-16 15:02
edited on: 2014-11-16 15:04

Finally I was able to understand what unwanted folder means!.
In part (50%) is my fault because I've not read carefully note 22077,
in part (50%) depends on how things are explained.
USE HTML TAG BOLD => to make things more visible

In any case UNWANTED is bad description.

Again IMHO effort needed to understand and solve issues is too high due to lack of clear details SINCE START of issue reporting.

I need MORE DETAILED info in order to reproduce.
This seems to be a side effect of fixing issue regarding NULL string on test suites names, related also to a replace on JSON data structure.

(0022205)
vincam (reporter)
2014-11-18 17:32

Fman, Thanks for your effort in understand my issue.
I think now it´s clear!
Do you need more details about it to solve or reproduce this issue?
(0022206)
fman (administrator)
2014-11-18 18:28

I'm not able to reproduce.

- Issue History
Date Modified Username Field Change
2014-11-03 12:16 vincam New Issue
2014-11-03 12:16 vincam File Added: Keyword issue.jpg
2014-11-03 14:16 fman Note Added: 0022073
2014-11-03 14:17 fman QA Team - Task Workflow Status => TBD
2014-11-03 14:17 fman Note Added: 0022074
2014-11-03 14:17 fman Status new => closed
2014-11-03 14:17 fman Assigned To => fman
2014-11-03 14:17 fman Resolution open => unable to reproduce
2014-11-03 15:34 vincam Note Added: 0022075
2014-11-03 15:34 vincam Status closed => assigned
2014-11-03 15:34 vincam Resolution unable to reproduce => reopened
2014-11-03 15:35 vincam File Added: Keyword issue 2.jpg
2014-11-03 18:42 fman Note Added: 0022076
2014-11-03 18:44 fman Note Edited: 0022076 View Revisions
2014-11-03 18:44 fman Note View State: 0022076: public
2014-11-03 18:44 fman Status assigned => feedback
2014-11-03 19:32 vincam Note Added: 0022077
2014-11-03 19:32 vincam Status feedback => assigned
2014-11-03 19:32 vincam File Added: Keyword issue 3.jpg
2014-11-04 22:13 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-11-04 22:13 fman Status assigned => resolved
2014-11-04 22:13 fman Fixed in Version => 1.9.13 (2015 #1)
2014-11-04 22:13 fman Resolution reopened => fixed
2014-11-16 15:02 fman Note Added: 0022170
2014-11-16 15:04 fman Note Edited: 0022170 View Revisions
2014-11-18 17:32 vincam Note Added: 0022205
2014-11-18 18:28 fman Note Added: 0022206
2014-12-31 14:22 fman Status resolved => closed
2015-01-31 11:31 fman Category Keywords => Filter on Keyword - Test Specification



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker