Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006664TestLinkRequirement to Test Case Assignmentpublic2014-10-10 19:122014-12-31 14:22
ReporterAdilson1 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSRHELOS Version5
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006664: When assigning requirement while using a filter, all filtered test cases get assigned and not selected test suite test cases.
DescriptionWhen assigning requirement while using a filter, all filtered test cases get assigned and not selected test suite test cases. When a filter is not used only test cases under the test suite are appropriately assigned to the test requirement.
Steps To Reproduce1.) Click on the "Assign Requirements" in the Project home page
2.) Then select a filter such as Status from the "Status" filter list, and hit Apply.
3.) From the test cases tree on the left, select a sub-test suite.
4.) Once test suite is selected, check the box next to the requirement checked the requirement from the requirements list and select "Assign".

The result is all test cases per the filter settings were added to the requirement instead of only test cases under the selected test suite.

Please see attachment for screen shots.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 24ESR /Chrome/ IE 10
PHP Version5.5.15
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon snagit-capture.png [^] (227,983 bytes) 2014-10-10 19:12


xml file icon ALFA.testproject-deep.xml [^] (4,644 bytes) 2014-10-11 07:35
xml file icon all-req (3).xml [^] (2,000 bytes) 2014-10-11 07:38
xml file icon ALFA.testproject-deep-v02.xml [^] (9,251 bytes) 2014-10-11 07:43
png file icon PilotPT-Project.png [^] (260,515 bytes) 2014-10-13 13:27


xml file icon Pilot PT.testproject-deep.xml [^] (6,325 bytes) 2014-10-13 21:44
xml file icon all-req (4).xml [^] (1,358 bytes) 2014-10-13 21:44

- Relationships

-  Notes
(0021918)
fman (administrator)
2014-10-11 07:36

uploading XML in order to allow people reproduce with low effort.
(0021919)
fman (administrator)
2014-10-11 07:42

>> The result is all test cases per the filter settings were added to the
>> requirement instead of only test cases under the selected test suite.

Q1. Why do you said this?
A1. due to the feedback message?
A2. you have checked and all req has been assigned ?

I've done a test and seems that FEEDBACK message is WRONG, but assignments are done OK.
(0021920)
fman (administrator)
2014-10-11 07:47
edited on: 2014-10-11 07:49

The number provided with feeback is

number of test case x number of req

how many req have you choosen ?


Tested with latest code gitorious (BRANCH 1.9), unable to reproduce

You can try using our demo => demo.testlink.org

(0021928)
Adilson1 (reporter)
2014-10-13 13:25

A1. Yes, the feedback message stated that all test cases in the test plan based on the selected filter, were assigned to the test requirement I checked.

A2. Yes I checked and saw that all test cases were indeed added to the test requirement and not only the ones under the test suite I selected. As I stated, this only occurs when a filter, such as "Status" is used. I selected a Status filter of "Draft" and then hit the Apply button, selected a test suite and then checked only one requirement. The result is all test cases from both of the test suites in the PPT:Pilot PT" project were added to the checked requirement. See second attachment.

I was able to reproduce this on demo.testlink.org using Test Project: "PPT: Pilot PT".
(0021934)
fman (administrator)
2014-10-13 21:42

In order to reproduce use attached XML regarding PPT project, but set ONE TEST CASE STATUS to REWORK.
Then filter with STATUS DRAFT, this will generate 3 test cases in TWO test suites.
Then choose test suite with JUST ONE TEST CASE.
Assign, ALL 3 filtered test cases will be assigned.
(0021935)
fman (administrator)
2014-10-13 21:43

Please get
https://gitorious.org/testlink-ga/testlink-code/commits/431523e59fa85d4da5ed4aa8688fe90a0fa9198b [^]

retest and provide feedback
(0021939)
Adilson1 (reporter)
2014-10-14 15:16

Hi fman, I have tested the fix to the code which I downloaded today. I have tested with no filters and also with several filters and they all produced the correct results. It is now working properly.

Thanks for the quick response.
(0021940)
fman (administrator)
2014-10-15 06:52

great!
if you find TestLinl useful, think about a donation to support our work.
contact testlink.forum@gmail.com
You can donate using PayPal or Flattr

- Issue History
Date Modified Username Field Change
2014-10-10 19:12 Adilson1 New Issue
2014-10-10 19:12 Adilson1 File Added: snagit-capture.png
2014-10-11 07:35 fman File Added: ALFA.testproject-deep.xml
2014-10-11 07:36 fman Note Added: 0021918
2014-10-11 07:38 fman File Added: all-req (3).xml
2014-10-11 07:42 fman Note Added: 0021919
2014-10-11 07:43 fman File Added: ALFA.testproject-deep-v02.xml
2014-10-11 07:45 fman Note View State: 0021919: public
2014-10-11 07:47 fman Note Added: 0021920
2014-10-11 07:48 fman Note View State: 0021920: public
2014-10-11 07:49 fman Note Edited: 0021920 View Revisions
2014-10-11 07:49 fman Assigned To => fman
2014-10-11 07:49 fman Status new => feedback
2014-10-13 13:25 Adilson1 Note Added: 0021928
2014-10-13 13:25 Adilson1 Status feedback => assigned
2014-10-13 13:27 Adilson1 File Added: PilotPT-Project.png
2014-10-13 21:42 fman Note Added: 0021934
2014-10-13 21:43 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-10-13 21:43 fman Note Added: 0021935
2014-10-13 21:43 fman Status assigned => resolved
2014-10-13 21:43 fman Fixed in Version => 1.9.13 (2015 #1)
2014-10-13 21:43 fman Resolution open => fixed
2014-10-13 21:44 fman File Added: Pilot PT.testproject-deep.xml
2014-10-13 21:44 fman File Added: all-req (4).xml
2014-10-14 15:16 Adilson1 Note Added: 0021939
2014-10-15 06:52 fman Note Added: 0021940
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker