Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006646TestLinkAPI - XMLRPCpublic2014-10-06 10:082014-12-31 14:22
Reporterdaniele.cucchi 
Assigned Tofman 
PrioritynoneSeverityfeature requestReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.12 (2014 Q3) 
Fixed in Version1.9.13 (2015 #1) 
Summary0006646: Extend API - XMLRPC Add function "removeAssignement"
DescriptionFrom GUI it is possible to remove assignement previously assigned test case (leaving the "Assgin to" field empty and checking the checkbox of test case, then save). We would appreciate if this could also be done remotely with an XMLRPC API.

The assignTestCaseExecutionTask method (really appreciated!!!) now let only assign test case to existing users.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon xmlrpc.class.php [^] (224,438 bytes) 2014-11-12 13:52
xml file icon Dark side of the moon.testproject-deep.xml [^] (2,882 bytes) 2014-11-14 19:31

- Relationships
child of 0006609closedfman Availables hot-fixes for 1.9.12 & How To get full fixed package from gitorious 

-  Notes
(0022119)
daniele.cucchi (reporter)
2014-11-12 13:53

Added a modified xmlrpc.class.php (made from version 1.9.12) with new unassignTestCaseExecutionTask. This function is basically the same of assignTestCaseExecutionTask without the last step in which the execution is assigned and without the check on operator parameter. Hope this could help in development.
(0022135)
fman (administrator)
2014-11-13 19:20

Because since 1.9.2 execution assignment can be done to multiple testers, operator parameter is needed, unless an option is added to remove ALL tester assignments.
(0022136)
fman (administrator)
2014-11-13 19:40

have you tested your implementation ?
does it work ?
(0022140)
daniele.cucchi (reporter)
2014-11-14 07:20

I have tested on our system which is based on 1.9.11 with some integration of bug fixing from 1.9.12. Since we wanted to remove all assignments it works as expected, but sincerly I did not take in account that execution can now be done to multiple testers.
(0022151)
fman (administrator)
2014-11-14 20:53

Code refactored to avoid duplication
https://gitorious.org/testlink-ga/testlink-code/commits/bd34e46979bf74bcaeb768e015d3cb8f22dd0a08 [^]

- Issue History
Date Modified Username Field Change
2014-10-06 10:08 daniele.cucchi New Issue
2014-10-06 13:42 fman QA Team - Task Workflow Status => TBD
2014-10-06 13:42 fman Priority normal => none
2014-11-12 13:52 daniele.cucchi File Added: xmlrpc.class.php
2014-11-12 13:53 daniele.cucchi Note Added: 0022119
2014-11-13 19:20 fman Note Added: 0022135
2014-11-13 19:40 fman Note Added: 0022136
2014-11-14 07:20 daniele.cucchi Note Added: 0022140
2014-11-14 19:31 fman File Added: Dark side of the moon.testproject-deep.xml
2014-11-14 20:53 fman Note Added: 0022151
2014-11-14 20:54 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-11-14 20:54 fman Status new => resolved
2014-11-14 20:54 fman Fixed in Version => 1.9.13 (2015 #1)
2014-11-14 20:54 fman Resolution open => fixed
2014-11-14 20:54 fman Assigned To => fman
2014-11-14 20:55 fman Relationship added child of 0006609
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker