Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006587TestLinkFilterspublic2014-09-19 10:412015-01-31 11:36
Reporterhwei 
Assigned Tofman 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformlinuxOScentosOS Version6.5
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0006587: MIGRATION ISSUE - we can see all test cases after filtered even it show the number is 0
DescriptionUpgrade test link from 1.9.3 to 1.9.11.
Set some specific criteria in filters under 'Test Execution' and filtered , it show the number is 0 , but we can see all test cases when double click result.
but no such issue in 1.9.3.

expected results:
if test link shows 0 result , user should NOT able to see all test cases.

actual results:
user can see all test cases. this will let use confuse.

Steps To Reproduce1. Click 'Test Execution'
2. Set some specific criteria in filters , just ensure no result.
3. Double click result(which shows 0 result) , all test cases appear.

see: Screenshot-filters.png
TagsNo tags attached.
Database (MySQL,Postgres,etc)5.1.73
Browserchrome
PHP Version5.4.31
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Screenshot-filters.png [^] (66,415 bytes) 2014-09-19 10:42


gz file icon testlink-1911-11.sql.tar.gz [^] (479,984 bytes) 2014-09-23 09:01
png file icon testlink-order.png [^] (99,004 bytes) 2014-09-28 02:20


png file icon testlink-result.png [^] (88,245 bytes) 2014-09-28 02:21


xml file icon fman - test project.testproject-deep (1).xml [^] (3,774 bytes) 2014-09-28 08:28

- Relationships
related to 0006612closedfman Test execution filters destroys tree 

-  Notes
(0021633)
fman (administrator)
2014-09-19 19:32

1. without your Database no action can be done
2. Please do upgrade again from version to version and retest at each migration
to find where things (related to your data) become broken
(0021648)
hwei (reporter)
2014-09-22 10:08
edited on: 2014-09-22 10:36

Thanks for you prompting?
I tested upgrade testlink from 1.9.3 to 1.9.10 one be one , it work on 1.9.4,1.9.6,1.9.8 and 1.9.9 after upgraded with MYSQL DB , but when upgraded from 1.9.9 to 1.9.10 , this issue appear.
According to "README" file :
{
- Upgrade from 1.9.9 to 1.9.10
WARNING: if you are using a table prefix replace /*prefix*/ with your prefix
a) Execute install/sql/alter_tables/1.9.10/<your_db>/DB.1.9.10/step1/db_schema_update.sql
b) Execute install/sql/alter_tables/1.9.10/<your_db>/DB.1.9.10/stepZ/z_final_step.sql
}
should TWO sql files exists in install/sql/alter_tables/1.9.10/<your_db>/DB.1.9.10 . but actually NOT, only one file exist in 1.9.10 and 1.9.11 installation.
{
1.9.10:
[root@~]# ls -l testlink-1.9.10/install/sql/alter_tables/1.9.10/mysql/DB.1.9.10/
total 4
drwxrwxr-x 2 apache apache 4096 Apr 25 22:57 step1

1.9.11:
[root@~]# ls -l testlink-1.9.11/install/sql/alter_tables/1.9.10/mysql/DB.1.9.10/
total 4
drwxrwxr-x 2 apache apache 4096 Jul 29 02:28 step1
}

Whether missed file cause this issue ?

(0021649)
hwei (reporter)
2014-09-22 10:10

Download testlink-1.9.11.tar.gz again, don't find mysql patch file z_final_step.sql for 1.9.10.
(0021650)
fman (administrator)
2014-09-22 16:44

final step on 1.9.10 does not exist but is not responsible of this issue (IMHO)
(0021657)
hwei (reporter)
2014-09-23 08:59
edited on: 2014-09-23 09:01

>> 1. without your Database no action can be done <<
Dumped mysql DB from testlink 1.9.11.

User: admin1/admin1

Plz check attachment: testlink-1911-11.sql.tar.gz

(0021672)
hwei (reporter)
2014-09-26 09:56
edited on: 2014-09-28 01:25

this is not my DB date problem , it's testlink bug , tested on FRESH 1.9.11 and can reproduce it , the precondition is: at lease have two suites under one test project and each suite at least have one test case.

try create data and test on demo.testlink.org with test project "mySuite" , but it just LOADIND since click 'Apply' under 'Test Execution'

(0021673)
hwei (reporter)
2014-09-26 09:56

doubt this issue exist on 1.9.10 as well.
(0021676)
fman (administrator)
2014-09-26 15:57

Please provide stepo by steps to reproduce, starting from test project creation without this info, issue will be closed
(0021750)
hwei (reporter)
2014-09-28 02:20

the steps are:
1. Desktop -> "Test Project Management" -> Create new Test Project 'myProject"
2. Desktop -> "Test Specification" , Create three test suites 'mySuite001','mySuite002','mySuite003' under 'myProject'.
3. Create several test cases for each test suite(in my test: 4 testcases for mySuite001, 3 testcases for mySuite002, 1 testcases for mySuite003), the order is : 'mySuite001' in the top, 'mySuite002' in the middle, 'mySuite003' in the bottom.
  Check attachment (testlink-order.png) to see detail.
4. Desktop -> "Test Plan Management" -> Create new Plan "myPlan".
5. Desktop -> "Add/Remove Test Cases"-> Add all test cases under 'myProject' into 'myPlan'.
6. Desktop -> 'Builds/Releases' -> Create new Build "myBuild".
7. Desktop -> "Test Execution" :
    Select 'Test Plan' as 'myPlan'
    Select 'Build to execute' as 'myBuild'.
    Set 'Test Case Title' as 'abcdefg123456' in Filters.
    Click 'Apply', you can see the result is: result number is 0 and mySuite001 disappear , but "mySuite002" and "mySuite003" appear.
    check attachment (testlink-result.png) to see detail.


expected results:
  if filter result is 0 , user should NOT be able to view other test cases.
actual results:
   only first suite hide , user can see second suite and later suites , this will let use confuse and it's NOT precise?

- Issue History
Date Modified Username Field Change
2014-09-19 10:41 hwei New Issue
2014-09-19 10:42 hwei File Added: Screenshot-filters.png
2014-09-19 19:31 fman QA Team - Task Workflow Status => TBD
2014-09-19 19:31 fman Summary we can see all test cases after filtered even it show the number is 0 => MIGRATION ISSUE - we can see all test cases after filtered even it show the number is 0
2014-09-19 19:32 fman Note Added: 0021633
2014-09-19 19:32 fman Status new => feedback
2014-09-22 10:08 hwei Note Added: 0021648
2014-09-22 10:08 hwei Status feedback => new
2014-09-22 10:10 hwei Note Added: 0021649
2014-09-22 10:36 hwei Note Edited: 0021648 View Revisions
2014-09-22 16:44 fman Note Added: 0021650
2014-09-23 08:59 hwei Note Added: 0021657
2014-09-23 08:59 hwei Note Edited: 0021657 View Revisions
2014-09-23 09:01 hwei File Added: testlink-1911-11.sql.tar.gz
2014-09-23 09:01 hwei Note Edited: 0021657 View Revisions
2014-09-23 19:40 fman View Status public => private
2014-09-26 09:56 hwei Note Added: 0021672
2014-09-26 09:56 hwei Note Added: 0021673
2014-09-26 15:57 fman Note Added: 0021676
2014-09-28 01:25 hwei Note Edited: 0021672 View Revisions
2014-09-28 02:20 hwei Note Added: 0021750
2014-09-28 02:20 hwei File Added: testlink-order.png
2014-09-28 02:21 hwei File Added: testlink-result.png
2014-09-28 08:21 fman View Status private => public
2014-09-28 08:28 fman File Added: fman - test project.testproject-deep (1).xml
2014-09-28 15:39 fman Relationship added related to 0006612
2014-09-29 21:08 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-09-29 21:08 fman Status new => resolved
2014-09-29 21:08 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-09-29 21:08 fman Resolution open => fixed
2014-09-29 21:08 fman Assigned To => fman
2015-01-31 11:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker