Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006551TestLinkTest Specificationpublic2014-09-03 18:422014-09-27 16:42
Reportersmakai1 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0006551: (User cannot export Test Spec Document) Possibility to generate HTML DOC for a specific Test Suite
DescriptionIt looks like http://mantis.testlink.org/view.php?id=6138 [^] introduced the moving of the "Generate Test Specification Document" away from the main Project view and into the Test Specification view under the "Gear" options. When a user has the Project selected then they the test spec for ALL test suites can be generated but when a user selects a specific test suite the ability is export a test spec doc is no available. Please see attached screenshot.
Steps To Reproduce# Goto test spec
# select projects (top level of tree)
# Click "gear" or options in right side panel
* see that HTML of test spec doc can be generated

# goto test spec
# select a test suite, below top of tree)
# Click "gear" or options in right side panel
* see that HTML of test spec doc CANNOT be generated as the button does not exist
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserOpera, Chrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon CannotCreateTestSpecFromTestSuite.png [^] (46,719 bytes) 2014-09-03 18:42

- Relationships
child of 0006457closedfman Availables hot-fixes for 1.9.11 & How To get full fixed package from gitorious 

-  Notes
(0021555)
fman (administrator)
2014-09-03 21:10

- issue subject is misleading
- category changed to feature request
- export concept is wrong
(0021557)
smakai1 (reporter)
2014-09-04 02:06

- Not sure where the subject was misleading.. but ok
- fman, can you explain what is wrong about the export concept? You can say it is wrong but without saying what is correct the comment is of no use.

I have 1.9.9 running on another VM and with the previous functionality of the "Generate Test Specification Document" that was available from the Project view a test suite can be selected and the html, open office writer or ms word doc export can be accomplished. Am I missing how to do this with 1.9.11? To me is seems that I am getting reduced functionality from the previous version.
(0021560)
fman (administrator)
2014-09-04 06:08

subject is absolutely wrong because YOU CAN GENERATE Test Spec DOCUMENT for full test project.
What you can not do is generate TEST SPEC DOC for an specific Test Suite.
Then FEATURE IS NOT COMPLETELY BLOCKED.
You have provided this info inside the image when IMHO was important enough to be in subject.

export is wrong IMHO because you want a report, not something you export for later import. (at leat for me), but this can be discussion about similar context and finally have no value.
 

>> To me is seems that I am getting reduced functionality from the previous
>> version.
You are getting a redesigned feature, an because:
TestLink does not REALLY produce a WORD doc or Open Office document, but provided to the browser this illusion, we have lot of issues with images
(they can not be emmbeded but were LINKS) when this 'Pseudo Word' what shared with people that have no direct access to testlink server.
Choice has been => System will give you exactly what it has promised => an HTML Output.
Do not think it's a great problem get this HTML and open it on WORD to change it if this is what you need.
I normaly use this output to share a PRINTED version with a client
(0021561)
smakai1 (reporter)
2014-09-04 06:42
edited on: 2014-09-04 06:43

I'm sorry fman, my terminology is not correct in regards to the functionality provided. Export was the wrong term and specification of the specific inability of report generation was lacking, I should have mentioned _report_ of Test SUITE instead of 'export of test spec document'.

I don't care about the report in ms word or open office document as you don't care if people need it or not as WORD can open it and then EXPORT to the format they would want. I just care about being able to produce a REPORT of a TEST SUITE the same as I was able to in 1.9.9. Redesigned feature or a feature request, I don't care. It is functionality I was expecting and now is not available in 1.9.11. At least it is free and the main developer is passionate about the project.
Thank you fman

(0021571)
fman (administrator)
2014-09-06 13:36

https://gitorious.org/testlink-ga/testlink-code/commit/bb29c65f2965dd9b21fd153ef0d65946e598b5f3 [^]
(0021713)
fman (administrator)
2014-09-27 16:42

Release done

- Issue History
Date Modified Username Field Change
2014-09-03 18:42 smakai1 New Issue
2014-09-03 18:42 smakai1 File Added: CannotCreateTestSpecFromTestSuite.png
2014-09-03 21:10 fman Note Added: 0021555
2014-09-03 21:12 fman QA Team - Task Workflow Status => TBD
2014-09-03 21:12 fman Severity tweak => feature request
2014-09-03 21:12 fman Summary User cannot export Test Spec Document => (User cannot export Test Spec Document) Possibility to generate HTML DOC for a specific Test Suite
2014-09-04 02:06 smakai1 Note Added: 0021557
2014-09-04 06:08 fman Note Added: 0021560
2014-09-04 06:42 smakai1 Note Added: 0021561
2014-09-04 06:43 smakai1 Note Edited: 0021561 View Revisions
2014-09-06 13:36 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-09-06 13:36 fman Note Added: 0021571
2014-09-06 13:36 fman Status new => resolved
2014-09-06 13:36 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-09-06 13:36 fman Resolution open => fixed
2014-09-06 13:36 fman Assigned To => fman
2014-09-06 13:38 fman Relationship added child of 0006457
2014-09-27 16:42 fman Note Added: 0021713
2014-09-27 16:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker