Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006547TestLinkNew Featurepublic2014-09-02 08:182014-09-27 16:42
Reporterfrancesco_v 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0006547: Automatically add comment to issue report when link a test execution to a issue
DescriptionIn test execution the execution history provides ability to link a issue in issue tracker or create a new one.
Create a new issue ("Create Issue" button) write in a new issue a detailed explanation of detected bug; linking to an existing issue don't write nothing.

When I link a execution result to an existing issue would be nice if a checkbox permit to add automatically a comment with detailed explanation of selected bug (and a explained link to execution result - http://mantis.testlink.org/view.php?id=6546 [^])
Tagsissue tracking
Database (MySQL,Postgres,etc)mariadb
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006557closedfman Mantis SOAP - addNote() method 
related to 0006562closedfman Redmine REST Integration - Possibility to ADD notes to issues on Redmine from TestLink 
parent of 0006560closedfman Mantis SOAP Integration - Possibility to ADD notes to issues on Mantis from TestLink 

-  Notes
(0021538)
fman (administrator)
2014-09-02 18:12

Please provide detailed use case in order
To understand better the requirement and
Proposed usability.
Detail what is the problem with current implementation.
(0021542)
francesco_v (reporter)
2014-09-03 07:08

Now we use Redmine to track new features and for every one we write required test cases.
When we found a bug in feature implementation we prefer to reopen issue instead creates a new one (to maintain traceability and clean changelog), so we write bug detail in test case execution (TestLink) and issue (Redmine), almost same information (double work).
TestLink create a detailed summary of test execution but only for new issue, existing one don't have any information about.

An useful implementation for "add issue" button may be:
[issue number] not really comfortable but works!
[issue comment] a text field for adding comment directly
[add execution detail] a check box to append in comment the text as "new issue" button

If user compiles form then TestLink append to issue:
TestLink user Eva as wrote:
[issue comment]
----------------------
[Execution detail]
[Possibly direct link to execution report]

Thanks
(0021551)
fman (administrator)
2014-09-03 17:28

1.
>>.. so we write bug detail in test case execution (TestLink) and issue >>(Redmine), almost same information (double work).

this is your process, but that is probably the problem.
Avoiding double work is the point, and IMHO this has to be done, adding info ONLY to REDMINE and nothing on Testlink.
But I suppose you have good reasons to mantain it.

1. current link issue feature can not be used as is because do not interact on WRITE mode with issue tracker system.

2. What can be done IMHO is feature like this:
2.1. user wants to add an execution note and that same note as NEW note on an issue.

2.2 a checkbox is present in the screen area where exec result is choosen
'Add execution note to issue'

2.3 User can select ONE or more issues from ssue list present on execution history using a checkbox is added to allow select and issue.


This is what I've understood (unfortunately your explanations are not clear enough for me).
(0021562)
francesco_v (reporter)
2014-09-04 08:25

I'm sorry for my poor english.

We studied our process in that way because:
- TestLink execution report is really useful, write it manually on Redmine every fail may be harder.
- Detail test execution in TestLink is simple and user friendly, and link it on Redmine is easy: we need to link issue to test execution (this is not present for existing issue).
- Write everything manually in Redmine is time-wasting because we would need to report info on build for example that Testlink already do.

Your option n.2 is actually faster on second test execution, but miss in case of first test execution (when execution history is empty) or when is necessary create a new issue (because old one is closed). In that case it would be useful a checkbox in the "Link Existent Issue" in order to choose if add the execution note to the linked issue or not (as I think some other team may not want to follow that process).

Thank you very much
(0021683)
fman (administrator)
2014-09-27 16:42

Release done

- Issue History
Date Modified Username Field Change
2014-09-02 08:18 francesco_v New Issue
2014-09-02 18:12 fman Note Added: 0021538
2014-09-02 18:13 fman Assigned To => fman
2014-09-02 18:13 fman Status new => feedback
2014-09-03 07:08 francesco_v Note Added: 0021542
2014-09-03 07:08 francesco_v Status feedback => assigned
2014-09-03 12:46 fman QA Team - Task Workflow Status => TBD
2014-09-03 12:46 fman Product Version => 1.9.11 (2014 Q2 - bug fixing)
2014-09-03 12:50 francesco_v Tag Attached: issue tracking
2014-09-03 17:28 fman Note Added: 0021551
2014-09-04 08:25 francesco_v Note Added: 0021562
2014-09-07 17:05 fman Relationship added related to 0006557
2014-09-08 10:57 fman Relationship added parent of 0006560
2014-09-08 14:19 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-09-08 14:33 fman Relationship added related to 0006562
2014-09-27 15:09 fman Status assigned => resolved
2014-09-27 15:09 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-09-27 15:09 fman Resolution open => fixed
2014-09-27 16:42 fman Note Added: 0021683
2014-09-27 16:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker