Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006534TestLinkUsers and Rightspublic2014-08-26 13:102014-12-31 14:22
Reportermbar 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows 7OSOS Version
Product Version 
Fixed in Version1.9.13 (2015 #1) 
Summary0006534: 1.9.12 DEV -- User with 'admin' rights cannot do Test Plan Management
DescriptionCreate a new project. Or simply select one from the list.
Then, if your user is [admin], click on the 'Test Plan Management' link on the right pane. You will get the message:

'Fatal error: Call to a member function hasRight() on a non-object in /var/www/html/testlink-1.9.5/lib/plan/planView.php on line 63
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.5.16
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006620closedfman Test Plan Management does not work 

-  Notes
(0021572)
fman (administrator)
2014-09-06 13:39

Please get latest code from gitorious, retest and provide feedback.
If issue persists please provided detailed steps to reproduce
(0021574)
mbar (reporter)
2014-09-06 14:19

I just downloaded newest trunk from git.
Unfortunately it did not help me (the update is in trunk, am I right?).

Maybe something is wrong with my user / email combination. As I am the person that introduced TesLink in my company, I have two accounts with same name / email, but different logins:
'admin' (system account) authenticated by DB
'mba' authenticated by LDAP

Both accounts have same role 'admin'. Both have same Name / Surname (Marek Bartosiewicz) and email marek.bartosiewicz@mycompany

Can this be of some help?

Everything was OK up to some update during 1.9.12 DEV cycle.
(0021575)
fman (administrator)
2014-09-06 14:58

Trunk is not a git concept.
You need to get latest commit on branch 1.9
using this (on unix/linix)
wget http://gitorious.org/testlink-ga/testlink-code/archive-tarball/testlink_1_9 [^]

you will get a tarball with latest code.

>> Maybe something is wrong with my user / email combination
do not think.

Please follow kindly request:
If issue persists please provided detailed steps to reproduce

if you do not do this, then I can not work, because I'm not sure I'm using same scenario.
Give a look to forum.testlink.org if you need to understand level of details requested.
(0021576)
mbar (reporter)
2014-09-06 15:43
edited on: 2014-09-06 15:47

Sorry for my misleading 'trunk' comment.
Of course
wget http://gitorious.org/testlink-ga/testlink-code/archive-tarball/testlink_1_9 [^]
was what I did.
And it didn't help. On our system it takes only one click to reproduce the problem: the click on 'Test Plan Management' link on the right pane.
I also noticed that 'admin' role in the user management hasn't all the options checked and all of them are grayed out making them impossible to enable. I don't remember if this is normal.
I'll check other 'admin' users if they have the same problem in my company on Monday.
'Leaders' do not experience the problem.

(0021577)
fman (administrator)
2014-09-06 17:49

From my point of view is very annoying asking again and again for detailed steps to reproduce and received this answer:
>> On our system it takes only one click to reproduce the problem: the click on >> 'Test Plan Management' link on the right pane.

Then you do not leave me other option that to be rude and say:
I will ignore this issue closing it , till I've time to test by myself.
I will close with reason: unfortunatelly user did not provide requested information.

Please do not reopen this issue or you will force me to delete it.
(0021578)
fman (administrator)
2014-09-06 17:49

unfortunately after several requests, user was not able to provide requested information to reproduce issue.
(0021656)
mbar (reporter)
2014-09-23 07:08

I'm not sure if this is the same problem, or a different one.
For now I'll not create a new issue -- if you want, I'll do so.

Please log in to demo.testlink.org as "admin / admin" and do the following:

- select the project "DEMO CODE UPDATED 20140921"
- click "Test Plan Management"
- you'll see blank (white) page.

You can also do:

- select the project "441:Test_testlink"
- click "Test Plan Management"
- you'll see blank (white) page.

Other projects do not experience the problem, maybe there is some trouble with the database and not the application code?
(0021658)
fman (administrator)
2014-09-23 09:24

>> (I'm not sure if this is the same problem, or a different one.
>> For now I'll not create a new issue -- if you want, I'll do so.
Yes please open a new issue.
(0021760)
mbar (reporter)
2014-09-29 10:28

I might have the steps to reproduce the problem -- in the demo Testlink.

- login as admin
- create a new project
- create a new test plan (by clicking Test Plan Management), call it "first" set it active, public
- return to main page
- create a new test plan (by clicking Test Plan Management), call it "second" set it active, public
- return to main Test Link page
- click Test Plan Management -- you'll get blank page
(0021761)
mbar (reporter)
2014-09-29 10:32

On my testlink installation we have PHP errors enabled, hence "Call to a member function hasRight() on a non-object in /var/www/html/testlink-1.9.5/lib/plan/planView.php on line 68" message.
after upgrading to 1.9.12

I did some "debugging" and this is the line:

$gui->tplans[$idk]['rights'][$target] = $roleObj->hasRight($target);

but the problem seems to be earlier, at the line:

$roleObj = &$args->user->globalRole;


in project that have more than one test plan (in our database), roleObj looks like this:
(0021763)
mbar (reporter)
2014-09-29 10:33

object(tlRole)0000095 (14) { ["name"]=> string(5) "admin" ["description"]=> string(0) "" ["rights"]=> array(46) { [0]=> object(tlRight)0000097 (10) { ["name"]=> string(16) "testplan_execute" ["activateCaching":protected]=> bool(true) ["dbID"]=> string(1) "1" ["detailLevel":protected]=> int(4294967295) ["objectID":protected]=> string(22) "5429309f7cfe6201585189" ["userFeedback":protected]=> NULL ["serializationInterfaces":protected]=> NULL ["serializationFormatDescriptors":protected]=> NULL ["tables":protected]=> array(55) { ["assignment_status"]=> string(17) "assignment_status" ["assignment_types"]=> string(16) "assignment_types" ["attachments"]=> string(11) "attachments" ["builds"]=> string(6) "builds" ["cfield_build_design_values"]=> string(26) "cfield_build_design_values" ["cfield_design_values"]=> string(20) "cfield_design_values" ["cfield_execution_values"]=> string(23) "cfield_execution_values" ["cfield_node_types"]=> string(17) "cfield_node_types"

[some dump deleted here]

 "req_revisions" ["rights"]=> string(6) "rights" ["risk_assignments"]=> string(16) "risk_assignments" ["role_rights"]=> string(11) "role_rights" ["roles"]=> string(5) "roles" ["testcase_relations"]=> string(18) "testcase_relations" ["tcversions"]=> string(10) "tcversions" ["tcsteps"]=> string(7) "tcsteps" ["testcase_keywords"]=> string(17) "testcase_keywords" ["testplan_platforms"]=> string(18) "testplan_platforms" ["testplan_tcversions"]=> string(19) "testplan_tcversions" ["testplans"]=> string(9) "testplans" ["testprojects"]=> string(12) "testprojects" ["testsuites"]=> string(10) "testsuites" ["text_templates"]=> string(14) "text_templates" ["transactions"]=> string(12) "transactions" ["user_assignments"]=> string(16) "user_assignments" ["user_group"]=> string(10) "user_group" ["user_group_assign"]=> string(17) "user_group_assign" ["user_testplan_roles"]=> string(19) "user_testplan_roles" ["user_testproject_roles"]=> string(22) "user_testproject_roles" ["users"]=> string(5) "users" } ["views":protected]=> array(3) { ["tcversions_last_active"]=> string(22) "tcversions_last_active" ["last_executions"]=> string(15) "last_executions" ["last_executions_by_platforms"]=> string(28) "last_executions_by_platforms" } } NULL
(0021764)
mbar (reporter)
2014-09-29 10:35
edited on: 2014-09-29 10:35

It seems the last NULL points to the second test plan, but is taken from the global role?

The workaround for me is to set the explicit roles for any test plan for admins and leaders within any test project. Then it works OK, instead of the second NULL I have a "normal" object(tlRole).

(0021775)
fman (administrator)
2014-09-29 21:38

https://gitorious.org/testlink-ga/testlink-code/commit/2aa48a4dfa9206a9f044e767bb91b3a0001f7dac [^]
(0021778)
mbar (reporter)
2014-09-30 05:38

Yes, it helped, thanks!
(0022137)
pkhooper (reporter)
2014-11-14 02:25

We also saw this problem in TestLink 1.9.12.

We have applied this patch.

The patch fixed the issue.

- Issue History
Date Modified Username Field Change
2014-08-26 13:10 mbar New Issue
2014-08-26 14:30 fman QA Team - Task Workflow Status => TBD
2014-08-26 14:30 fman Product Version 1.9.11 (2014 Q2 - bug fixing) =>
2014-09-06 13:39 fman Note Added: 0021572
2014-09-06 13:40 fman Assigned To => fman
2014-09-06 13:40 fman Status new => feedback
2014-09-06 14:19 mbar Note Added: 0021574
2014-09-06 14:19 mbar Status feedback => assigned
2014-09-06 14:58 fman Note Added: 0021575
2014-09-06 14:59 fman Status assigned => feedback
2014-09-06 15:43 mbar Note Added: 0021576
2014-09-06 15:43 mbar Status feedback => assigned
2014-09-06 15:47 mbar Note Edited: 0021576 View Revisions
2014-09-06 17:49 fman Note Added: 0021577
2014-09-06 17:49 fman Note Added: 0021578
2014-09-06 17:49 fman Status assigned => closed
2014-09-06 17:49 fman Resolution open => unable to reproduce
2014-09-23 07:08 mbar Note Added: 0021656
2014-09-23 07:08 mbar Status closed => assigned
2014-09-23 07:08 mbar Resolution unable to reproduce => reopened
2014-09-23 09:24 fman Note Added: 0021658
2014-09-23 09:24 fman Status assigned => closed
2014-09-23 09:24 fman Resolution reopened => fixed
2014-09-29 10:28 mbar Note Added: 0021760
2014-09-29 10:28 mbar Status closed => assigned
2014-09-29 10:28 mbar Resolution fixed => reopened
2014-09-29 10:32 mbar Note Added: 0021761
2014-09-29 10:32 mbar Note Added: 0021762
2014-09-29 10:32 mbar Note Deleted: 0021762
2014-09-29 10:33 mbar Note Added: 0021763
2014-09-29 10:35 mbar Note Added: 0021764
2014-09-29 10:35 mbar Note Edited: 0021764 View Revisions
2014-09-29 21:38 fman Note Added: 0021775
2014-09-29 21:39 fman Relationship added related to 0006620
2014-09-29 21:46 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-09-29 21:46 fman Status assigned => resolved
2014-09-29 21:46 fman Fixed in Version => 1.9.13 (2015 #1)
2014-09-29 21:46 fman Resolution reopened => fixed
2014-09-30 05:38 mbar Note Added: 0021778
2014-11-14 02:25 pkhooper Note Added: 0022137
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker