Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006527TestLinkUsers and Rightspublic2014-08-21 07:302015-06-30 05:34
Reportermokalstudio 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version 
Summary0006527: user group feature
Descriptionthere has "user_group" table in db but user group feature is missing. Now the user management feature can't work fine when has many user.

I think user group feature is needed.
if support this user manage module will pretty good,i think.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysl5
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
duplicate of 0005305new Contribution - User Groups 
related to 0001329closedfman Create/Assign to User Groups 
related to 0001199closedfman integration of user groups 
related to 0001081closedfman Field in user data containing one's department 

-  Notes
(0021498)
mokalstudio (reporter)
2014-08-21 07:39

some detailed description:
-user can belong to one or more group.
-group can define project and testplan role
-users will has same project/testplan role which its group have
-of course, user can define project/testplan role separate.
-when group role and user role conflicted, all rights define in two role allowed for this user.
(0021499)
fman (administrator)
2014-08-21 07:44

1. it would be great always to do some search for duplicates before posting (0005305)

2. is it not clear what is the REAL use case.
save time doing what ?

3. Now the user management feature can't work fine when has many user.
can you explain in details what do you mean for :
can't work fine ?
(0023161)
Mr.Bricodage (updater)
2015-04-26 15:50

should be closed (duplicated with 0005305 that provide contribution)

- Issue History
Date Modified Username Field Change
2014-08-21 07:30 mokalstudio New Issue
2014-08-21 07:39 mokalstudio Note Added: 0021498
2014-08-21 07:44 fman Note Added: 0021499
2014-08-21 07:45 fman QA Team - Task Workflow Status => TBD
2014-08-21 07:45 fman Summary user group feature missing, can add this? => user group feature
2014-08-21 07:46 fman Relationship added related to 0005305
2014-08-21 07:48 fman Relationship added related to 0001329
2014-08-21 07:49 fman Relationship added related to 0001199
2015-04-26 15:48 Mr.Bricodage Relationship added related to 0001081
2015-04-26 15:50 Mr.Bricodage Note Added: 0023161
2015-06-30 05:33 fman Relationship replaced duplicate of 0005305
2015-06-30 05:33 fman Status new => resolved
2015-06-30 05:33 fman Resolution open => duplicate
2015-06-30 05:33 fman Assigned To => fman
2015-06-30 05:34 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker