Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006473TestLinkRequirements Import - TL XML formatpublic2014-08-07 01:172014-09-27 16:43
Reporterhitek_kirilova 
Assigned Tofman 
PrioritynormalSeveritytextReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0006473: Confusing message appears while using Import under Requirements
DescriptionActual Result: Confusing message appears

Expected Result: The warning message should describe the problem
Steps To Reproduce1. Login to TestLink as admin
2. Go to Requirements
3. Click Import button
4. Browse and choose file (pls find under Upload File)
5. Click Upload File
6. Warning message containing only 'OK' appears
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filescsv file icon Matrix for Add Customer.csv [^] (2,401 bytes) 2014-08-07 01:17
png file icon Aug 6.PNG [^] (66,076 bytes) 2014-08-07 01:18

- Relationships
child of 0006457closedfman Availables hot-fixes for 1.9.11 & How To get full fixed package from gitorious 

-  Notes
(0021391)
fman (administrator)
2014-08-07 05:39

>> Expected Result: The warning message should describe the problem
what is the message that has to appear?
you can not expect (if you ever have done a development) that if you try to load garbage the system will provide a good messafe

IMHO this king of testing is USELESS, because is focusing in worhtless aspects of the product.

Issue description also is poor because you do not explain that you are using a file that does not has the required format, but you are requesting the developer to open the file to understand this
(0021392)
hitek_kirilova (reporter)
2014-08-07 06:15

As I user, not as a developer, the msg that tells me that I try to upload GARBAGE is better than 'OK'
OK what, OK wrong file, OK the system doesn't working?!?
Of course this is only MHO, but is your choice is the platform is going to be User friendly or not.
(0021395)
fman (administrator)
2014-08-07 13:55

What you have to do as user/tester is provide clear steps to reproduce
thing that you have not done.
Also you can provide a suggestion of msg to display
In addition I repeat because you are done a work as tester you need to focus in important things not this silly things
(0021407)
fman (administrator)
2014-08-08 20:11

https://gitorious.org/testlink-ga/testlink-code/commit/e261ac19148ec4c6e92f3a47db1aa47399687f67 [^]
(0021741)
fman (administrator)
2014-09-27 16:43

Release done

- Issue History
Date Modified Username Field Change
2014-08-07 01:17 hitek_kirilova New Issue
2014-08-07 01:17 hitek_kirilova File Added: Matrix for Add Customer.csv
2014-08-07 01:18 hitek_kirilova File Added: Aug 6.PNG
2014-08-07 05:39 fman Note Added: 0021391
2014-08-07 06:15 hitek_kirilova Note Added: 0021392
2014-08-07 13:55 fman Note Added: 0021395
2014-08-08 20:11 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-08-08 20:11 fman Note Added: 0021407
2014-08-08 20:11 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-08-08 20:11 fman Status new => resolved
2014-08-08 20:11 fman Resolution open => fixed
2014-08-08 20:11 fman Assigned To => fman
2014-08-08 20:11 fman Relationship added child of 0006457
2014-09-27 16:43 fman Note Added: 0021741
2014-09-27 16:43 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker