Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006444TestLinkAPI - XMLRPCpublic2014-07-23 12:252014-07-28 20:31
Reporterfoxcris 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.11 (2014 Q2 - bug fixing) 
Summary0006444: Extend API - XMLRPC function "getLastExecutionResult" to return also the linked bug ids
DescriptionWith the function getLastExecutionResult the last execution status of an testcase can be requested via the XMLRPC. This function currently does not report the bugids which have been attached during the executions. The attached path adds this feature.
Additional InformationThe attached patch has been created agains the current brach testlink_1_9. Timestamp: 2014-07-23 14:00
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespatch file icon testlink-code.patch [^] (1,642 bytes) 2014-07-23 12:25 [Show Content]
patch file icon testlink-code_v2.patch [^] (3,257 bytes) 2014-07-24 05:59 [Show Content]
png file icon Screenshot - 07252014 - 08:31:08 PM.png [^] (25,110 bytes) 2014-07-25 18:31

- Relationships
child of 0006313closedfman Availables hot-fixes for 1.9.10 & How To get full fixed package from gitorious 

-  Notes
(0021294)
fman (administrator)
2014-07-23 17:19

Thanks for your contribution
A option is need to allow user to get or not BUGS.
(0021297)
foxcris (reporter)
2014-07-24 06:02

Attached you can find v2 of the patch.
As proposed I added an option "listbugids" to configure the behaviour of "getLastExecutionResult".

   * @param int $args["listbugids"] - optional
   * if set to "all" the bugids of all executions are returned
   * if set to "latest" only bug ids linked with the latest execution are returned
(0021298)
fman (administrator)
2014-07-24 14:42
edited on: 2014-07-24 14:42

will see if a better name can be used
option for DO NOT GET bugs is also needed

(0021301)
fman (administrator)
2014-07-24 21:19

patch2 is rejected.
function has to return only bugs related to last execution because this is method scope.
(0021302)
foxcris (reporter)
2014-07-25 04:51

I now the scope is the last execution. However what a user(in this case me) wants to retrieve is the latest state of the testcase (passed,failed ...) and all bug ids. All bug ids are required as during testing the tester is not entering all the bug ids again on each execution.
For example you have a test which has failed on the first build. The tester has assigned a bug id to this execution. The next time the test is executed the test still fails. As the bug was already linked, the tester is not entering it again. Thats what is my experience. Thus I think all bug ids belong the the latest execution depending on the workflow which is used for testing.

However if you do not want introduce also an option to get all bug ids of all executions with the function "getLastExecutionResult" i would propose to create a new function "getAllBugIDs(testplanname, testcase)". Is that ok for you? I would rework the patch then. Additionally I would change introduced option "listbugids" for "getLastExecutionResult" to be a boolean value. Thus someone can explicitly decide to get the bugids or not. Default value would be to not retrieve the bug ids (no change to the behaviour before).
(0021303)
fman (administrator)
2014-07-25 12:38

>> "getAllBugIDs(testplanname, testcase)". Is that ok for you?
more or less but is a better solution
provide code and I will review and refactor it as needed
(0021304)
fman (administrator)
2014-07-25 18:38

https://gitorious.org/testlink-ga/testlink-code/commit/83d008016816311b0d189bc1b1eab6e9da359010 [^]

- Issue History
Date Modified Username Field Change
2014-07-23 12:25 foxcris New Issue
2014-07-23 12:25 foxcris File Added: testlink-code.patch
2014-07-23 17:19 fman Note Added: 0021294
2014-07-24 05:59 foxcris File Added: testlink-code_v2.patch
2014-07-24 06:02 foxcris Note Added: 0021297
2014-07-24 14:42 fman Note Added: 0021298
2014-07-24 14:42 fman Note Edited: 0021298 View Revisions
2014-07-24 21:19 fman Note Added: 0021301
2014-07-24 21:37 fman Assigned To => fman
2014-07-24 21:37 fman Status new => assigned
2014-07-25 04:51 foxcris Note Added: 0021302
2014-07-25 12:38 fman Note Added: 0021303
2014-07-25 18:31 fman File Added: Screenshot - 07252014 - 08:31:08 PM.png
2014-07-25 18:38 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-07-25 18:38 fman Note Added: 0021304
2014-07-25 18:38 fman Status assigned => resolved
2014-07-25 18:38 fman Fixed in Version => 1.9.11 (2014 Q2 - bug fixing)
2014-07-25 18:38 fman Resolution open => fixed
2014-07-25 18:38 fman Product Version => 1.9.10 (2014 Q1 - bug fixing)
2014-07-25 18:38 fman Relationship added child of 0006313
2014-07-28 20:31 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker